You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, October 7th 2014, 1:20pm

[bug?] IE11 html5 embedding __definegetter__ not supported

Hi,

It seems there is a bug in krpano 1.17.5, when trying to use WebGL (html5 = always) when using Internet Explorer 11.

In the function embedhtml5() IE11 gives the error: Object doesn't support property or method '__definegetter__'. When looking up the __definegetter__ method on MDN , it seems this function is deprecated and non standard and is not recommended to be used in any software. Possibly IE11 has dropped support for it, but I don't understand why there has been no mention of this bug before on the forums.

Best regards,

Laurens

2

Tuesday, October 7th 2014, 1:30pm

Hi,

you can please show your example?
I can't see such bug in IE11 or any other IE version.

Are there other scripts involved?

The krpano HTML5 viewer implements the __defineGetter__ and __defineSetter__ functions by its own when they are not supported by the browser (like this is the case in IE).

Best regards,
Klaus

3

Tuesday, October 7th 2014, 1:57pm

Hi Klaus,
On www.viadrupsteen.nl/test/ you can find an example.

I have used the new Krpano Tools to license the swf and embed the embedding script.

Yes there are many other scripts involved. Perhaps they are conflicting, indeed.

Best regards,

Laurens

4

Tuesday, October 7th 2014, 2:24pm

Hi,

the problem is that you are forcing the IE to behave as IE8 - see this line in your html:

Source code

1
<meta http-equiv="x-ua-compatible" content="IE=8" />

but the problem - the IE8 doesn't support any 'HTML5'!

Basically this would be no problem, the krpano embedding script would choose Flash in this case, but now you are also forcing the usage of the HTML5 viewer by using html5=always - and this is the result - trying to use HTML5 in IE8 - and this can't work.

That means there is no bug - either remove that 'x-ua-compatible' setting or increase it to IE=11.
Additionally the html5=always setting should be removed or replaced. The setting html5=always should be used only for internal testing, when only html5 should be used, the use html5=only - see here:

http://krpano.com/docu/html/#html5

Best regards,
Klaus

5

Tuesday, October 7th 2014, 3:24pm

Hi Klaus,

Thank you. Indeed I was only testing to see whether IE11 was working with WebGL. Good call on the IE8 document mode. This is because some of the HTML and CSS was not behaving correctly when not setting this. But that is not your problem! Thanks again.

Best regards,

Laurens