You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

1

Sunday, November 9th 2014, 4:28pm

mapspot over radar googlemaps

Hi,

i have a problem getting the 'custom' mapspot on top of the radar with the googlemaps plugin.

example 1:
http://www.virtualtuur.com/krpano/maps/1/
http://www.virtualtuur.com/krpano/maps/1/tour.xml

default mapspot works fine
EDIT:mmmm there also it seems the radar is on top of the mapspot... (?)

http://www.virtualtuur.com/krpano/maps/2/
http://www.virtualtuur.com/krpano/maps/2/tour.xml

can't get it.

any suggestions?

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Alexey Tkachenko

Professional

Posts: 757

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

2

Sunday, November 9th 2014, 4:56pm

Hi!

Yes, in both examples radar is on top of the spot (checked in Chrome desktop). See the attached prinscreens.

What about zorder of radar and spot?
Alexey Tkachenko has attached the following images:
  • 1.jpg
  • 2.jpg
Regards,

Alexey

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

3

Sunday, November 9th 2014, 4:58pm

yes i see myself as well ;-)
makes no difference when i set any zorder.
i did in example 2 now

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

4

Monday, November 10th 2014, 2:06pm

is this a bug?

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

5

Tuesday, November 11th 2014, 2:57pm

Can anybody show me a bare bone example that puts the mapspot on top of the radar with googlsmaps plugin?
Bingmap could also be an option.

Thanks in advance!

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

Umalo

Professional

Posts: 1,047

Location: Osijek, Croatia, EU

  • Send private message

7

Wednesday, November 12th 2014, 7:23pm

Never used google maps but tried now and result is the same. Do you have any specefic reason forcing solution with google maps specialy with this new things related to keys.
maybe with radar as separate layer plugin and some tweaks you could get radar looks like below active point. Just idea...

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

8

Wednesday, November 12th 2014, 7:26pm

I tried a lot already.
Show me a working example.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Umalo

Professional

Posts: 1,047

Location: Osijek, Croatia, EU

  • Send private message

9

Thursday, November 13th 2014, 12:57am

hm it doesn't work. What about following workaround: make radar of the same color as your spot is and just make it more transparent:


Source code

1
<radar visible="true" size="100" alpha="0.4" fillcolor="0x006ed9" fillalpha="1" linecolor="0x00FF00" linealpha="0.0" linewidth="0.0" dragable="true" headingoffset="0"/>

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

10

Thursday, November 13th 2014, 9:32am

Hahaha
Very creative!
But my plan was 'slightly' different. Haha

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

11

Monday, November 17th 2014, 1:24pm

Hi,

the reason for the problem was that Google had changed the Google Maps API.
This will be fixed in krpano version 1.18.1.

Best regards,
Klaus

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

12

Tuesday, November 18th 2014, 10:21am

Thanks Klaus!
Good to know.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Umalo

Professional

Posts: 1,047

Location: Osijek, Croatia, EU

  • Send private message

13

Friday, November 21st 2014, 5:56pm

http://krpano.com/news/#releasenotes1181
"Fix: The radar was above the map spots."
Is it ok now?

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

14

Friday, November 21st 2014, 6:23pm

I suppose yes.
I will update the example to show... Tomorrow.
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

15

Saturday, November 22nd 2014, 12:42pm

mmm...
updated but not good yet?
http://www.virtualtuur.com/krpano/maps/4/


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
<krpano version="1.18" bgcolor="0x000000" logkey="true" onstart="startup();" >

<action name="startup">
	loadscene(scene_1,null,MERGE,BLEND(0.5));
</action>

	<scene name="scene_1" title="a1" onstart=""  >
		<preview type="grid(cube,16,16,512,0xCCCCCC,0x666666,0x999999);" details="16" />
		<view hlookat="0" />
	</scene>
	

<layer name="mapcontainer" keep="true" type="container" bgcolor="0xFFFFFF" bgalpha="0.5" align="leftbottom" x="5" y="5" width="270" height="370">

<plugin name="map" keep="true" url="../plugins/googlemaps.swf" alturl="../plugins/googlemaps.js" align="lefttop" x="10" y="10" width="250" height="350" key="An4-9WoANqtASVorNezSjENest2VC0zoAzvMhEpdTjb3uY-k6u6bMkPxYpDsolsF" maptype="SATELLITE" lat="41.898761" lng="12.473094" zoom="18">
	<radar visible="true" size="300" alpha="0.33" fillcolor="0xFFFFFF" fillalpha="1.0" linecolor="0x00FF00" linealpha="0.5" linewidth="0.5" dragable="true" headingoffset="0"/>
	<spot name="spot1" url="mapspot.png" lat="41.898761" lng="12.473094" heading="0" active="true" activeurl="mapspot.png"  />
</plugin>
</layer>
	
</krpano>


i also experience some turning of the sphere also when i already stop using the mouse.. (safari)

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

16

Monday, November 24th 2014, 8:36am

Hi,

this was definitely working, but unfortunately only for a short-time...

Google has just removed the older 3.16 version of the Google Maps API:
https://groups.google.com/forum/#!topic/…ify/-GqD0WKdYnM

But this was the API version that the krpano Google Maps plugin was requesting, because in the newer API versions the 'layering' was changed and that in a way that doesn't allow adding interactive elements (like the radar) behind the map spots. Additionally I wasn't aware that Google is removing old API versions.

Finding now workarounds and hacks for the new Google Maps API to get the Google Maps plugin fully working as it should might take more time now...

Best regards,
Klaus

Tuur

Sage

  • "Tuur" started this thread

Posts: 3,169

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

17

Monday, November 24th 2014, 10:19am

Hi Klaus,
Ok, that is clear, and a pitty.
Thanks for the explenation.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

18

Wednesday, December 10th 2014, 11:23am

Hi,

this will be fixed in the next release (1.18.2).

Best regards,
Klaus

Similar threads