You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, December 22nd 2014, 2:55pm

Nadir Logo appears in screen at ath=0

Hi Klaus,

something strange:
If I have an embeded nadir logo and if I rotate the pano slowly, the logo is shown for a short time on the lefttop of the screen near ath=0
(only HTML5 in FF V.34, Flash is fine, WIN 8, krpano 1.18)
This happens only, if I look near atv=0 and rotate slowly, if you rotate fast you won`t see it! same with autorotate...

I had a look at your example, http://krpano.com/examples/118/examples/…nadir-logo.html , same result...

Any ideas?

Thanks for help, thanks for all your work and merry x-mas;-)
Steve

2

Tuesday, December 23rd 2014, 9:03am

Hi,

that's a CSS3D rendering bug of newer Firefox versions...

The CSS3D support from severals browsers are unfortunately getting worse and worse - Firefox and Chrome have both bad and buggy CSS3D rendering. Luckily both browsers are supporting WebGL, which is currently used only for the pano display itself.

But I'm already working on rendering image hotspots also via WebGL to avoid CSS3D as much as possible. WebGL is a real graphics API, there the browsers can't do such things.

Best regards,
Klaus

3

Wednesday, December 24th 2014, 2:31am

Ahh, ok, thanks... I thought I´ve seen the bug in Chrome too, but testing that situation the logo didn´t appear...

Sounds good to render the HS-Images in WebGL...little but annoying CSS-3D bug...

Good luck..;-)

4

Wednesday, January 14th 2015, 10:23am

Hi,

damm, even with the newest Version 35 of FF the problem still appears... *cry*

Steve

5

Monday, January 26th 2015, 7:19am

+1. Latest Firefox, latest Krpano (18.2).

https://www.youtube.com/watch?v=JJMn8kyE7JI


Video is unlisted, not searchable.

Are there any workarounds at this point in time?

Thank you.

6

Monday, January 26th 2015, 1:24pm

Hi,

please see above - that's a Firefox CSS3D bug - fixing it itself isn't possible from krpano side - ony Mozilla could do fixes here (but regarding to the history of browser CSS3D bugs I don't expect anything soon).

But for krpano version 1.19 I'm working on rendering distorted hotspots by WebGL. That means in this case krpano will control almost everything about the rendering and not the browser as it is now with CSS3D.

As workaround these solution would be possible:
  • Don't use distorted hotspots in Firefox - e.g. use a simpler zoom=true hotspots instead:

    Source code

    1
    2
    3
    
    distorted.html5.and.firefox="false"
    distorted.flash.or.no-firefox="true"
    zoom="true"

  • Prefer Flash for Firefox:

    Source code

    1
    
    embedpano({..., html5:(navigator.userAgent.indexOf("Firefox") > 0 ? "fallback" : "prefer"), ...});

Best regards,
Klaus

7

Wednesday, January 28th 2015, 11:01am

Hi,

about workarounds - I've found another quick one - just add this line:

Source code

1
<view fisheye="0.001" devices="firefox" />


As older Firefox versions also had this bug, but not that hard and only noticeable when using fisheye distortions (where the hotspots easier become flipped) there is already a build-in workaround in krpano for this case. But this workaround only got applied when the fisheye distorted was enabled - therefore set the fisheye setting (only for Firefox) to a very small value to apply it.

There will be a bugfix version 1.18.3 where this workaround will be included automatically and in version 1.19 the distorted hotspots will be rendered by WebGL.

Here the nadir-logo example with this workaround:
http://krpano.com/examples/118/examples/…w.fisheye=0.001

Best regards,
Klaus

8

Tuesday, February 3rd 2015, 5:56am

Thank you.

9

Thursday, February 12th 2015, 8:31am

Oh hell yes, thank you! This has been plaguing me for a while, and I knew it was a firefox issue -- I just couldn't figure out a workaround. I was just about to post about the issue, when I found this!

Many thanks.

10

Thursday, February 12th 2015, 9:36am

I tried all the workarounds mentioned by Klaus, and none of them were ideal (which is fine -- it is a workaround, after all!). BUT, purely by accident, I stumbled on a flawless fix (at least for me). I'd be curious if anyone else can say the same?


For each scene, I replace my nadir hotspot lines from this (some unrelated attributes removed):

<hotspot name="nadirlogo" url="skin/NadirLogo.png" ath="0.000" atv="90.000" scale="1.0" rotate="0.0" distorted="true" rotatewithview="true" />

To this:

<hotspot name="nadirlogo" url="skin/NadirLogo.png" ath="0.000" atv="90.000" scale="1.0" rotate="0.0" distorted.html5.and.firefox="false" distorted.flash.or.no-firefox="true" rotatewithview.html5.and.firefox="false" rotatewithview.flash.or.no-firefox="true" />

The first part (distorted) is mentioned above by Klaus, but the second part (rotatewithview) finishes the puzzle!
For some odd reason, the nadir logo rotates with view on Firefox, even though "rotatewithview" is set to "false".
I am puzzled by WHY this works, all I know is that it DOES!

Hope this helps someone else.

11

Saturday, February 14th 2015, 11:31am

Hi,

I have reported the Firefox bug here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1126730

Please VOTE there to get this fixed.

But with the final krpano 1.19 this will be fixed anyway because then WebGL instead of CSS3D will be used for the hotspots. Then the browsers CSS3D bugs wouldn't matter anymore.

Best regards,
Klaus

12

Wednesday, April 8th 2015, 9:26pm


about workarounds - I've found another quick one - just add this line:

Source code

1







@Klaus - Where (which file) do I add your work-around script?

Thanks

13

Friday, April 10th 2015, 5:59pm

Anybody help?

Thanks

DorinDXN

Trainee

Posts: 103

Location: Timisoara, Romania

  • Send private message

14

Monday, June 29th 2015, 8:23pm

Hi Klaus, the nadir logo keeps appearing in top-left corner in FireFox, form time to time, especially when you pan to left.
Tested in 1.19-pr2 as well.

I can provide link, if needed.

Any work-around for this?

thanks,
Dorin

This post has been edited 2 times, last edit by "DorinDXN" (Jun 30th 2015, 1:12pm)


15

Tuesday, June 30th 2015, 1:36pm

Any work-around for this?
Just see a few posts above:
Nadir Logo appears in screen at ath=0

But as said it's a Firefox CSS3D bug (on some systems) and as soon as the hotspot-rendering-via-WebGL support is fully ready (planed for the final 1.19 version), it will be possible to render the hotspots via WebGL (automatically) - then the CSS3D bugs of the browser will not matter anymore for this case.

Best regards,
Klaus

DorinDXN

Trainee

Posts: 103

Location: Timisoara, Romania

  • Send private message

16

Tuesday, June 30th 2015, 2:08pm

Thank for quick reply, I understand that is Firefox bug.

a kind of work-around I found is this

Source code

1
  onviewchange="set(hotspot[nadirlogo].rotate,get(view.hlookat)); set(ver, get(view.vlookat)); if ((ver GT 25) ,set(hotspot[nadirlogo].visible,true),set(hotspot[nadirlogo].visible,false)) ;" 


maybe is of some help for others, until the final 1.19 is out.

cheers,
Dorin

Similar threads