You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, January 29th 2015, 4:29pm

hotspot works in ie but not chrome or safari... live environment

Good Morning,

I am trying to make a hotspot work in a 3 scene tour and have been successful in making the hotspot image show up in ie but nowhere else.

I am sure that i am overlooking something simple but can't see the forest for the trees.

I am looking at everything live vs local

Any Pearls of wisdom?

Tuur

Sage

Posts: 3,337

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

2

Thursday, January 29th 2015, 5:23pm

please share a link or the code

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

3

Thursday, January 29th 2015, 5:44pm

http://bluespringsmip.com/v2/tour.html?html5=only

When the scene opens you should see a plane with a link scene

to the right in ie is a info icon that changes to an icon that is a link.




<hotspot name="walmart"
type="image"
url="http://www.bluespringsmip.com/2015/images/icon_i_white.png"
alturl=""
keep="false"
devices="all"
visible="true"
enabled="true"
handcursor="true"
maskchildren="false"
zorder="1"
style=""
ath="28.299486209749986" atv="-4.6563835630425603"
edge="center"
zoom="false"
distorted="false" rx="0.0" ry="0.0" rz="0.0"
width="" height=""
scale="1.0"
rotate="0.0"
alpha="1.0"
onover="set(url, http://www.bluespringsmip.com/2015/images/5_walmart.png);"
onhover=""
onout="set(url, http://www.bluespringsmip.com/2015/images/icon_i_white.png);"
ondown=""
onup=""
onclick="openurl('http://walmart.com',_blank)"
onloaded=""
/>

4

Tuesday, February 3rd 2015, 10:17am

Hi,

for me your tour works in all browsers...

BUT - I would recommend avoiding full url paths like 'http://www.bluespringsmip.com/2015/images/icon_i_white.png' !

When you run your tour on 'http://bluespringsmip.com' (without the 'www.') and access that file, you will have an unnecessary cross-domain access.

If you really need to use absolute paths, then better use server-absolute paths like '/2015/images/icon_i_white.png' (or even better just relative paths).

Best regards,
Klaus

5

Tuesday, February 3rd 2015, 3:08pm

Thenks for the update

Thank you for responding with the info about absolute vs. relative I will use it moving forward.

It's not that the tour does not work its that the hotspot i manually entered are not showing up.

On our end we have verified across 3 computers

The hotspots created by the tour editor work great but the one I manually entered do not show up.

This is a screen grab from ie showing the buttons their in the clouds to the right of the plane.... we don't see these in chrome or safari pc and mac.

Are you saying you see these info icons on your end?

<img src="http://bluespringsmip.com/v2/bluesprings_mip_capture_ie.png" alt="bluesprings_mip_capture_ie.png" title="bluesprings_mip_capture_ie.png" style="font-size: 0.8em;" />