You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

241

Tuesday, September 8th 2015, 1:32pm

Which Oculus Rift runtime have you installed?
The Chromium WebVR build doesn't work with the latest one yet.
I think 0.5 or 0.6 would need to be used...

cartola

Beginner

Posts: 24

Location: Rio de Janeiro, Brazil

Occupation: System Analyst

  • Send private message

242

Wednesday, September 23rd 2015, 3:41pm

Hi, I've read above that the hotspot rendering is not finished yet in this pre-release, but anyway, maybe my example can also help developing it.

I've recently used the pr1, but after a friend advised me about some problems in Safari+Mac desktop I've changed to pr3 and added

Source code

1
<display framerate="60" devices="desktop.and.safari" />
to my xml

When upgraded to pr3 the hotspot at nadir just vanished, and it is not inside VR mode, it already disapeared when entering the standard panoramic mode.

Here are two examples:

http://cartola.org/panoramas/20141121-Me…eum-Great_Hall/

http://cartola.org/panoramas/20141121-Metmuseum-Esfinges

The hospot link is there (nadir) but the image doesn't show. No error is reported by krpano. I haven't put the example online, but if I just change the index.js with the one from pr1 the hotspot image gets shown.

Bests and thank you for your great work, as always.


Hi, just to keep possible interested people informed, the hotspots have appeared when I added 'keep="true"'. Flash version didn't need it. In fact I was having this problem in 19-pr3, not in this one. In 19-pr1 it worked without keep=true like in this one. It took me a while to solve it.

Cheers.
http://cartola.org/360
twitter: @carloscartola | facebook
Rio de Janeiro, Brazil

243

Wednesday, October 14th 2015, 3:54pm

some questions on vr plugin features

Hi Klaus

Just tried the VR plugin on iPhone 6 and Samsung s6 - very very impressed, much more instinctive positioning the '+' over a 'go forward' arrow.

Some questions...

1. What is the best flag/variable to test whether the tour is in vr mode (can I use the vr="true") so for example I'd like to play an audio commentary after the pano is loaded, but only want this to play when in VR mode.

2. vlookat - I'm using vlookat to 'orientate' the next pano view when an arrow is touched/clicked:


<hotspot name="arrow-90"
url="../hotspots/yellow-arrow.png"


.....

onclick="loadscene(pano3,null,merge,blend(2));set(view.hlookat,90)"

I understand that vlookat is ignored and effectively the real headset direction is used which makes obvious sense. Not an issue where I have a series of panos' all orientated in the same direction (i.e. 0 degrees always = North), but I have a tour which is an inverted 'U' and the 0 becomes 180 as you go around the bend (if that makes sense) is there a 'fix' for this or should I just make sure all pano's consistently have the same orientation?

3. I have a video that plays 'on the wall' of one of my virtual tours, does not work in VR, assume this is a feature, is this likely to be available in the final VR mode version?

Best regards

Tim

ps - for Samsung gearvr, to stop the gearvr app starting up I bought and installed package disabler pro on Samsung s6 and disabled gear vr services, this stops the oculus app starting up

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

244

Wednesday, October 14th 2015, 6:40pm

1. if(layer[webvr].isenabled

2. set(layer[gyro].enabled,false); before loadscene

3. depth="1000"
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

245

Wednesday, October 14th 2015, 11:19pm

Thanks

I'll try 1 and 3, issue with 2... isn't that going turn off gyro?

I've tried this instead...

<hotspot name="arrow-254"
url="../hotspots/yellow-arrow.png"
alpha="0.8"
scale="0.5"
distorted="true"
rx="-60.0"
ath="254"
atv="5"
zoom="true"
onhover="showtext(' ',hotspottextstyle);"
onclick="loadscene(pano21,null,merge,blend(2));set(view.hlookat,70);set(webvr.resetSensor,70);"
/>


I was expecting the 'called' pano to be orientated at 70 degrees, but it opens at the same orientation as the pano it was called from. so the webvr.resetSensor seems not to be read, or maybe I'm not using it correctly



Tim

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

246

Thursday, October 15th 2015, 12:57am

Your commands after loadscene will do nothing. Try the gyro back on in scene onstarts or use an event or something.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

247

Friday, October 16th 2015, 8:39am

Hi,

that usage/syntax of resetSensor is wrong:
onclick="loadscene(pano21,null,merge,blend(2));set(view.hlookat,70);set(webvr.resetSensor,70);"
see here:
http://krpano.com/plugins/webvr/#resetsensor

The correct usage would be:

Source code

1
onclick="loadscene(pano21,null,merge,blend(2)); webvr.resetSensor(70);"


or better try this:

Source code

1
onclick="loadscene(pano21,null,merge,blend(2)); if(webvr.isenabled == true, webvr.resetSensor(70), set(view.hlookat,70) );"


And you would need to use at least 1.19 pre-release 3 (because you're posting in the pre-release 1 thread).

Best regards,
Klaus

248

Sunday, October 18th 2015, 12:40pm

Hi Klaus

Many thanks for this, just tried it and the second option did exactly what I needed.

I am using pre release 3, sorry I did not pick the right forum.

Re limiting hlookat and vlookat (i.e. using vlookatmax/vlookatmin etc) do you eventually intend krpano to support this in VR or is it just not feasible?

thanks again for all your efforts with krpano.

Best regards
Tim

249

Tuesday, October 20th 2015, 10:32am

Re limiting hlookat and vlookat (i.e. using vlookatmax/vlookatmin etc) do you eventually intend krpano to support this in VR or is it just not feasible?
There are currently no plans to support limiting the viewing-range in VR, that just doesn't work well.

Best regards,
Klaus

250

Tuesday, February 23rd 2016, 2:04am

Hi there.
Just tried new awesome features.
Question: will Stereoscopic effect work with such plugin as arrows?
Just did a quick tests and noticed that they are gone.

Thanks!

251

Friday, February 26th 2016, 10:37am

How to use resetSensor(hlookat)

Hi guys

I am new at programming and krpano.

I have an introduction page with thumbnail previews and then linked scenes of panorama pics with hotspots. I would like to be able to see the same startview for every scene after i enter VRmode. Where and how should I use the resetSensor(hlookat) ? Should I use it in the tour.xml or webvr.xml? how should I code it?

When i Enter VR mode on my mobile device, I would like to see the startview that i have set no matter which position i am standing.

I did this.

onstart="lookat(179.999,0); if(webvr.isenabled == true, webvr.resetSensor(hlookat));"

And upon using the resetSensor(hlookat); , where should i delete the KEEPMOVING ?

Thanks.

This post has been edited 2 times, last edit by "tmrnvrcome" (Feb 26th 2016, 11:00am)


252

Monday, February 29th 2016, 7:28am

Hi guys

I am new at programming and krpano.

I have an introduction page with thumbnail previews and then linked scenes of panorama pics with hotspots. I would like to be able to see the same startview for every scene after i enter VRmode. Where and how should I use the resetSensor(hlookat) ? Should I use it in the tour.xml or webvr.xml? how should I code it?

When i Enter VR mode on my mobile device, I would like to see the startview that i have set no matter which position i am standing.

I did this.

onstart="lookat(179.999,0); if(webvr.isenabled == true, webvr.resetSensor(hlookat));"

And upon using the resetSensor(hlookat); , where should i delete the KEEPMOVING ?

Thanks.
It's ok. I got it already.

253

Sunday, March 6th 2016, 6:50pm

WebVR not always fullscreen on iPhone

Hi, I know it has been discussed before, but that was year ago and my problem is a bit different: I got reports from an iPhone 6 user telling me the fullscreen mode works once WebVR is activated for about 1 minute, but then the top bar comes back in. This is with the default browser. With Chrome, the bar never even disappears, i.e. there's no real full screen mode. Everything works fine on Android, i.e. no bar in fullscreen mode. Any idea to fix this?

Similar threads