You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Phil

Trainee

  • "Phil" started this thread

Posts: 97

Location: Texas

  • Send private message

1

Monday, February 23rd 2015, 5:21am

Distorted hotspot isn't working in Flash...only HTML5

I have a project using a distorted hotspot and I've noticed that it's only work with html5. When the browser is using Flash, the hotspot won't turn on. Tested in Chrome and FF with the same results.

Here's a simple example where clicking on the + turns on the hotspot in html5 but not in Flash.


Flash: http://360photopro.com/hotspot-test/index.html?html5=only

HTML5: http://360photopro.com/hotspot-test/index.html?flash=only

XML: http://360photopro.com/hotspot-test/tour.xml

Zipped project (778kb): http://360photopro.com/hotspot-test/hotspot-test.zip

Can anyone see where I'm making a mistake?

Thanks,
Phil

This post has been edited 1 times, last edit by "Phil" (Feb 23rd 2015, 5:31am)


2

Monday, February 23rd 2015, 10:14am

Hi,

that's because your xml code - see here:

Quoted

<hotspot name="motorcycle" ... devices="html5+desktop"/>
<hotspot name="motorcycle" ... devices="mobile|tablet"/>
The hotspot is once defined only for 'HTML5 AND desktop' and once for 'mobile OR tablet' devices - and that means no Flash.

Best regards,
Klaus

Phil

Trainee

  • "Phil" started this thread

Posts: 97

Location: Texas

  • Send private message

3

Monday, February 23rd 2015, 2:30pm

Thank you.