You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Scott Witte

Intermediate

  • "Scott Witte" started this thread

Posts: 343

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

1

Monday, March 9th 2015, 5:45am

Parsing Bug in v1.18.3

Just about certain this is new with v1.18.3.

Apparently you now must have white space between XML attributes but only in HTML5, not Flash. This leads to a fatal XML parsing error:

x="5"y="5"

This does not:

x="5" y="5"

Note the space before "y". Doesn't mater what attribute. Easy to test and confirm.

martyhr

Intermediate

Posts: 347

Location: CZ

  • Send private message

2

Monday, March 9th 2015, 8:28am

Scott, this happened also in previous versions to me.

3

Monday, March 9th 2015, 9:48am

Hi,

that's not a bug and not related to krpano - having no whitespace between xml attributes is generally invalid.

See here point 7:
http://krpano.com/docu/xml/syntaxrules/#errorchecking

Or here:
http://www.validome.org/lang/en/errors/MISC/3003

The XML parser of the Flashplayer is (misleadingly) more tolerant to XML syntax errors - that can't be used as reference. The XML parsers of the HTML5 browsers are correct and respecting the XML syntax rules.

Best regards,
Klaus

Scott Witte

Intermediate

  • "Scott Witte" started this thread

Posts: 343

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

4

Monday, March 9th 2015, 4:41pm

Hmm. Learn something new every day.

Thanks.