You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

mstoss

Intermediate

  • "mstoss" started this thread

Posts: 286

Location: Berlin

  • Send private message

1

Sunday, March 15th 2015, 4:15pm

Error when embedding an Amazon book shop link

Hello,

I tried to use the standard logo feature to embed a book link to Amazon. I got an error, saying "EntityRef: expecting ';'" so I guess, the link has some characters which I have to edit, but how?

<layer name="skin_logo"
url="skin/shop.png"
scale="0.25"
opened_onclick="openurl('http://www.amazon.de/gp/product/123456789?ie=UTF8&tag=wwwexample&linkCode=as2&camp=1234&creative=5678&creativeASIN=123456789',_blank);" />

Any hint?

Yours,
Michael

This post has been edited 1 times, last edit by "mstoss" (Mar 15th 2015, 7:25pm)


herrpedro

Trainee

Posts: 140

Location: Lisbon

Occupation: Programmer/analyst

  • Send private message

2

Sunday, March 15th 2015, 11:44pm

hi,
been looking at
http://krpano.com/docu/xml/#layer

and cant seem to find "opened_onclick" on layer attributes


may be you want just "onclick"?

herrpedro

Trainee

Posts: 140

Location: Lisbon

Occupation: Programmer/analyst

  • Send private message

3

Sunday, March 15th 2015, 11:46pm

if that is correct i'd try ampersand substitution of some form


& in the xml causes crash

mstoss

Intermediate

  • "mstoss" started this thread

Posts: 286

Location: Berlin

  • Send private message

4

Monday, March 16th 2015, 7:05pm

if that is correct i'd try ampersand substitution of some form


& in the xml causes crash
Thanks a lot! That was the solution. Replacing & with &amp; as Klaus wrote in your link did the trick :-)

All the best,
Michael

Similar threads