You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

flash360

Trainee

  • "flash360" started this thread

Posts: 89

Location: All over

Occupation: this

  • Send private message

1

Thursday, August 20th 2009, 4:16am

My Plugins are only apperaing once?

Hi Klaus,

I use the below to open a new plugin - And unload plugins. This works fine once.... second time you click on the hotspot it doesnt come up --- is there somerthing permenant to removeplugin?

Thanks In Advance

John


<action name="hideallimages">

if(plugin[i_2].loaded, removeplugin(i_2) );

</action>


onclick="set(visible,0); looktohotspot(h_2, 80, smooth(50,50,50));
action(hideallimages);
set(plugin[i_2].url,items/6/2.png);
set(plugin{i_2}.visible,true);"

/>


<plugin name="i_2"
url=""
keep="true"
visible="true" enabled="true" handcursor="true" capture="true" children="true"
zorder="100"
alpha="1.00" blendmode="normal"
smoothing="true"
origin="centre" edge="centre"
scale="1"
onloaded=""
onover=""
onhover=""
onout=""
ondown=""
onup=""
onclick="action(hideallimages)"
ox=""
oy=""
rotate="0"
/>

2

Thursday, August 20th 2009, 5:09pm

Hi,

when it has been removed with removeplugin() it must be added again with addplugin()

what do you want to do?
changing the "url" is also possible without removing and adding,
and for hiding - changing "visible" can be used,

best regards,
Klaus

VN2009

Professional

Posts: 1,336

Location: Duluth MN

  • Send private message

3

Thursday, August 20th 2009, 6:00pm

i see in your xml that you have visible set to 0 i didnt know that would work. thought it should be true or false.

Similar threads