You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Scott Witte

Intermediate

  • "Scott Witte" started this thread

Posts: 269

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

1

Wednesday, April 8th 2015, 7:52am

Soundinterface a little broken in ios 8.x

As we know, to play a html5 sound in iOS there must be physical user interaction to start. Click a play button and the sound can start. But once done you don't have to do that again. If, after the first sound finishes you have programmed another to start automatically, that works. And it use to work in KRPano until iOS 8. I just tested with iOS 7.1 where different sounds can play in sequence. In iOS 8.1 and 8.2 you need to touch the screen to start each sound.

KRPano Example

A javascript example doing the same thing which works in iOS 8.x the same as in iOS 7.x.

HansNyb

Professional

Posts: 936

Location: Denmark

Occupation: Photographer

  • Send private message

2

Wednesday, April 8th 2015, 9:00am

No problem with 8.2 on my iPad Air. Both examples play automatically after you start them

Hans

Scott Witte

Intermediate

  • "Scott Witte" started this thread

Posts: 269

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

3

Wednesday, April 8th 2015, 5:40pm

Hmmmmm. Now it works for me, too. So, ah, never mind.

It wasn't working for whatever reason. So I moved testing to iOS simulator where the problem persisted no matter what I did. Lesson learned: You can't really trust the simulator.

Darn. Thanks for checking.