You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, June 17th 2015, 8:27am

Video Controls in 1.19 pr2

Hello everyone!

can someone point me to an example where I could see the way to implement video controls for 360/VR mods in 1.19?
I have tried 1.18 xml "way" implementations but unfortunately the controls are popping up and then disappearing after the video is displayed.

Thanks.

2

Tuesday, June 23rd 2015, 10:15am

Can someone at least tell me if it should work or not in 1.19 r2?

3

Tuesday, June 23rd 2015, 10:58am

Hi,

can you explain what exactly you mean?

Everything related to video panos that worked in 1.18, should work in 1.19 too.
E.g. the examples here are already using the 1.19 pre-release version.

Best regards,
Klaus

4

Tuesday, June 23rd 2015, 1:12pm

Hi Klaus,

I'm having a mobile implementation of your plugin for 360 and VR playback for offline and online view.
The way how I'm trying to make the videointerface to show is as follow:
- Inside webvr.xml I copied the '<action name="setup_video_controls">....</action>'
- In the video.xml i'm icluding the videointerface.xml
- In the webvr.xml's webvr_onavailable action I'm calling setup_video_controls(); videointerface_videoready();

The results is that the video control interface pops up, then hides (probably overlapping by the video), I'm also having an exit button, the Enter VR icon and a switcher for Gyro/Dragging and all these icons are also became double sized.

If you please can give me an advise where I'm failing the implementation.

5

Tuesday, June 23rd 2015, 2:52pm

Hi,

the pano video can't overlap any elements - is there an image element with 'plugin:video' ?

Or do you mean when entering the VR mode - the enter vr script in the webvr.xml hides all layers that don't have a vr="true" attribute.

About double-sized - the webvr.xml is designed to work with stagescale=1.0 and adjusts the the stagescale setting for this, but the videointerface.xml is designed to work with stagescale=0.5 on mobiles and stagescale=1.0 on tablets and desktop.

Btw - the final 1.19 will include an updated and VR capable video skin of course.

Best regards,
Klaus

6

Wednesday, June 24th 2015, 12:12pm

Hi Klaus,

thanks for the comments!

I managed to fix the scale issue.

About the disappearing of the video control:

I attached the dynamically generate video.xml by the app and indeed there is <image><sphere url="plugin:video" /></image> but I guess this should not be removed.


This is a small video to illustrate the effect: link


As you can see it doesn't hides the controls, it's more like it would overlap..


Thank you!
stephnx has attached the following file:
  • video.xml (1.64 kB - 16 times downloaded - latest: Nov 15th 2018, 6:47pm)

7

Friday, June 26th 2015, 7:27am

Hi,

Have you added keep="true" to all videointerface elements?

If not, either add that or maybe better just move the videointerface include into the <scene>.
Note - layer and events elements without keep=true will be removed when loading a new pano/scene.

Best regards,
Klaus

8

Friday, June 26th 2015, 1:19pm

Dear Klaus

thank you for your help!!

It works now.

What I did is that I modified the start.xml <scene name="video_scene" onstart="plugin[video].play();videointerface_videoready();videointerface_setup_interface(); setup_video_controls();"><include url="%SWFPATH%/skin/videointerface.xml" />

Then since everything was working except the playback control I had to add manual the name of the Video Plugin inside the videointerface.xml's "videointerface_setup_interface"=>set(videointerface_video, 'Video');