You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

321

Tuesday, March 15th 2016, 5:35pm

Example: so on a Motorola Moto X™ (2. Generation) with Chrome 49.0.2623.91 it doesnt work, but the same device with firefox 45.0 can change viewer to VR.
i know the 'requirements' for mobile devices, but what is, if some devices or browser still does not work.


maybe the " vr supporting device test" doesnt work properly or the vr script is not preloaded or something like this !?

322

Thursday, March 17th 2016, 8:23am

but what is, if some devices or browser still does not work.
First it would be necessary to know what doesn't work - e.g.
  • when there is no 'VR button' - in this case either the browser doesn't support WebGL or the browser isn't sending any 'devicemotion' events (=that means there is no gyro support).
  • or just the gyro isn't working - in this case the browser is sending devicemotion events but the gyro/acceleration data is 'invalid' or not sense full - here the device itself might lack working sensors, but there is no way to detect that case.

Best regards,
Klaus

323

Thursday, March 17th 2016, 10:52am

First it would be necessary to know what doesn't work - e.g.
thnak you klaus for your answer.


my problem is, that some devices meet all requirements but doesnt work properly in all cases.


so some devices (LG G5 or Sony Xperia Z1 Compact) seems to work in latest android chrome. vr is working and the user can use a google cardboard to watch the vr panoramas. but after some time in standby and a reload suddenly no compatiblity is detected any more. users has to delete cache that everything is working again.

another case is the moto x i already mentioned. here the vr works in latest firefox but not in latest chrome browser.

this error seems somewhat arbitrary and it makes selling or only presenting my vr products very hard.

i try to add the webvr.js in my player html so that this file existing localy for sure. this improved the vr compatiblity in some cases but furthermore there are incompatiblity errors .

may be the vr compatiblity testing could be improved with some optimisations for that cases !?

324

Thursday, March 17th 2016, 11:47am

Sorry, but you still didn't say WHAT isn't working - the VR support detection or the gyro?
And if it's the VR support detection - is WebGL available at that time? (check by the info in the contextmenu or the krpano log)
And is the gyro plugin available? (check if the gyro icon of the vtour skin is there)

325

Thursday, March 17th 2016, 12:35pm

Sorry, but you still didn't say WHAT isn't working - the VR support detection or the gyro?
And if it's the VR support detection - is WebGL available at that time? (check by the info in the contextmenu or the krpano log)
And is the gyro plugin available? (check if the gyro icon of the vtour skin is there)
Okay, sorry for my confusing posts. I want the WebVR Plugin running stable on most devices.

Motorola Moto X (Chrome doesnt work, but Firefox)

Chrome
1. The VR Suport isn't working
2. The Info in Context is: Android 6.0 (XT1092) - Chrome 49.0 - WebGL
3. The Gyro Symbol is there and can be activated

Firefox
1. The VR Suport is working in 95% (may be the 5% is my fault with some testing situations)
2. The Info in Context is: Android 6.0 (rv:45.0) - Firefox 45.0 - WebGL
3. The Gyro Symbol is there and can be activated



if you need other information, please write me.

Thx

326

Monday, March 21st 2016, 3:33pm

The new deeplinking option in the vtourskin is very useful for me, but should have 2 modifications.

1. The lookat part of the URL should use all supported parameters, that means also the Pannini parameter

2. The scene should be specified by name and not by index, because in case of modifications of the Tour the Index would change, but not the name.


Uwe

327

Monday, March 21st 2016, 4:48pm

Hi,
The new deeplinking option in the vtourskin is very useful for me, but should have 2 modifications.
You can adjust it anytime for your needs - look in the vtourskin.xml at the 'skin_deeplinking_update_url' <action>.

Instead of the scene 'index' use 'name' and the pannini value can be handlet like the other view settings there and added as last setting for the lookat call.

Best regards,
Klaus

328

Monday, March 21st 2016, 4:55pm

We have updated krpano from 1.18.5 to 1.19 and we have one issue: When loading a new scene ( krpano.call("loadscene(scene" + fileName + ", null, null, null);");), the previous image is now shown for a while before loading the new image and this is really causing some confusion in the navigation. You can check what I exactly say if you go to https://goo.gl/dG9UAq and try to navigate using the hotspots. It used to work fine with 1.18.5. Any ideas?
Could somebody confirm if it is a bug? @Muxi had the same problem and trying to create a very simple XML and running the loadscene method also produces the same effect: The previews view is shown again before loading the new one. This is specially confusing in the case of ZOOMBLEND (old image shown zoomed when it shouldn't)

329

Monday, March 21st 2016, 5:02pm

Could somebody confirm if it is a bug?
I'm not sure what you mean, but maybe re-test that with the next release. A lot of things have already changed since the pre-release-3 - e.g. the whole wmode=transparent support (used in your example) wasn't finished in that pre-release.

Best regards,
Klaus

330

Monday, March 21st 2016, 5:47pm

Could somebody confirm if it is a bug?
I'm not sure what you mean, but maybe re-test that with the next release. A lot of things have already changed since the pre-release-3 - e.g. the whole wmode=transparent support (used in your example) wasn't finished in that pre-release.

Best regards,
Klaus
I thought 1.19.pre3 and 1.18.5 are the latest releases available up to now. And I also though in general wmode only applies to flash, although it look like it does apply to HTML5 in the case of "transparent".

For anybody trying to find out the "error": changing the wmode to "window" or "direct" does the trick. In transparent or opaque there is still this issue.

331

Tuesday, March 22nd 2016, 4:31pm

Iphone VR mode and flashing screens when changing panos

Okay so I have a quick question, On Iphones there seems to be an issue or atleast in our projects with the VR, the view is cross eyed if you get what I mean this only happens on Iphones and doesn't on some of them? I've tried looking around on the forum but I can't find people with the same problem.

Also about the screen flashing the background of the html body, I read somewhere that you were fixing this in the next release? Any chance you could confirm that or is it something we are going to have to try to fix ourselfs?

Best regards, Wilco

This post has been edited 2 times, last edit by "WilcoVDS" (Mar 25th 2016, 11:59am) with the following reason: Screen jitter on android fixed, seems we were using gyro.js instead of gyro2.js, silly mistake.


332

Friday, April 1st 2016, 8:57am

misaligning distorted hotspot

Hello! I use distorted hotspot in VR mode with depth="off" setting.
At the left screen all is good, but there is misaligning at the right screen.
I tried to set(display.stereooverlap, 0); but it didn't help.

How to fix it?
krpano 1.19-pr3



Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

333

Saturday, April 2nd 2016, 3:55pm

Depth off is not supported yet. We are all waiting for the next release.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

334

Saturday, April 2nd 2016, 4:41pm

It shouldn't take long anymore! ;-)

Tuur

Sage

Posts: 3,184

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

335

Saturday, April 2nd 2016, 9:30pm

*love*
http://www.virtualtuur.com
Skype:studiotuur

336

Monday, April 4th 2016, 5:50pm

YEEEEEEEP!!!! *love*
A delayed easter-surprise for all of us...*g*

337

Tuesday, April 5th 2016, 3:34pm

Opening External Link (URL) Inside VR Mode

How would I go about opening a External Link / URL from within VR mode. Right now I have the following:

Source code

1
<action name="openAd1">	webvr.exitVR();	openurl('http://vermontpeaks.com',_blank);</action>

This works when using non VR mode, my hope was by including the Exit Call it would first close VR mode, then open the URL, but it doesn't seam to work. Any idea?
Thanks,
~Andrew

jordi

Intermediate

Posts: 479

Location: Barcelona

Occupation: creating ideas & coding them

  • Send private message

338

Tuesday, April 5th 2016, 3:47pm

maibe just try no to exit VR and just open the url, it should exit anyway, or try first open url and then exit
everpano.com step beyond 360

339

Tuesday, April 5th 2016, 4:15pm

Popup Blocker

Quoted

"maibe just try no to exit VR and just open the url, it should exit anyway, or try first open url and then exit"
I tried that first, unfortunately there is something that prevents the openurl() call to execute when done from within VR mode. On closer inspection, I believe what is happening is that openurl() is causing the popup blocker in Chrome and Safari to trigger. While I know I can white list this, my viewers won't know that. Anyone eles have a problem with openurl() triger popup blocker?

jordi

Intermediate

Posts: 479

Location: Barcelona

Occupation: creating ideas & coding them

  • Send private message

340

Tuesday, April 5th 2016, 4:40pm

yes, for me it's also getting blocked...

I tried with self and top, and it's working , but maibe you don't want to leave the page ...
everpano.com step beyond 360