Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

121

Montag, 28. September 2015, 13:51

initvars for the menubar not working for all browsers?

EDIT2: question removed.
I noticed a lot of irregularities, sometimes loading, sometimes not, mostly on Chrome. Whereas the examples of Klaus were working perfectly. Finally I figured out the Virtual Tours or Panos were misbehaving behind an online site with password protection. Strange, but without the password it is working OK.

cheers!

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »LMB« (29. September 2015, 14:43) aus folgendem Grund: incorrect


122

Montag, 28. September 2015, 21:14

change video on iphone?

I have several hotspots and I want each to play a different pano video. I understand having to preload and pause the movie via the touch event on startup, and I can get one to play just fine, but how exaclty do I go about changing the video on the click of another hotspot? Is it possible?

Thanks,
Ryan

123

Dienstag, 29. September 2015, 09:07

Hi to all, Hi Klaus


Thanks a lot for your wonderful software. I'm new here and working on the following problem since hours and nights, maybe you can help me:

To look at a certain point in the new pano I edited the skin_hotspotstyle in vtourskin.xml the following way:

Quellcode

1
2
3
4
onclick="if(linkedscene, set(enabled,false); skin_hidetooltips(); tween(depth|alpha|oy|rx, 4000|0.0|-50|-60, 0.5, default, loadscene(get(linkedscene),null,get(skin_settings.loadscene_flags),get(skin_settings.loadscene_blend)); 
lookat(get(h), get(v), get(fov)); 
wait(1); 
lookto(get(toH), get(toV), get(tofoV), tween(easeInOutQuart,4)); skin_updatescroll();); looktohotspot(); );"



This works fine if I view the pano in the "normal" mode. If I change to webvr mode, the viewer looks at a certain point in the old pano before tweening to the new pano and continue with the lookto-command. It seems that in VR mode the lookat-command is beeing executed in the old pano(?)

Many thanks for your help...

124

Dienstag, 29. September 2015, 14:36

Question about performance

I tried the 1.19p3 demo with our Oculus DK2 ( runtime version 0.7.0 ) using Firefox Nightly latest version and it's very "laggy" - is it a known problem with DK2 ? With Cardboard + Mobilephone ( Z3 compact ) it works fine.

I think the system used is in a good shape ( WIN 7 64bit with 16MB DDR4 , GPU 970GTX 4GB and CPU i7 5820K@3.3GHz ) but don't have the possibility to test it on another VR Gear.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »suppenhuhn« (29. September 2015, 17:13)


125

Mittwoch, 30. September 2015, 10:57

Hi,
Finally I figured out the Virtual Tours or Panos were misbehaving behind an online site with password protection. Strange, but without the password it is working OK.
In such case use:

Quellcode

1
<security cors="use-credentials" />


And make sure not to mix files protected and unprotected files (because several browsers have caching bugs here, e.g. they would cache the unprotected file request and when trying to load it as protected, the browser will wrongly use the old unprotected one from the cache).

This works fine if I view the pano in the "normal" mode. If I change to webvr mode, the viewer looks at a certain point in the old pano before tweening to the new pano and continue with the lookto-command. It seems that in VR mode the lookat-command is beeing executed in the old pano(?)
In VR it's not possible to control/change the looking direction of the users by changing the view.* settings.

The only way to force a new looking direction, would be calling the resetsensor action of the WebVR plugin:
http://krpano.com/plugins/webvr/#resetsensor


I tried the 1.19p3 demo with our Oculus DK2 ( runtime version 0.7.0 ) using Firefox Nightly latest version and it's very "laggy" - is it a known problem with DK2 ? With Cardboard + Mobilephone ( Z3 compact ) it works fine.
Please contact Firefox directly about laggy WebVR support.
For me the DK2 works best on Windows with the Chromium WebVR builds.

Btw - please note that the whole Oculus Rift / WebVR stuff is still under heavy development and very experimental (I mean on the side of Oculus and WebVR ;-))! So expect more setup-work or experimenting with the system, drivers, runtimes and browser versions to get things working (also expect problems with 'Nightly' versions). That all hopefully should become more stable and common usable after the final release of the Oculus Rift customer version and stable drivers and runtimes.

Best regards,
Klaus

126

Donnerstag, 1. Oktober 2015, 15:20


Btw - please note that the whole Oculus Rift / WebVR stuff is still under heavy development and very experimental (I mean on the side of Oculus and WebVR ;-))! So expect more setup-work or experimenting with the system, drivers, runtimes and browser versions to get things working (also expect problems with 'Nightly' versions). That all hopefully should become more stable and common usable after the final release of the Oculus Rift customer version and stable drivers and runtimes.

Best regards,
Klaus


I know, I know - developing is no kinderfasching... but sadly Chromium doesn't work at all on my machine ?!?

Changing the configurations / drivers all the time made me really sick the last 6 month and decided using only the latest runtimes/drivers from now . When it works -> it's fine... if not i'll wait ;-) That's probably the reason why the most using still DK1 for testing, because it's less trouble.

But it's still exciting and with one of the best tools like yours much more fun YEAH

D_V

Anfänger

Beiträge: 5

Wohnort: Portugal

Beruf: 3D Artist & Designer

  • Nachricht senden

127

Mittwoch, 7. Oktober 2015, 09:55

How do i enable All Time Tooltips on VR mode?

How do i enable All Time Tooltips on VR mode?

I have it running in all my tours but when i enter VR Mode they disappear.

Thanks

128

Mittwoch, 7. Oktober 2015, 22:11

Hi,

I ive encountered an issue using krpano 1.19-pr3 with the hotspots arrow , it looks ok in VR mode , but are not ok in non VR mode. In non VR mode the distance between arrows is much enlarge and are not orientated well. I 've tried to disable the VR mode but seems the issue is still reproducing , seems that the issue is not related to the in/out VR mode.
With the version 1.18.2 it looks ok.

Any suggestion will be appreciated. Thanks


Below are the picture with pr3 version where arrows are not ok , the distance between arrows is to big and second is with krpano version 1.18.2 where arrows are displayed ok

[img]http://krpano.com/forum/wbb/index.php?page=Attachment&attachmentID=1670[/img] [img]http://krpano.com/forum/wbb/index.php?page=Attachment&attachmentID=1671[/img]

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »clauc« (7. Oktober 2015, 23:00)


129

Donnerstag, 8. Oktober 2015, 07:31

Hi,
How do i enable All Time Tooltips on VR mode?
Please read the pre-release posts - in stereo rendering mode only distorted image hotspots are currently visible, that means at the moment 'tooltips' would need to be implemented via images as distorted hotspots.

I ive encountered an issue using krpano 1.19-pr3 with the hotspots arrow , it looks ok in VR mode , but are not ok in non VR mode.
The hotspot rendering code is not final in the current pre-releases.

Best regards,
Klaus

VVZen

Anfänger

Beiträge: 26

Beruf: Freelance 2d-3d Artist

  • Nachricht senden

130

Donnerstag, 8. Oktober 2015, 10:24

Is it currently possible to load a new tour.xml in VR mode and continue the navigation without exiting VR?
So that I can load a scene from another xml.
Using loadpano() currently exits from VR mode.

I tried also loadscene() with an <include url="myOtherTour.xml">, but I'm having problems with my styles (different for each tour) being overridden.
Thanks for the great job!


Namastè.
VVZen - 3d generalist getting into the VR world

yaskebasi.it

philkrom

Anfänger

Beiträge: 35

Wohnort: Montpellier France

Beruf: Zooomez cofounder

  • Nachricht senden

131

Freitag, 9. Oktober 2015, 16:04

HiRes equis in VR Mode = not smooth

Hi !

A am using KRpano with VR devices for a while, months before it was implemented in 1.19.

I am using a Samsung Note3, and have noticed that if the (source) equi is 17000x8500, it is not as "fluid" as if the equi is 5000x2500.

As you can't zooomin in VR mode, it should be to force VR mode to use "lowres" tiles, and so get a better VR experience ?

Best regards, hope someone can help me...
Philippe - Newbie in krpano code but very interested in everything about Oculus and VR devices *w00t*

Cofounder of the Zooomez project - zmz.fr - map on this link
If you want to support our project, please like our Facebook page *thumbsup*

Beiträge: 1 850

Beruf: Virtual Tours - Photography - Krpano developer

  • Nachricht senden

132

Sonntag, 11. Oktober 2015, 07:55

Hotspots don't take changes in url

I built some jpg animations that change the url of hotspots.
In webvr mode it just disappears a sec and then goes back to the original image. Dropping out of webvr mode shows the correct image.. loaded/loading/url all look correct.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

133

Dienstag, 13. Oktober 2015, 14:34

8 Panorama's shown, the rest is not used (but created)

Hello guys,

When I drag my 12 spherical jpegs on the MAKE VTOUR (NORMAL) droplet, it does create my files for the 12 panorama's. However, only the first 8 panorama's show up in the thumb nail list and tour.xml. Should I create the other panorama's manually, or am I doing something wrong?

Thanks in advance,
Kevin

Beiträge: 1 850

Beruf: Virtual Tours - Photography - Krpano developer

  • Nachricht senden

134

Mittwoch, 14. Oktober 2015, 04:11

VR hotspots with depth..

VR mode only supports hotspots with depth.. there needs to be a way to disable the stereo mode for this too. so that normal distorted hotspots work as well otherwise they are a bit misaligned and not part of the background.
I guess this is all in the works.. but I thought I'd throw that out there.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

135

Mittwoch, 14. Oktober 2015, 07:55

Hi,
Is it currently possible to load a new tour.xml in VR mode and continue the navigation without exiting VR?
Yes, but the xml (and the skin there) would need to be designed for that.
The default vtourskin.xml is not designed for getting loaded directly from an other tour.


As you can't zooomin in VR mode, it should be to force VR mode to use "lowres" tiles, and so get a better VR experience ?
That's already the case since pre-release-3 - see the multireslock setting:
http://krpano.com/plugins/webvr/#multireslock


I built some jpg animations that change the url of hotspots.
In webvr mode it just disappears a sec and then goes back to the original image.
This is because of the current incomplete hotspot-via-WebGL-rendering support in the pre-release.


When I drag my 12 spherical jpegs on the MAKE VTOUR (NORMAL) droplet, it does create my files for the 12 panorama's. However, only the first 8 panorama's show up in the thumb nail list and tour.xml.
OSX 10.10?
If yes, this is an OSX system bug, but I've already developed a tricky workaround for the next release.

As manual workaround for the moment it would be possible to call the krpano tools from the terminal - e.g. this way:

Quellcode

1
./krpanotools makepano -config=templates/vtour-multires.config /YOUR-PANO-FOLDER/*.jpg



VR mode only supports hotspots with depth.. there needs to be a way to disable the stereo mode for this too.
I agree, for the next release a depth="off" mode was already added for this case.


Best regards,
Klaus

VVZen

Anfänger

Beiträge: 26

Beruf: Freelance 2d-3d Artist

  • Nachricht senden

136

Donnerstag, 15. Oktober 2015, 11:10

Hi,
Is it currently possible to load a new tour.xml in VR mode and continue the navigation without exiting VR?
Yes, but the xml (and the skin there) would need to be designed for that.
The default vtourskin.xml is not designed for getting loaded directly from an other tour.

[...]
Best regards,
Klaus


Thank you so much, Klaus!
At the end I was able to obtain what I needed by redesigning some of the xml structure.
My only other little question is: is it currently possible to load a virtual tour directly in vr mode?

For example, this could be achieved passing a var to the tour address request? (like: myAddress.html?loadinvrmode=yes ).
(this leads me to.. : How can I trigger the webvr.enterVR() without user interaction? )

Thanks again.

Namasté
VVZen - 3d generalist getting into the VR world

yaskebasi.it

jordi

Fortgeschrittener

Beiträge: 420

Wohnort: Barcelona

Beruf: creating ideas & coding them

  • Nachricht senden

137

Donnerstag, 15. Oktober 2015, 12:08

is it currently possible to load a virtual tour directly in vr mode?
Yes it is, for my experience you need to leave some time before entering on VR, something like this is working for me :

Quellcode

1
delayedcall(0.5, if(vrInit, webvr.toggleVR(); ););


Hope it helps
everpano.com smart virtual tours

VVZen

Anfänger

Beiträge: 26

Beruf: Freelance 2d-3d Artist

  • Nachricht senden

138

Donnerstag, 15. Oktober 2015, 12:43

is it currently possible to load a virtual tour directly in vr mode?
Yes it is, for my experience you need to leave some time before entering on VR, something like this is working for me :

Quellcode

1
delayedcall(0.5, if(vrInit, webvr.toggleVR(); ););


Hope it helps


Thank you so much, works like a charm!!
Great solution.
Two thumbs up! *thumbup* *thumbup*

Namastè.
VVZen - 3d generalist getting into the VR world

yaskebasi.it

augustommm

Anfänger

Beiträge: 34

Wohnort: Goiânia-Goiás-Brazil

Beruf: Photographer

  • Nachricht senden

139

Donnerstag, 15. Oktober 2015, 15:26

Hello guys!

Sorry for being such a newbie!

Where exactly should I place this line of code for this to work?


Cheers!

is it currently possible to load a virtual tour directly in vr mode?
Yes it is, for my experience you need to leave some time before entering on VR, something like this is working for me :

Quellcode

1
delayedcall(0.5, if(vrInit, webvr.toggleVR(); ););


Hope it helps


Thank you so much, works like a charm!!
Great solution.
Two thumbs up! *thumbup* *thumbup*

Namastè.

VVZen

Anfänger

Beiträge: 26

Beruf: Freelance 2d-3d Artist

  • Nachricht senden

140

Donnerstag, 15. Oktober 2015, 17:28

Hello guys!

Sorry for being such a newbie!

Where exactly should I place this line of code for this to work?


You could put in the startup action, and pass the argument while sending the address like this: http://mytour/tour.html?enterinvr=true

Quellcode

1
2
3
4
5
6
7
<action name="startup" autorun="onstart">
    delayedcall(0.5, if(get(enterinvr), webvr.toggleVR(); ););
    trace('VR is active? ', get(enterinvr));
    if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
    loadscene(get(startscene),merge,blend(4));
    if(startactions !== null, startactions() );
</action>  


UPDATE:
It seems that on my mobile phone it won't start directly in vr mode, while on desktop under fake vr it does.
Is it required some kind of user interaction to enter in vr mode?
Can we bypass this?
I'm loading the pano inside the webview of an android app.

Namastè. *smile*
VVZen - 3d generalist getting into the VR world

yaskebasi.it