You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

161

Thursday, October 29th 2015, 6:37pm

spotstyle conflict with map-spots

Zadda wrote at 4.8.15
regarding 1.19 pre-Release 3
I don't know if it's documented (as i didn't found mention of it) but with the new Style,
You have to set your maps spot style outside of the maps <> otherwise create errors...not finding style
( i got errors when having several inside the and with spots having a style="" attribute )
I have the same problem.
In the <spots ../> I did rename 'style=' into 'spotstyle=' (recommended by Klaus ) This helped to clear the errors.
Any spotstyle declaration within the map-plugin (normal coding) or outside the map-plugin does not create the wanted effect. I only can create the DEFAULT styles.

Zadda,
do you have a solution in the meantime?

Thanks and regards

Umalo

Professional

Posts: 1,047

Location: Osijek, Croatia, EU

  • Send private message

162

Sunday, November 1st 2015, 9:19pm

Has anybody experienced and reported strange behaviour of the scrollarea with thumbs on Safary? Images overlapping, partialy not visible thumbs....
Tested locally and couldn't find a quick workaround. Just tested with http://krpano.com/tours/corfu/blending-demo.html
Got this reported from two different customers and thought I did something wrong, now I see this happen also on Klaus tour so I would kindly ask someone else to try this link with Safary and confirm strange thumbs when scrollilng (also when resizing window size)
Thanks

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

163

Sunday, November 1st 2015, 10:54pm

yeah shows messed up for me on html5 /safari.. but my tours seems to work ok..

I vaguely remember something.. try changing align and or edge for scrollarea. Or maybe the children too.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

Red

Trainee

Posts: 98

Location: Australia

Occupation: Virtual tour creator, VR app developer

  • Send private message

164

Wednesday, November 4th 2015, 4:42am

Resizing browser window in Safari

There appears to be an issue in pre-release 3 when resizing the browser window in Safari desktop. The view in the window when resizing becomes flashy and pixelated.

Just wanted to point it out.
Thanks

165

Thursday, November 5th 2015, 7:17pm

Stereo Movie inside pano?

Anyone know if it is possible to display a 3d movie inside a static stereo pano? I'm creating a 3d animation and rather than render it 360 (time/processor constraints), I would like to render it to a standard stereo 1080P or 720P format and then project it onto a virtual screen in krpano. This would be viewed in google cardboard and allow the viewer to feel like they are in a theater setting.

Just curious... Thanks,
Ryan

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

166

Friday, November 6th 2015, 5:48pm

The video player plugin doesn't work yet for webvr.. I already tried it. :)
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

167

Saturday, November 7th 2015, 1:46pm

webvr video splits in the wrong direction

Hi,

As a new user of this forum I'll start with a big thank to Klaus and all the contributors that enable the krpano technology for all of us.

I'm developing a mobile app (Cordova) that embeds 360°videos and I'm experiencing an unexpected behavior with MobileVR. I can successfully enter the VR mode, everything looks fine but the screen is splitted in the wrong axis (i.e. horizontally when the phone orientation is landscape). I could not find any advice on that issue anywhere, so I'm feeling this must be trivial... But cannot seem to find the cause of the problem. And cannot reproduce the issue in a desktop browser either.

Any help would be greatly appreciated,
Thanks !

168

Saturday, November 7th 2015, 9:56pm

I figured out what was causing this and it has nothing to do with krpano. For some reason my app was locked in portrait mode, switching to landscape fixed the issue.

Now the MobileVR looks really promising, thanks !

169

Tuesday, November 10th 2015, 5:33pm

Resolved Video playback issue on mobile

Hello I have an issue with my krpano with panoramic video. When I am connected on wifi and I launch my krpano all video works very well, but when I put my phone on my mobil provider network my kpano launch but only video didn't work.
I try with your online krpano demo and is it the same, video works on wifi , not on mobil network.
I don't find nothing about this issue.
I try on different mobil and mobil provider the same result.
My phone is a samsung edge, and the url of my krpano is www.360vr.mobi
Thank you for the help.


Maybe Google made some update, I don't know if its google chrome or webview. But now all seems working

Resolved

philkrom

Beginner

Posts: 35

Location: Montpellier France

Occupation: Zooomez cofounder

  • Send private message

170

Wednesday, November 11th 2015, 2:56pm

How to open a pano only if pointing a specific area of the image ?

Hi everybody

This tour - based on klaus examples - works fine on webvr browsers and mobile devices.
http://static.zooomez.fr/medias/vr/showreel-ET11+aero/vvvr


But as you can see, there are lot of images (hotpsots)




and people often open a pano by mistake, they only wanted to enlarge the image to read the text at the bottom but they stay too long on the photo and the pano opens.

So I would like to do the following, which I am sur is not too complicated : If someone points on a photo, it is scaled up, but it doesn't open the pano.

I will add a hand on each photo like this : (the hand is in the same image, not a different image)



And I would like that the pano opens ONLY if the cursor stays several seconds on this hand.

I hope you understand what I mean :-)

- on the photo : enlarge the photo but doesn't open the pano
- on the hand : opens after 2 or 3 seconds.

Sur it is not complicated to do, but I don't know how...

Any help welcome !

Best regards

Philippe
Philippe - Newbie in krpano code but very interested in everything about Oculus and VR devices *w00t*

Cofounder of the Zooomez project - zmz.fr - map on this link
If you want to support our project, please like our Facebook page *thumbsup*

jeromebg

Professional

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

171

Wednesday, November 11th 2015, 10:17pm

Strange issue with vr_cursor ?

Hi, something I don't understand, I added some code to hide all hotspots with "thumb" style when user exits VR mode :

Source code

1
2
3
4
5
6
7
8
9
10
11
12
	<action name="webvr_onexitvr">
		stopdelayedcall(vr_button_fadeout);
		set(layer[webvr_button].crop,0|0|100|63);
		tween(layer[webvr_button].alpha,1);
		tween(layer[webvr_setupbutton].alpha,0);

		webvr_restore_layers();
		
		for(set(i,0), i LT hotspot.count, inc(i),
			if(hotspot[get(i)].style == 'thumb', set(hotspot[get(i)].enabled, false);tween(hotspot[get(i)].alpha, 0.0, 0.25);));
		  );
	</action>

First issue : It works except for the last hotspot which stays visible
Second issue : when going back to VR mode the vr_cursor isn't visible any more, is I remove the new code then the vr_cursor works again as expected...

A clue ?

172

Thursday, November 12th 2015, 7:02pm

Gear VR

Hello All

I just got the Samsung Gear VR for the Galaxy S6/S6 Edge and it is awesome.
I have to upload my panoramic images to the Oculus/360Photos folder to view my panoramas and they look great.
I wanted to view my actual tours via a browser so I bought the "package disable Pro" and I disabled everything related to Oculus by searching for Oculus in the "package disable" app.

Issue
When I attach my phone to the Gear VR it makes a sound but nothing comes on, I cannot see the browser screen on my phone

Are there anyone here using the same gear and is able to get it to work?
If so, can you please share

Thank you

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

173

Thursday, November 12th 2015, 7:17pm

You leave all that stuff be.
Gear VR service is what you disable.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

174

Thursday, November 12th 2015, 8:57pm

You leave all that stuff be.
Gear VR service is what you disable.
There are 6 things related to Oculus
com.oculus.horizon
com.oculus.oculus360photos
com.oculus.home
com.oculus.systemactivities
com.oculus.cinema
com.oculus.pwatson

Disabling none of these solved my problem
No matter which one I disable, I still get a sound and a blank screen when I place the phone in the Gear VR, even if I have it open to the url of the tour in the browser.

I need to know what I am doing wrong.

This is the app I am using to disable it Package Disabler Pro
Thank You

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

175

Thursday, November 12th 2015, 10:04pm

Did you try my suggestion at all?

Try it and continue on with your day.
....scroll down.. find Gear VR. Disable it. done.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

176

Friday, November 13th 2015, 12:02am

Did you try my suggestion at all?

Try it and continue on with your day.
....scroll down.. find Gear VR. Disable it. done.
Thank you

I did not pay attention that stating "Gear VR Services" differs from searching for Oculus.
I should have pay attention to that.
I found it, disabled it and all is well, I can now go about my day.

Just a note
============
If you desire to find it via the app's search function, search for vrsvc

Thanks again

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

177

Friday, November 13th 2015, 3:23am

yeah the search in package disabler is bassackwards. It should at least search for package title instead of filename. *rolleyes*
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

KiboOst

Trainee

Posts: 83

Location: France

Occupation: TD

  • Send private message

178

Friday, November 13th 2015, 10:50am

Deleted

This post has been edited 1 times, last edit by "KiboOst" (Nov 17th 2015, 10:30am)


KiboOst

Trainee

Posts: 83

Location: France

Occupation: TD

  • Send private message

179

Friday, November 13th 2015, 1:23pm

Deleted

This post has been edited 2 times, last edit by "KiboOst" (Nov 17th 2015, 10:31am)


180

Friday, November 13th 2015, 7:09pm

Hi

I am seeing a problem while creating buttons hotspots using textfield, that has been introduced at version 1.19.

The problem is that not all of the hotspots are showing. I'm not talking about in VR mode, just in the normal pano viewing mode.

Here is an example which should have 11 buttons, but button 6 is not being displayed

Here are my findings so far...

- Flash is fine, this problem is only in HTML5 mode.
- Version 1.18.5 is fine, version 1.19 pr1 is broken, version 1.19 p3 is broken.

- When I use between 1 and 10 textfield hostpots, they all display correctly.
- When I use more than 10 textfield hotspots, at least one hotspot does not get displayed.

- It is broken in Chrome 46 (Adobe Flash Player plugin disabled) - tested on multiple PCs
- It works in Firefox 38 (Shockwave Flash plugin disabled)
- It works in IE11 (Shockwave Flash Object disabled)

- I am not using any skins
- I have tried setting html5 to "auto+webgl" and to "auto+css3d", it makes no difference.
- using normal fixed position layers instead of hotspots, all buttons display. this suggests the problem is in the code that creates the hotspots.
- I have tried using hotspot names that have no numbers so e.g. "buttona, buttonb", instead of "button1, button2". It makes no difference.


- Here are the results I get. The first four have linked examples using 1.19.pr3:

1 button to 10 buttons
- all buttons displayed correctly

11 buttons
- button 6 not displayed

12 or 13 buttons
- buttons 2 and 7 not displayed

14 or 15 buttons
- button 2 not displayed

16 or 17 buttons
- button 9 not displayed

18 or 19 buttons
- button 2 and 10 not displayed

20 or 21 buttons
- button 2 not displayed

22 or 23 buttons
- button 12 not displayed

24 or 25 buttons
- buttons 2 and 13 not displayed


- Note than when using 11 or more buttons, there are always only three types of results:
1) just button 2 missing
2) just one button other than button 2 missing
3) button 2 plus one other button missing
- These three result types repeat with a regular pattern as you increase the number of buttons going result type 1), 1), 2), 2), 3), 3), then back to 1), 1), 2), 2), 3), 3) and so on.
- They results always come in pairs. e.g. using 12 or 13 buttons gives the same result, 14 and 15 gives the same result, 16 and 17 etc.
- When a button that is not button 2 is missing it will be always be button number ( roundup(totalbuttons/2) + 1 )
- These patterns suggest a mathematical error somewhere in the code.
- Could the fact that the results come in pairs, and that the non button 2's number can be predicted as being 1 more than half the total, mean that it might be something to do with hotspots being created in the background in pairs ready for using in a stereographic display even though we're not using VR mode, and not even loading a skin or the webvr plugin?


- Also, in the outputted HTML, the DIVs that are created for each of the textfield hotspots look strange...
- I believe the DIVs for each hotspot should appear in the HTML in the same order that the textfield hotspots are in the XML.
- However, once we have 11 or more buttons, in every case, button 2 is either not displayed at all, or it is displayed in the correct position on the screen but appears in the wrong order in the HTML DIVs.
- When button 2 is displayed in the correct position on the screen but appears in the wrong order in the DIVs, it seems to kill off the button that should have been in that position in the DIVs.
- e.g. with 11 buttons, button 2 is on the screen in the right place, but appears between buttons 5 and 7 in the DIVs. And button 6, which should have been in the DIVs between 5 abd 7, is not displayed at all.
- Why, with 11 buttons or more, is button 2 always either missing, or shown but in the wrong place in the DIVs

- Lastly, a couple of random thoughts...
- Is it a coincidence that the problems start when there are 11 buttons? When using up to 10 buttons, the hotspots would always be between index 0 and 9 in a hotspot array, so the array index always has just one digit. The 11th button would be index 10 in the array, which has 2 digits.
- Or could there be some problem with the textfield hostpot array's index mixing strings and integers, e.g. 1+1=11 rather than 1+1=2


I have no idea what can be causing this, but presume it is a krpano bug as 1.18.5 works, but 1.19 doesn't.

However, I've only seen the problem in Chrome so far. Again, this is HTML5 only, and nothing to do with VR mode.

Can anyone help, or suggest any other tests I can do to help track the source of the problem?


Many Thanks

David