You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, August 5th 2015, 4:39pm

Loading another xml file at end of video

Hi,

At the end of a video I'd like to load a different video. I've created a custom action script plugin that does some custom stuff needed and added a function that invokes loadpano(url_to_next_video_xml_file) with the new xml file for the next video. I do this instead of playvideo because it'll be a lot easier given much of the custom xml properties I've added to the xml config file. In effect I'd just like to "reload" the player with another xml file and start again.

When the video has ended I call this function in the plugin which then calls loadpano. Nothing happens and the player becomes unresponsive, clicking icons/seek doesn't do anything and the video frame is static.

I'm pretty sure the url is being loaded (and on the same domain). Any ideas on how to debug this issue further?

Thanks!

herrpedro

Intermediate

Posts: 153

Location: Lisbon

Occupation: Programmer/analyst

  • Send private message

2

Wednesday, August 5th 2015, 7:37pm

try to use "inspect" from chrome -> here you can see what internet objects are fetched in a timeline and the http responsecodes and content -> meaning you can see, after the video ends, if there is a httprequest for your new panorama

or "trace();" and "showlog();" in krpano to show customs values in the krpano log
like "trace ('loading second pano');"

http://krpano.com/docu/actions/#trace


check the debugging section

Similar threads