You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, August 20th 2015, 11:21pm

Fancybox Full screen

Hi guys,

I am facing a problem with the facybox that is when I am on full screen mode it doesn't work.
Does anybody know?
Thanks

jeromebg

Professional

Posts: 836

Location: Angers - France

Occupation: Photographer

  • Send private message

2

Sunday, August 23rd 2015, 6:50pm

It won't work with the flash player (security restrictions) but should be all right in html5

3

Thursday, August 27th 2015, 8:54pm

Hi,

I don't know how Fancybox works, but if it's using iframes, it would be necessary that it would add the iframe allowfullscreen setting to the iframe definition to allow using the HTML5 fullscreen mode.

Best regards,
Klaus

4

Sunday, September 6th 2015, 5:46am

Hello guys,

I was searching on the fancybox code, and I found this line. It already allows the full screen in the chrome, firefox and so on, so I think that it might be a Krpano deficiency.
What do you guys think?
And thanks for answer me.

Would you guys have any example?

iframe : '<iframe id="fancybox-frame{rnd}" name="fancybox-frame{rnd}" class="fancybox-iframe" frameborder="0" vspace="0" hspace="0" webkitAllowFullScreen mozallowfullscreen allowFullScreen' + (IE ? ' allowtransparency="true"' : '') + '></iframe>',

Ps. I really really need get it solved.
Thanks

5

Tuesday, November 29th 2016, 4:43pm

Hello there,

I've got the EXACT same problem.

I managed to make hotspots display galleries using Fancybox.

The problem is it does not work in krpano's fullscreen. It looks like the picture is displayed "behind" the tour because it appears as soon as you leave the fullscreen.
It works using browser's fullscreen though(F11).

I tried editing fancybox line (the one Lucas suggested in the post above) :

webkitAllowFullScreen mozallowfullscreen allowFullScreen


to

webkitAllowFullScreen="true" mozallowfullscreen="true" allowFullScreen="true"


but it does not make any difference.

Any idea?

Thanks.