You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 792

Location: Angers - France

Occupation: Photographer

  • Send private message

1

Friday, October 2nd 2015, 11:25am

looktohotspot center

Hi, I don't understand why when using looktohotspot it doesn't center the hotspot in the screen on the pano with limitview="range" ?
http://iloveny360.com/360/

2

Thursday, October 8th 2015, 7:58am

Hi,

the action moves to the ath/atv coordinates of the hotspots (not to the image center itself).

Best regards,
Klaus

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 792

Location: Angers - France

Occupation: Photographer

  • Send private message

3

Thursday, October 8th 2015, 9:44am

Thanx Klaus, I understand that, the ath destination is correct but the atv is top of screen.
If you look at my example the ath/atv values are the bottom line of the hotspot, and when I use looktohotspot the bottom line of the hotspot goes top screen (I don't know if I'm clear enough ?)

I made a quick screencast : https://youtu.be/KyPM08OBZ_8

Tuur

Sage

Posts: 3,173

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

4

Thursday, October 8th 2015, 11:26am

Hi Jerome,

did you set some 'oy' or so?
Maybe put the hotspot code to see for us.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 792

Location: Angers - France

Occupation: Photographer

  • Send private message

5

Thursday, October 8th 2015, 11:59am

Thanx for looking Tuur, no oy

Source code

1
2
<hotspot name="myhotspot" ath="-19.272" atv="3.957" url="%SWFPATH%/skin/icons/trait.png" edge="bottom" height="30"/>
<plugin name="myhotspot" url="%SWFPATH%/skin/icons/hotspot.png" edge="bottom" align="top" parent="hotspot[myhotspot]"/>


and it works perfect on the others panos, the problem is only with the first one with limitview="range"

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 792

Location: Angers - France

Occupation: Photographer

  • Send private message

6

Friday, October 9th 2015, 10:46am

Found the problem, it's because architectural is set to 1, with architectural="0" it zooms center screen.
Is this normal Klaus ?