You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, October 9th 2015, 10:42pm

HTML5 video poster not showing up.

I have a posterurl that I want as the video still before it is played. Well I have this working correctly on my local site but once it goes on the dev server it doesnt show the poster any more. Instead the player uses the first frame of the video as the video poster. I think this has to do with load times since the local site loads much faster than the dev server. Iv looked around on Krpano's forums and through the docs but I'm not finding anything that would suggest its possible to change what loads when. Is there anyway I can make the video load only after the user clicks the poster without going outside of krpano's api?


Iv noticed that all the examples on the site http://krpano.com/video/ use the first frame as the poster. Is this a limitation of the HTML5 player?


Thanks

2

Tuesday, October 20th 2015, 10:52am

Hi,

see here for information the HTML5 video 'poster' setting:
https://developer.mozilla.org/en/docs/We…deo#attr-poster

It might be possible to delay the video loading by using an other 'preload' setting:
https://developer.mozilla.org/en/docs/We…eo#attr-preload

but this setting will be currently not exposed by the videoplayer plugin API (I will add an API for the next releases) - and additionally it would depend on the browser what would happen in this case.

Best regards,
Klaus