You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Anoril

Trainee

  • "Anoril" started this thread

Posts: 69

Location: Paris, France

Occupation: Game Developer and Photographer

  • Send private message

1

Thursday, September 10th 2009, 9:41pm

PHPBB Forum integration issue

Hi all,

I search arround with no result so I ask here my question:

I installed phpBB3 forum on a webserver and there is a new behaviour that consists in displaying Flash stuff in posts. Then I directly tried to display my panoramas in some posts test but there is "security issues"...

Can someone explain me why having swf on a server and linking it to another server makes tiles and others blocked for "security reasons" ? How can I do ? I'm using KRProtect... Is there a way to get the whole stuff running smooth ?

Here a sample of what I'm talking about: http://www.serveurphotos1.free.fr/forum/…c.php?f=5&t=494

Thanks for your help.

See You,

Paul
« Quidquid latine dictum sit, altum sonatur »
Pentax stuff.

2

Thursday, September 10th 2009, 10:00pm

I can't help you specifically but I can point you in the right direction. You need to have a cross-domain.xml file that tells flash to share the info from one site to the other. There are several threads here relating to cross-domain issues.

3

Thursday, September 10th 2009, 10:29pm

Hi,

yes, this is a crossdomain access,

the html with the embedded swf is here:
http://www.serveurphotos1.free.fr/forum/…c.php?f=5&t=494
domain = www.serveurphotos1.free.fr

and the data and swf here:
http://www.serveurphotos3.free.fr/Vacanc…es/l1_f_0_0.jpg
domain = www.serveurphotos3.free.fr

two different domains!
I'm not sure but maybe there are crossdomain.xml files need for both domains...

e.g.
here:
http://www.serveurphotos1.free.fr/crossdomain.xml
and here:
http://www.serveurphotos3.free.fr/crossdomain.xml

the content of the crossdomain.xml could be:

Source code

1
2
3
<cross-domain-policy>
<allow-access-from domain="*"/>
</cross-domain-policy>


best regards,
Klaus

Anoril

Trainee

  • "Anoril" started this thread

Posts: 69

Location: Paris, France

Occupation: Game Developer and Photographer

  • Send private message

4

Friday, September 11th 2009, 9:13am

Oh, so easy and so... err... hidden feature ^^

Thanks a lot for your help! I'll try to understand the deeper concept behind these cross-domain behaviour! :)

Best regards,

Paul
« Quidquid latine dictum sit, altum sonatur »
Pentax stuff.

DonaldG

Beginner

Posts: 18

Location: Somerset, UK

Occupation: Retired CEO

  • Send private message

5

Friday, September 11th 2009, 12:06pm

RE: PHPBB Forum integration issue

Hi all,

I search arround with no result so I ask here my question:

Here a sample of what I'm talking about: http://www.serveurphotos1.free.fr/forum/…c.php?f=5&t=494

Thanks for your help.

See You,

Paul




Hi Paul

I can't help with the errors - just started with KRpano a few days ago...However, I have visited the page above. Last week I was in Geurande so was very interested in your pano.
I closed the 'error' notice and the pano worked well until I decided to look at it in full screen. As soon as right clicked and selected 'full screen' the browser crashed.

I am using Vista Ultimate and Internet Explorer 8 with 5 tabs open. The crash causes IE8 to immediately close the tab that renders your link.

I did reboot my machine and check other KRPanos and they worked ok full screen - I then visited your link again & IE8 crashed again.

I don't know if anyone else experienced this or if it is specific to my machine.

Regards

Donald

6

Monday, September 14th 2009, 11:13pm

Hi,
I closed the 'error' notice and the pano worked well until I decided to look at it in full screen. As soon as right clicked and selected 'full screen' the browser crashed.
yes, you're right,
there was still build 2009-06-04 used (see in the log by pressing 'o')
this version crashes the browser when using the contextmenu (only on Windows)
please update to 1.0.8 beta 8 build 2009-06-15 there this was fixed,

see the update notes here:
krpano 1.0.8 beta 8

it was a bug of the Flashplayer,
I have made here a testpage about this bug and the workaround for it:
http://krpano.com/flashplayer/bugs/conte…tmenucrash.html

best regards,
Klaus

Similar threads