You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, February 7th 2016, 5:21pm

devices="desktop.and.tablet" not working

Hi,

I have a <layer>.

When I type

Source code

1
<layer devices="desktop">



It does only display on desktop PC, as expected.

But when I type

Source code

1
<layer devices="desktop.and.tablet">




Nothing display at all. Also doesn't work with


Source code

1
<layer devices="desktop+tablet">




I took that from the documentation (http://krpano.com/docu/xml/#devices) and I don't get why id doesn't work.


I'm using krpano 1.18


Any idea ?




spacerywirtualne

Professional

Posts: 919

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

2

Sunday, February 7th 2016, 5:56pm

Hi

desktop.and.tablet = Such a condition will never happen.

try
desktop.or.tablet
Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

Posts: 1,850

Occupation: Virtual Tours - Photography - Krpano developer

  • Send private message

3

Sunday, February 7th 2016, 6:58pm

desktop.and.tablet = Such a condition will never happen.

True. Microsoft book can be a tablet, but it does not identify itself uniquely. Kind of annoying since you can't detect it and choose between normal rotation or gyro.
KRPano Developer: Portfolio ::Gigapixel Tagging Solutions - Porfolio 2 :: Facebook :: Twitter :: reddit.com/r/VirtualTour

Tuur

Sage

Posts: 3,184

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

4

Sunday, February 7th 2016, 9:03pm

Hi,

Of course it should be

devices="desktop|tablet"

Or even better

devices="normal"

Hope it helps
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

5

Monday, February 8th 2016, 12:12am

Hoow yes, I didn't realized that "AND" was exclusive, silly me. Seems so obvious once you explain it. Thanks everyone ! *thumbsup*

Devices = "normal" doesn't seems to work though, the layer doesn't display when I use that.

Tuur

Sage

Posts: 3,184

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

6

Monday, February 8th 2016, 2:13am

Normal is possible with 1.19.3
Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

7

Monday, February 8th 2016, 9:50am

achsoo, thank you !