You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tsukada

Beginner

  • "tsukada" started this thread

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

1

Wednesday, March 2nd 2016, 1:38pm

iOS suddenly shutdown when using distorted video hotspot on iphone

Please help me.

iOS 9 on iphone suddenly is shutdown or rebooted when viewing panorama with video hotspot.
I made a simple page to reproduce the problem.

https://web5.abook.bz/ios9/


After loading the page, you rotate the scene, even without playing video, after a minute or so, suddenly appearing Apple logo, which means iOS reboot. Sometimes is just causes Safari browser shutdown but most cases iOS reboot.

Here's a detail:
iOS 8.4 iPhone/iPad No problem
iOS 9.2 iPad No problem

iOS 9.2 iPhone / iPad(Simulator) 100% occur


I tried to use videoplayer.js version 1.19pr4, pr3 and 1.18.5, but the results were same, problem reproduced.
If you use smaller video, it takes more time for the problem to occur.

In case of not distorted hotspot it is unlikely occurred.


I suspect iOS bug but this is a serious problem for our service launching.


Any advice is appreciated.

spacerywirtualne

Professional

Posts: 919

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

2

Wednesday, March 2nd 2016, 2:22pm

You must use MAKE PANO (MULTIRES) droplet.bat

Loading not cut panoramas always ends badly.

Best Regards

Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

tsukada

Beginner

  • "tsukada" started this thread

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

3

Thursday, March 3rd 2016, 10:17am

Thanks for your reply, spacerywirtualne.
But the problem still occurs even when I use MAKE PANO (MULTIRES) droplet.bat as you instruct.
I don't believe the cause is whether using cube or sphere image.

Here's a site using multires cubes for reproducing the problem.

https://web5.abook.bz/ios9/cube.html


And the attached is a crash report created when iphone simulator crashed.


I have to correct my last post in which I described the meaning of appearing Apple logo.
It is not iOS reboot but SpringBoard crash, still it is a serious problem though.
And I said iPad had no problem, but later I found it had the same problem though it seldom happened.
iOS 8 yet has no problem, only iOS 9 has.
tsukada has attached the following file:
  • crash_report.txt (71.42 kB - 1 times downloaded - latest: Mar 14th 2016, 11:34am)

4

Sunday, March 13th 2016, 7:40pm

Hi Tsukada,

Did you find a solution to your problem?

I have the same problem with a range of Iphones sixes, which Iphone are you using?


tsukada

Beginner

  • "tsukada" started this thread

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

5

Monday, March 14th 2016, 11:55am

Hi Sean,

I didn't find any solution yet.
So I implemented exclusion of video hotspots from scene if device is iOS9 on iphone.

I tested iPhone6, 5, and simulator, but the only factor is iOS9.