You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

spacerywirtualne

Professional

Posts: 901

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

41

Friday, April 15th 2016, 10:04am

You can adjust depth and scale the same time - e.g. when using:
depth=1000 + scale=1
depth=500 + scale=0.5
depth=2000 + scale=2
depth=4000 + scale=4
the hotspot will always have the same size.

That means when the hotspot is farther away, it would need to be scaled more to get the same size.
Thank you Klaus for explanation.


I did not find information about the loadpanoscene() function in the example xml code or in the documentation. *confused*


Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

reza_shnia

Trainee

Posts: 90

Occupation: krpano freelancer || creating ideas & coding them || krpano developer

  • Send private message

42

Friday, April 15th 2016, 4:55pm

Phonegap Problem

Hi
I build a mobile application by phonegap and krpano 1.19-pr4.
I test my app in ios 9 and android 5 and every thing was fine.
but when i test my app in android 4.3 , i get this error :
Local usage with file:// urls is limited due browser security restrictions!

how can i solve it?

reza_shnia

Trainee

Posts: 90

Occupation: krpano freelancer || creating ideas & coding them || krpano developer

  • Send private message

43

Friday, April 15th 2016, 8:50pm

Hi
I build a mobile application by phonegap and krpano 1.19-pr4.
I test my app in ios 9 and android 5 and every thing was fine.
but when i test my app in android 4.3 , i get this error :
Local usage with file:// urls is limited due browser security restrictions!

how can i solve it?

Can i embed XML content directly inline of HTML file against importing XML file?
or can i get xml content from ajax request ?(in android i can get file content by ajax request.)

Scott Witte

Intermediate

Posts: 258

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

44

Saturday, April 16th 2016, 1:53am

<include if"..." Seems Broken?

The following code fails:

Source code

1
2
3
4
<skin_settings
    webvr="true"
/>
<include url="%SWFPATH%/plugins/webvr.xml" devices="html5" if="skin_settings.webvr == true" />

It worked in pr3. Is it a bug or my coding?

45

Saturday, April 16th 2016, 10:28am

Hi,
I build a mobile application by phonegap and krpano 1.19-pr4.
I test my app in ios 9 and android 5 and every thing was fine.
but when i test my app in android 4.3 , i get this error :
Local usage with file:// urls is limited due browser security restrictions!
For special usage cases where local usage is not blocked by the browser - use localfallback=none - see here:
http://krpano.com/docu/html/#localfallback

Can i embed XML content directly inline of HTML file against importing XML file?
Use xml=null in the embedding and in the onready callback call the loadxml() action to pass an inline xml as string.

It worked in pr3. Is it a bug or my coding?
No, there was a bug in pr3, it might have looked it worked because it was matching your current setting, but it wasn't correctly working - pr4 is correct now - see the note in the documentation about using if on includes - 'the variables in the if check need to be defined before the current xml gets loaded':
http://krpano.com/docu/xml/#if

Best regards,
Klaus

Scott Witte

Intermediate

Posts: 258

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

46

Saturday, April 16th 2016, 5:29pm

'the variables in the if check need to be defined before the current xml gets loaded':

OK. Trying to understand this. in your current setup, with the include directive for webvr.xml in vtourskin.xml, which itself is "included" by tour.xml, where/when could I define a variable that would switch including webvr on or off?

Scott Witte

Intermediate

Posts: 258

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

47

Saturday, April 16th 2016, 9:08pm

WebVR and Autorotation

The interaction between autorotation and simulated WebVR has changed in PR4. In PR3 when you move the mouse to move the display it pauses autorotation in the same way that manually dragging does normally. In PR4 there is no pause making for a less accurate simulation. I doubt that was intentional?

reza_shnia

Trainee

Posts: 90

Occupation: krpano freelancer || creating ideas & coding them || krpano developer

  • Send private message

48

Sunday, April 17th 2016, 4:07am

three.js

For special usage cases where local usage is not blocked by the browser - use localfallback=none - see here:
Thank you Klaus for explanation.

Another question :
I am using three.js in my project, after upgrading my project from krpano 1.19-pr3 to krpano 1.19-pr4, panorama does not shown in the scene.
Actually three.js add a black layer on the scene.

How can i solve it?


ChrisR

Beginner

Posts: 9

Location: Brooklyn

  • Send private message

49

Monday, April 18th 2016, 9:56pm

Hide/ Show Skin on start

Hi Klaus,

Thank you so much for this new release. It has definitely improved the handling of the videoplayer, which is tremendously helpful.

The issue I'm having right now is completely unrelated to that though.
I had built a tour where on the start of the first scene the skin is hidden. Once the users goes to the next scene, it becomes visible:
http://vuwstudio.com/vt/temp/show-hideskin/tour3.html

When I do this in PR4, it does not work properly:
http://vuwstudio.com/vt/temp/show-hideskin/tour4.html

I have done some troubleshooting and - as you can see from my example upload - the only difference is the tour.js file that is being used. I've renamed them for clearer labeling. Both tours were created with the standard features.

Is this a bug in PR4 or am I doing something wrong?

Thank you

Christian

jeromebg

Professional

Posts: 788

Location: Angers - France

Occupation: Photographer

  • Send private message

50

Tuesday, April 19th 2016, 10:00am

Hi Klaus,
You didn't answered about hotspot offset problem : krpano 1.19-pr4
Is it a bug ?
Thanx

51

Tuesday, April 19th 2016, 12:54pm

Hi,

about the bug reports - they are on my list for checking, I will answer here when I know more.

Best regards,
Klaus

jeromebg

Professional

Posts: 788

Location: Angers - France

Occupation: Photographer

  • Send private message

52

Tuesday, April 19th 2016, 2:02pm

Hi,

about the bug reports - they are on my list for checking, I will answer here when I know more.

Best regards,
Klaus

Ok, thanx Klaus !

360boy

Intermediate

Posts: 224

Location: Mexico City

Occupation: Virtual tours, Krpano coding, Graphic Design, Photographer, Panographer

  • Send private message

53

Wednesday, April 20th 2016, 3:07am

Initial HLOOKAT is possible now?

Hello Klaus,

As I remember initial "view.hlookat" wasn't possible to specify individually on each scene on previous versions for WEBVR, is it possible now with this release?

Thanx

Luis

tsukada

Beginner

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

54

Wednesday, April 20th 2016, 8:57am

Hello Klaus,


Thanks for your great work. I've been looking forward to this new release.

Now I'm testing video player with pr4 and found a problem.

When I set html5controls to true, in case of flat layer,
Using chrome or ie, the controls are not shown on mouse over, but they are shown on mouse click but the controls does not work at all.
FF does not show controls at all.
In case of distorted hotspot, the controls are not shown even when I click.

According to the document below,
http://krpano.com/plugins/videoplayer/#html5controls

html5controls attribute is still described.


How should I do to show and work the controls?

55

Wednesday, April 20th 2016, 10:14am

Let Internet Explorer never be forgotten

THAT IS AMAZING !!!!! *g* *g* *thumbup* Klaus the new version just made my week... until Internet Explorer came into my life. *cry* Which evokes my question oddly enough I can make it work with Mozilla firefox and not with Internet Explorer. Is this normal ?

Many thanks in advance.

Alaa


_______
Quick Update: I've used the KRPano test server and it works neatly with IE. Thus a quick observation opening the vtour.html directly with I.E doesn't work and requires the KRPANO test server

This post has been edited 1 times, last edit by "aelboudali" (Apr 20th 2016, 1:27pm)


56

Wednesday, April 20th 2016, 12:11pm

Minor bug : deeplinking / littleplanet view

Hi Klaus,



Copy/Paste URL of Deeplinking doesn't work if littleplanet view is true.

If I copy the the URL in this case and open a new window and paste the URL, it displays the nadir then returns to start view

Suggestion : you should add the option "zoom to cursor" in the skin settings

Thank's for all your job. I *love* KR Pano !

57

Thursday, April 21st 2016, 11:37pm

"Change Controlmode" not working with virtual tours

Apparently, "Change Controlmode" has no effect in virtual tours. With normal panos it works as expected.

Example here:
http://www.chiangmai.net/panoramas/chian…ep/virtual_tour


It remains in the "drag mode". I re-tested with version 1.18.2 and the function works normally.

Tested in FF 45 (Flash) and Chrome 50 (HTML5) on Linux (Opensuse)


Thanks!

58

Friday, April 22nd 2016, 10:30pm

Hi,
Apparently, "Change Controlmode" has no effect in virtual tours. With normal panos it works as expected.
The default setting was changed from 'moveto' to 'drag' (previously named 'drag2d') - and because of the renamed value the switch() action call in the older vtourskin.xml don't work and need to get updated.

That means - in the vtourskin.xml look for 'drag2d' and change it to 'drag'.

Best regards,
Klaus

stevenChen

Beginner

Posts: 18

Location: beijing, china

  • Send private message

59

Saturday, April 23rd 2016, 8:30pm

progress.progress value is always 0 when <Image type is sphere

hi klaus:
i find out when set <Image> label type to sphere, the progress.progress value is always 0
i tested in the offical loading-progress demo and just modified the code as below :

<!-- <preview url="http://krpano.com/tours/corfu/panos/achilleion-hof-unten.tiles/preview.jpg"/>
<image>
<cube url="http://krpano.com/tours/corfu/panos/achilleion-hof-unten.tiles/pano_%s.jpg?nocache=%$random%" devices="tablet|desktop" />
<cube url="http://krpano.com/tours/corfu/panos/achilleion-hof-unten.tiles/mobile_%s.jpg?nocache=%$random%" devices="mobile" />
</image> -->

<preview url="%SWFPATH%/pic/Park_preview.jpg" />
<image>
<sphere url="%SWFPATH%/pic/Park.jpg" />
</image>

Alexey Tkachenko

Professional

Posts: 752

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

60

Monday, April 25th 2016, 3:49pm

Hi!

New autorotate functions are very cool. But in one of my projects I have a pano where user must not stop autorotation in any way. How do I make autorotation ignore all user interaction and stay rotating constantly?
Regards,

Alexey

Similar threads