You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

tsukada

Beginner

Posts: 27

Location: Tokyo, Japan

Occupation: Programmer

  • Send private message

61

Tuesday, April 26th 2016, 6:40am

Hotspot not work on IE or Firefox after moving to scene

HI,

I found another problem.

Hotspot doesn't accept mouse event on IE(ver11) or Firefox(latest). On Chrome or with pr3, it does not happen.

I made a simple tour with two scenes that are created by droplet and attached two simple hotspots.

https://web5.abook.bz/vtour/


Here's how to reproduce.
1. Open the site above with IE or Firefox
2. Move to the next scene using control below.
3. Go back to the first scene using control(press left button)
4. Hover your mouse cursor on hotspot which is located on center.
You will notice the mouse cursor not change to hand style and even if you click nothing will happen.
5. Hover mouse on control below so that the cursor changes to hand.
6. Try no.4 process again then you notice cursor changes and onclick event become enabled.
*If you click thumbnail to move back to the first scene then the mouse event become enabled.


This doesn't occur with pr3, but I'd like to use pr4.
Any advice is appreciated.

62

Tuesday, April 26th 2016, 9:37pm

oculus

Forgive me if this has been addressed already, but will the panoramas work seamlessly with an Oculus? I have a potential job that wants to use one.

Thanks!

63

Wednesday, April 27th 2016, 3:04pm

Hi,
Another question :
I am using three.js in my project, after upgrading my project from krpano 1.19-pr3 to krpano 1.19-pr4, panorama does not shown in the scene.
Actually three.js add a black layer on the scene.
The reason for this problem is that the new krpano version tracks and caches the currently used internal WebGL 'program' - and Three.JS is changing the current WebGL program by its own and so messes that tracking.

In the next release (1.19-pr5) will be an new additional API to restore the current krpano internal WebGL program - and there will be an updated Three.JS plugin example (basically only one added line there).

Best regards,
Klaus

64

Wednesday, April 27th 2016, 3:19pm

The interaction between autorotation and simulated WebVR has changed in PR4. In PR3 when you move the mouse to move the display it pauses autorotation in the same way that manually dragging does normally. In PR4 there is no pause making for a less accurate simulation. I doubt that was intentional?
Will be fixed in the next release.

65

Wednesday, April 27th 2016, 3:30pm

As I remember initial "view.hlookat" wasn't possible to specify individually on each scene on previous versions for WEBVR, is it possible now with this release?
Use the lookat action from the WebVR plugin for this:
http://krpano.com/plugins/webvr/#lookat

E.g. add this code in the tour.xml:

Source code

1
2
3
<events name="webvr_hlookat" keep="true"
  onxmlcomplete="if(webvr AND webvr.isenabled, webvr.lookat(get(xml.view.hlookat)));"
  />
and remove all 'KEEPMOVING' occurrences from the vtourskin.xml.

Then the VR view will be automatically set to the initial view.hlookat value set in the current scene.

Additionally try also reducing the blending time to avoid the feeling of a 'hanging view' in VR in this case.

Best regards,
Klaus

66

Wednesday, April 27th 2016, 3:36pm

Hi,
i find out when set <Image> label type to sphere, the progress.progress value is always 0
Only whole files will be tracked.

I'm not fully sure now but so far I remember the browser don't send progress event when loading image files, there is only a complete event. That means the loading progress of one single image can't be tracked - and for one single image pano the progress.progress can be only 0.0 (on start and during loading) and 1.0 (when done).

67

Wednesday, April 27th 2016, 3:37pm

New autorotate functions are very cool. But in one of my projects I have a pano where user must not stop autorotation in any way. How do I make autorotation ignore all user interaction and stay rotating constantly?
Disable the user control:
http://krpano.com/docu/xml/#control.usercontrol

68

Wednesday, April 27th 2016, 3:40pm

Forgive me if this has been addressed already, but will the panoramas work seamlessly with an Oculus? I have a potential job that wants to use one.
Yes - krpano has full WebVR API support.

All you need is a WebVR capable browser - get one here (today I would recommend Chrome for this):
https://webvr.info/

Best regards,
Klaus

Alexey Tkachenko

Professional

Posts: 757

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

69

Wednesday, April 27th 2016, 4:14pm

New autorotate functions are very cool. But in one of my projects I have a pano where user must not stop autorotation in any way. How do I make autorotation ignore all user interaction and stay rotating constantly?
Disable the user control:
http://krpano.com/docu/xml/#control.usercontrol
I had userconrol disabled already, yes. Here's a small test:

http://vt.most-inform.com/bugs/autorotate/


The scene has the following code onstart:

Source code

1
onstart="autorotate.start();set(control.usercontrol, off);" 



But user interaction pauses autorotation anyway.
Regards,

Alexey

360boy

Intermediate

Posts: 224

Location: Mexico City

Occupation: Virtual tours, Krpano coding, Graphic Design, Photographer, Panographer

  • Send private message

70

Wednesday, April 27th 2016, 7:59pm

Dear Klaus,

Found a really annoying bug in TABLET/MOBILE when using textfield hotspots in this version. It seems PR4 is adding a default OX OY offset (more emphasized in mobile) which can't be removed manually (ox="0" oy="0") and really changes a lot the position of the hotspot in reference to the specified ATH and ATV. We use this textfields as text tags and now they're just not working at all. I could try to manually remove it but I'm not sure if it's "device independent". Please help us with in next release!

Also, thanks for your detailed explanation, this is exactly the point that I didn't remember:

Quoted

and remove all 'KEEPMOVING' occurrences from the vtourskin.xml.


I've felt always that freezing the view when changing from pano to pano feels strange, that's why we activated the KEEPMOVING option and from your explanation I see it's still interfering with the view assignation on the new scene in PR4. It will be perfect if we could overcome this fact in a future version as I think is the most comfortable way to blend between panos without "taking the image with you as you move your head" ;-) .

Cheers! *thumbsup*

Sergey74

Trainee

Posts: 128

Location: Russia, Chelyabinsk

Occupation: professional noob

  • Send private message

71

Wednesday, April 27th 2016, 9:43pm

After the last update Google Chrome Mobile on tablet Nexus 7 2012 stopped working krpano 1.19.4
In other browsers (firefox, opera) it works
Version 1.18.5 works everywhere
https://drive.google.com/open?id=0B9Qqnf…Z1FtYjRlcy1uZ28
translation difficulties *huh*

Scott Witte

Intermediate

Posts: 270

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

72

Wednesday, April 27th 2016, 11:02pm

WebVR dies in Chrome and FF on iOS?

Standard display works for me in Chome and FF on iOS. BUT.... click the WebVR icon and the pano disappears. Only the div's background image shows. Strangely the sound keeps playing for a while. Then the page reloads.

This did not happen in PR3 and is no problem in Safari iOS or in Chome or FF desktop.

Example: New Years Fireworks

Did I get some setting wrong?

UPDATE: After lots of testing I am pretty certain the problem is NOT with KRPano.
UPDATE2: And.... Seems PR4 is involved, weirdly. See post below.

This post has been edited 5 times, last edit by "Scott Witte" (May 4th 2016, 8:56pm)


Scott Witte

Intermediate

Posts: 270

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

73

Wednesday, April 27th 2016, 11:33pm

Fake VR broken in IE?

Fake VR doesn't seem to work properly in IE11 (desktop). When I go into VR mode it does not go full screen, moving (vs dragging) the cursor has no effect and the Fake VR mode message does not disappear. This was also the case with PR3.

Example: New Years Fireworks.

And this seems the same in Safari, although I can only test on my virtual mac (VMWare) on Windows.

This post has been edited 1 times, last edit by "Scott Witte" (Apr 27th 2016, 11:58pm)


74

Thursday, April 28th 2016, 6:57am

It seems PR4 is adding a default OX OY offset
That was already reported (a few posts before) and is already on my list. I'm not sure yet what could cause that, but I hope to find out soon.


think is the most comfortable way to blend between panos without "taking the image with you as you move your head
That's also already on my list, but that's more complex - it requires different viewing and rendering handling - the current horizontal viewing direction would need to be stored for the previous pano as kind of horizontal offset when changing the view for the new pano...

75

Thursday, April 28th 2016, 7:02am

After the last update Google Chrome Mobile on tablet Nexus 7 2012 stopped working krpano 1.19.4
Maybe the GPU driver of that device was blacklisted by Chrome?
Is there still WebGL support there?
It seems no.

The old krpano versions were using CSS3D as fallback in this case, but that's not a good solution for Chrome, because CSS3D in Chrome is buggy and broken in many ways. Some simple panos might work on some devices, but in many other cases it results in a broken output ('missing' tiles, Chrome broken software rendering artifacts).

76

Thursday, April 28th 2016, 7:20am

Fake VR doesn't seem to work properly in IE11 (desktop). When I go into VR mode it does not go full screen, moving (vs dragging) the cursor has no effect and the Fake VR mode message does not disappear. This was also the case with PR3.
The WebVR plugin switches in FAKE mode only to fullscreen mode when the browsers supports the Pointer Lock API - and the IE11 doesn't do that. That direct moving control mode in the fake mode is also only possible when the browser supports that API.

The Fake VR message isn't intended to go away (see the webvr.xml code).

Best regards,
Klaus

panomexico

Beginner

Posts: 17

Location: Deutschland / Mexiko

  • Send private message

77

Thursday, April 28th 2016, 11:27am

Hallo Klaus,

perfekt die neue Version, ich bin begeistert, dass jetzt bei den 360° Videos der Ton auf dem iPhone klappt :)

http://www.video360grad.com/videos_10919…o/videopano.xml

Ich habe das Video in 5 Auflösungen bereit gestellt, das iPhone und das iPad machen nur bis 2048x1024 mit, wie kann ich in der videopano.xml
die 4096x2048er Auflösung für die mobilen Geräte ausblenden, auf dem PC funktioniert die 4096x2048 Auflösung, deshalb möchte ich diese drin lassen.

<!-- add the video sources and play the video -->
<action name="add_video_sources">
videointerface_addsource('1024x512', '%CURRENTXML%/video-1024x512.mp4|%CURRENTXML%/video-1024x512.webm|%CURRENTXML%/iphone-audio.m4a', '%CURRENTXML%/video-1024x512-poster.jpg');
videointerface_addsource('1344x672', '%CURRENTXML%/video-1344x672.mp4|%CURRENTXML%/video-1344x672.webm|%CURRENTXML%/iphone-audio.m4a', '%CURRENTXML%/video-1344x672-poster.jpg');
videointerface_addsource('1920x960', '%CURRENTXML%/video-1920x960.mp4|%CURRENTXML%/video-1920x960.webm|%CURRENTXML%/iphone-audio.m4a', '%CURRENTXML%/video-1920x960-poster.jpg');
videointerface_addsource('2048x1024', '%CURRENTXML%/video-2048x1024.mp4|%CURRENTXML%/video-2048x1024.webm|%CURRENTXML%/iphone-audio.m4a', '%CURRENTXML%/video-2048x1024-poster.jpg');
videointerface_addsource('4096x2048', '%CURRENTXML%/video-4096x2048.mp4|%CURRENTXML%/video-4096x2048.webm|%CURRENTXML%/iphone-audio.m4a', '%CURRENTXML%/video-4096x2048-poster.jpg');

if(device.ios,
<!-- iOS Safari has a very slow 'video-to-webgl-texture' transfer, therefore use a low-res video by default -->
videointerface_play('1024x512');
,
videointerface_play('1920x960');
);
</action>

</scene>

VG Matthias

This post has been edited 5 times, last edit by "panomexico" (Apr 28th 2016, 12:04pm)


78

Thursday, April 28th 2016, 10:27pm

I haven't been able to figure out how to change default control mode from Move Control to Drag Control and default projection from Fisheye to Normal for videopano. Any ideas?

Also, is there a way to easily add Cardboard icon and functionality to the play bar?

Many thanks!

79

Friday, April 29th 2016, 8:43am

With the 1.19pr4 version hotspot with edge different from center have a 10px offset ?
It seems PR4 is adding a default OX OY offset
I found the reason now - it affects hotspots without zoom=true or distroted=true and an edge setting different to center. That problem was a more complex conflict with applying an internal zoom scaling to keep the hotspot size the same regardless of the current view zoom. That will be fixed in the next release (should be ready soon).

80

Friday, April 29th 2016, 8:46am

Ich habe das Video in 5 Auflösungen bereit gestellt, das iPhone und das iPad machen nur bis 2048x1024 mit, wie kann ich in der videopano.xml
die 4096x2048er Auflösung für die mobilen Geräte ausblenden, auf dem PC funktioniert die 4096x2048 Auflösung, deshalb möchte ich diese drin lassen.
Das liegt an Apple selbst - Apple erlaubt keine höheren Auflösungen im iOS Browser, obwohl die Hardware vieler iOS Geräte mehr könnte.

Um die höheren Auflösung für iOS auszublenden, einfach ein 'if(device.ios, ...);' um die entsprechende 'videointerface_addsource' Aufrufe legen.

Similar threads