You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

aschakel

Beginner

  • "aschakel" started this thread

Posts: 7

Occupation: Designer and coder

  • Send private message

1

Monday, June 6th 2016, 10:04am

Cannot hide Mobile VR Setup

I've this strange thing on my iPad in the WebVR viewer.

When I activate the VR Tour by a JavaScript call 'webvr.enterVR()' then the viewer enters the VR mode. That's OK.

But on my iPad it shows unknown device and the Mobile VR Setup screen. The problem is that I cannot click
on any button from there, like SAVE, RESET or CLOSE. I cannot hide this setup screen.
On my Iphone the setup screen is not activated, but I can also not CLICK in the tour to ENTER the VR Setup screen.
The other way around.

Both devices the iPad and iPhone (iOS 9.3.2) tested in Google Chrome and Apple Safari browser don't recognize touch on screen..

The Pano #ID is position:absolute and Z-index:9999 in CSS. I cannot think of any other possible error in this,
it's just the standard setting srcreen. It's going ok on the Android phone.

Anyone has have this problem before and know any solution?

2

Monday, June 6th 2016, 11:31am

Hi,

tablets are not intended for VR usage of course - or do you have a headset for a tablet ;-).

There the 'fake mode' runs and due the tablets are unknown devices with unknown screen sizes, the setup screen will be shown. Modifying that behavior is possible of course - that's all just in the webvr.xml helper xml and not part of the viewer or the webvr plugin.

Best regards,
Klaus

aschakel

Beginner

  • "aschakel" started this thread

Posts: 7

Occupation: Designer and coder

  • Send private message

3

Wednesday, June 8th 2016, 5:26pm

Haha oops, no I dont have a headset for a tablet. You are right!

Ive removed the button on the tablet now, that's working a lot better. No VR on tablets...