You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, June 23rd 2016, 10:59am

Android phones showing 'HTML5 Browser with CSS3D or WebGL support required'

Android phones showing 'HTML5 Browser with CSS3D or WebGL support required'

I have verified this on Android 4.4 , 5 and 6 versions.

8 out of 10 times krpano viewer doesn't create krpanoObject.

Is there any setting. tried changing 'html5': "only"

This post has been edited 2 times, last edit by "PratapDessai" (Jun 23rd 2016, 12:57pm)


2

Wednesday, June 29th 2016, 11:31am

Hi,

it basically means what it means - the device+browser combination doesn't support neither CSS3D nor WebGL (for what reasons whatever) - any without that it's not possible to show panos...

Best regards,
Klaus

3

Wednesday, June 29th 2016, 4:01pm

Hi,

it basically means what it means - the device+browser combination doesn't support neither CSS3D nor WebGL (for what reasons whatever) - any without that it's not possible to show panos...

Best regards,
Klaus

about this,i found in a certain browser on a certain mobilephone,when the same vtour in 1.19 pr3 that is fine,nothing go wrong,but when update viewer to 1.19 pr4 or 1.19 pr5,it show the warning ‘HTML5 Browser with CSS3D or WebGL support required' »’。

4

Wednesday, June 29th 2016, 5:10pm

Which certain browser and certain mobilephone?
And which example?
And how was it working?
With CSS3D or WebGL?
Singleres or multires?

5

Wednesday, June 29th 2016, 5:26pm

Below is my device details :
1. Android 4.4.4 - Samsung Duos - Inside App not working. On same device browser works file
2. Android 5.0 - Samsung s4 - Inside App not working. On same device browser works file

Error is "HTML5 Browser with WebGL or CSS3D support required!"

Looks like Samsung devices only. I m using -pr5

Note : I also had Nexus with Android 6.0, there was it was not working. But when I posterurl it started work. Not sure if posterurl is mandatory.


I was trying to fake device .. But couldn't get through. Any other alternative.

Below is my xml

<krpano version="1.19" bgcolor="#000000"><plugin name="gyro" ' +
'url="some https link/gyro2.js" ' +
'enabled="true"/><plugin name="video" ' +
'url.html5="some https link/videoplayer18.js" ' +
'posterurl="some https link/1x1.png" videourl="' +
'some https link/video-1024x512.mp4|some https link/silence.m4a" ' +
'pausedonstart="true" loop="false" enabled="true" preload="true" zorder="0" ' +
'align="center" ox="0" oy="0" width.no-panovideosupport="100%" height.no-panovideosupport="prop" ' +
'/> <image devices="html5"> <sphere url="plugin:video" /> </image> ' +
'<view hlookat="0" vlookat="0" fovtype="DFOV" fov="130" fovmin="75" fovmax="150" fisheye="0.35" /> ' +
'<security cors="off" /> </krpano>

6

Tuesday, July 12th 2016, 1:00pm

Also noted.. on Android 6.0 inside App, video plays but with blank white screen

7

Wednesday, July 13th 2016, 3:36pm

Hi Klaus,

Could you help me figure what would be reason and what workaround we could do to get this working in Android 4.4 version.

I have to only use the default webView in android app and webgl flag comes false there in android 4.4 and android 5

8

Tuesday, July 26th 2016, 8:17am

Problem got resolved after updating WebView on samsung with android 6 devices