You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

joekki

Trainee

  • "joekki" started this thread

Posts: 78

Location: Turku, Finland

Occupation: Panoramic photographer and web site builder

  • Send private message

1

Friday, July 15th 2016, 3:08pm

[solved] Loading video failed on IE & Android

Is there anything that can be done? I have checked mime-types etc. but I don't understand why this won't work.

https://paivalehdenmuseo.panoraamakuvat.…ttely-360-video

This is in the scene:

<plugin name="video" url.flash="plugins/videoplayer.swf" url.html5="plugins/videoplayer.js" videourl="Tytto_converted.mp4|panos/Tytto/Tytto.webm"/>
<image prealign="0|-15|0">
<sphere url="plugin:video"/>
</image>

I changed the path from panos/Tytto/Tytto.mp4 to the root, and tried another conversion but no luck. Chrome works fine.

This post has been edited 1 times, last edit by "joekki" (Jul 19th 2016, 5:41pm)


Umalo

Professional

Posts: 1,046

Location: Osijek, Croatia, EU

  • Send private message

2

Friday, July 15th 2016, 3:19pm

Are you sure webm is stored at: panos/Tytto/Tytto.webm

joekki

Trainee

  • "joekki" started this thread

Posts: 78

Location: Turku, Finland

Occupation: Panoramic photographer and web site builder

  • Send private message

3

Friday, July 15th 2016, 3:58pm

https://paivalehdenmuseo.panoraamakuvat.…ytto/Tytto.webm

Seems to be correct. IE complains about the mp4 file. I tried both paths.

joekki

Trainee

  • "joekki" started this thread

Posts: 78

Location: Turku, Finland

Occupation: Panoramic photographer and web site builder

  • Send private message

4

Tuesday, July 19th 2016, 5:40pm

solved

Just for the future researchers: Problem was somehow corrupted mp4 file. It at least was missing height and width in meta data. Converted it again with ffmpeg and now it works with IE/mobile.

Similar threads