You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, July 19th 2016, 9:25am

1.19-pr5 not working on iOS 8

(as requested to re-post from krpano 1.19-pr4 / 1.19-pr5)

Hi,
I've tried to upgrade from 1.18.6 to 1.19-pr5 because audio on iOS seems to work only with 1.19. Works fine on iOS 9, but I've noticed on a similar test device with iOS 8 (btw: also happens on iOS Simulator), that videos don't play at all, they just seem to be stuck at the beginning. If there is extra audio, only the audio plays.
I can reproduce it with the examples posted on your website:
http://d8d913s460fub.cloudfront.net/krpa…x.html?v=119pr5 (after click on play, only audio plays, video doesn't progress, play button still active in controls, progress bar not advancing)
http://d8d913s460fub.cloudfront.net/krpa…x.html?v=119pr5 (same as above, except there's no audio playing)
No relevant warnings in console.
Thank you and best regards, Ernst

2

Thursday, July 21st 2016, 6:55pm

Hey,
This is happening for me as well.

Cheers,

Plasmic

3

Thursday, July 21st 2016, 7:01pm

This is happening for me as well

Since pr4 and I can't find a download link to pr3 anymore which I believe was working?!

4

Monday, July 25th 2016, 8:35pm

Hi,

sorry, I don't have any iOS 8 test devices anymore (they are all already on iOS 9 and iOS 10 beta - and downgrading is blocked by Apple), but I will look for testing that case somehow. But generally it's strange, at the moment I can't image a reason now why iOS 8 shouldn't work...

Btw - I must admit I'm wondering how someone can be still on iOS 8 with the aggressive update reminders from Apple... ;-)


Quoted

Since pr4 and I can't find a download link to pr3 anymore which I believe was working?!
The viewer itself shouldn't be the reason, when then the videoplayer plugin (which is completely new in 1.19pr4) is the reason. Try using the videoplayer plugin from version 1.18.6 (this one is basically the same as the one in 1.19-pr3).

Best regards,
Klaus

5

Tuesday, July 26th 2016, 10:00am

Hi Klaus,
thanks for looking into this. According to Apple, 86% of iOS users are using iOS 9, with 11% still being on iOS 8 (data measured on July 18, 2016): https://developer.apple.com/support/app-store/
So it would be nice if iOS 8 would still work (especially if it is not complicated to support it).
As I've mentioned, you can also reproduce the issue in the Simulator, so if you have a Mac with Xcode, you don't need a device with iOS 8 for now.
Thanks again!

6

Thursday, July 28th 2016, 9:33pm

Hi,

after a very long day testing, I have found the reason now why iOS 8 wasn't working anymore:

Internally a 'video.load()' call was missing to get the video in a workable state.
Only iOS8 requires that call, iOS 9 and all other systems not.

In the next krpano release this will be fixed - then iOS 8 will work again.


It's also possible to apply a workaround for the current version - here an example:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
<action name="ios8workaround" type="Javascript">
    function applyworkaround()
    {
        if(caller.videoDOM.src)
            caller.videoDOM.load();
        else
            setTimeout(applyworkaround, 1);
    }
    applyworkaround();
</action>

<plugin name="video"
    	...
    	onvideoready="ios8workaround();"
    	...
    	/>


Best regards,
Klaus

7

Friday, July 29th 2016, 12:48pm

Thank you very much!

8

Friday, August 5th 2016, 10:27pm

Hi - iOS 8 will work again (1.19-pr6):
krpano 1.19-pr4 / 1.19-pr5 / 1.19-pr6

9

Tuesday, August 9th 2016, 11:47am

Thanks again!