You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Anoril

Trainee

  • "Anoril" started this thread

Posts: 69

Location: Paris, France

Occupation: Game Developer and Photographer

  • Send private message

1

Wednesday, August 31st 2016, 4:57pm

WebVR and Layer interaction

Hello all!

I'm trying to get this working:

A WebVR experience with an animated introduction.

The introduction consists in several logos and texts to be displayed, one after the other, in full-stage: a black background layer hides the 360 view while logos are displayed. At the end, I hide the background layer to get the user viewing the actual panorama.
I made this with simple delayed calls and it works fine.

But I want it to work with a VR headset. So I placed a "Start" button which triggers "webvr.enterVR(); startIntro();"
This works too: we enter VR mode and the introduction animation starts.

My point is that the introduction is played FULLSCREEN! I mean: Instead of having a 3d imersive view with the introduction displayed on EACH eye, the layers (background, images and texts) composing the introduction are displayed on BOTH eyes: a single image is cut in half, having a part seen on the left eye while the other part is seen on the right eye! Very disturbing...

How can I do?

First, to get the layers working, I set "vr" to "true" thus they are not removed when entering VR mode... But I supposed that's not enough...

Best regards,

Paul
« Quidquid latine dictum sit, altum sonatur »
Pentax stuff.