You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

41

Tuesday, May 16th 2017, 10:08pm

Hi! I want this version with vk.com included. Where can I get that? Thank you!

Will add in next release ;)

kabelbindix

Beginner

Posts: 6

Location: Kaiserslautern

  • Send private message

42

Saturday, July 8th 2017, 9:55am

Problems with mobile devices - android / ios

Good morning,

I uploaded 1 : 1 the plugin files to a server http://kabelbindix.bplaced.net/demo_snapshot/demo.html and no mobile device is running the panoshot plugin.
http://kabelbindix.bplaced.net has the same problems.
My desktop windows computer with firefox has no problems with those uploaded files and the plugin is running fine.

https://360images.fr/snapshot_demo/tour.html is OK with every device.

Where is my mistake.

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

43

Saturday, July 8th 2017, 11:37am

Hi,
It's just because your button do display the snapshot UI has devices="desktop" :
<layer name="show_snapshot_UI" align="bottom" url="panoshot/snapshot.png" onclick="show_snapshot(true);" y="50" devices="desktop"/>

Just remove devices="desktop" :)

kabelbindix

Beginner

Posts: 6

Location: Kaiserslautern

  • Send private message

44

Sunday, July 9th 2017, 1:06pm

Super, it runs - thank you for your fast and great support *smile*

45

Tuesday, August 22nd 2017, 5:47pm

feedback o snapshot plugin - following purchase

I've spent the last day working with the plugin.

Its very neat and I'll definitely be looking at using it in my virtual tours, some points:
  • facebook - when posting to facebook only the link to the virtual tour view is posted but no image, is there anyway to post an image?
  • linkedin - I could not get this to work, linkedin keeps saying - Unable to share this update at the moment
  • Instagram - could an API to Instagram be added?

look forward to your comments


Tim

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

46

Wednesday, August 23rd 2017, 10:57am

Hi Trek,
Facebook has removed the possibility to choose a custom picture when sharing a url... now only the og:image will be used by Facebook. Hope they will give a solution soon.
LinkedIn is working on my side ? Maybe try again.
Instagram only enable sharing from their mobile app

Best regards

47

Tuesday, September 5th 2017, 7:53pm

Here is an example of the url generated when sharing:

http://www.trekwireless.co.uk/lalitlondo…54,1.678,25.016


This works fine where the virtual tour has a single pano.

My problem is that the virtual tour has several pano's but the above syntax is not loading pano5, but the default pano, I normally load different pano's by using ?scenetoload=panoXX

and have the following xml:


<action name="startup">

if(scenetoload === null, set(scenetoload,pano3));

loadscene(get(scenetoload),blend(4));

So... how do I get sceneview to work where my xml has several pano's? is this a standard krpano feature or part of snapshot?

thanks
Tim

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

48

Tuesday, September 5th 2017, 8:27pm

So... how do I get sceneview to work where my xml has several pano's? is this a standard krpano feature or part of snapshot?


Hi trek, the default is :

Source code

1
2
3
4
5
	<action name="startup" autorun="onstart">
		if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
		loadscene(get(startscene), null, MERGE);
		if(startactions !== null, startactions() );
	</action>


Snapshot plugin sets the startscene var, but if you don't check for it and load if it exist it won't work.

Best regards

49

Wednesday, September 6th 2017, 10:23am

Thanks for the quick response, I will test this out today.

quick question... would it be possible to have the email text fields as variables so that they could be pano specific?

I am using the plugin for hotel virtual tours so would be great to be able to make the text relate to each pano, for example, 'here is a picture of the President Suite'

cheers
Tim

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

50

Wednesday, September 6th 2017, 10:28am

Thanks for the quick response, I will test this out today.

quick question... would it be possible to have the email text fields as variables so that they could be pano specific?

I am using the plugin for hotel virtual tours so would be great to be able to make the text relate to each pano, for example, 'here is a picture of the President Suite'

cheers
Tim

Wll add in the next release

51

Wednesday, September 6th 2017, 2:53pm

Re


<action name="startup" autorun="onstart">
if(startscene === null OR !scene[get(startscene)], copy(startscene,scene[0].name); );
loadscene(get(startscene), null, MERGE);
if(startactions !== null, startactions() );
</action>



This works fine, but I have another problem

In the startup section I normally use:


<action name="startup">

if(scenetoload === null, set(scenetoload,pano3));

loadscene(get(scenetoload),blend(4));

This lets the 'calling' html specify which scene to load, for example:

http://trekwireless.co.uk/lalitlondon/re…enetoload=pano5


If the scenetoload variable is not specified then pano3 will be the default scene that is loaded

so...

I could use startscene instead of scenetoload but my problem is that clients have the html string in their web pages, so not easy to change.

How can I use both startscene for example http://www.trekwireless.co.uk/lalitlondo…66,1.615,63.169

and my existing scenetoload parameter?

thanks in advance for help

Tim

fixed it *thumbsup* *thumbsup* *thumbsup*



if(scenetoload === null, set(scenetoload,pano3));


if(startscene === null, set(startscene,get(scenetoload)));


Therefore if scenetoload and startscene are null then the 'opening pano' is set to pano3


if scenetoload has been parsed as a parameter then this scene will overwrite the opening pano


likewise if startscene has been specified then this will be the opening pano as it only gets overwritten if it is null


this works because you would never specify both parameters, they are mutually exclusive !

This post has been edited 1 times, last edit by "trek" (Sep 6th 2017, 7:27pm)


52

Thursday, November 9th 2017, 12:32pm

Facebook thumb problem

Hi,
I have a problem with showing thumb on Facebook, where Ido mistake?

Thanks
Peter Farkaš has attached the following image:
  • Snímka obrazovky (25).png

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

53

Friday, November 10th 2017, 11:18am

Hi, send the link to the tour, without I can't debug anything...

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

55

Friday, November 10th 2017, 7:01pm


It works perfect on my side ?

56

Monday, November 20th 2017, 5:42pm


It works perfect on my side ?
But the preview does not appear on Facebook ...:
Peter Farkaš has attached the following image:
  • on-facebook.jpg

57

Monday, November 20th 2017, 8:45pm

Great job on this plugin

Hello,

I just wanted to say thanks for such a great plugin. I am working on a large tour and this is a wonderful addition. The tour is not complete and I have lots of UI/UX work to do, but this is a perfect addition. I added a camera icon to the control bar of a default UI and it works great. Still need to hook up FB and such, but very impressed with your work on this plugin. THANKS!!

http://visualconstruction.com/AFM/

R,

Loren

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

58

Monday, November 20th 2017, 9:08pm

But the preview does not appear on Facebook ...:

Still working fine for me ?


Hello,

I just wanted to say thanks for such a great plugin. I am working on a large tour and this is a wonderful addition. The tour is not complete and I have lots of UI/UX work to do, but this is a perfect addition. I added a camera icon to the control bar of a default UI and it works great. Still need to hook up FB and such, but very impressed with your work on this plugin. THANKS!!

http://visualconstruction.com/AFM/

R,

Loren

Thnx for your feedback.
Nice panos ! maybe you should limit maxpixelzoom to 1 as you already have a very good resolution ?

59

Tuesday, November 21st 2017, 11:49am

But the preview does not appear on Facebook ...:

Still working fine for me ?


Hello,

I just wanted to say thanks for such a great plugin. I am working on a large tour and this is a wonderful addition. The tour is not complete and I have lots of UI/UX work to do, but this is a perfect addition. I added a camera icon to the control bar of a default UI and it works great. Still need to hook up FB and such, but very impressed with your work on this plugin. THANKS!!

http://visualconstruction.com/AFM/

R,

Loren

Thnx for your feedback.
Nice panos ! maybe you should limit maxpixelzoom to 1 as you already have a very good resolution ?
It still does not work for me. Is there any special settings or permission in the Facebook app? Thank you

jeromebg

Professional

  • "jeromebg" started this thread

Posts: 793

Location: Angers - France

Occupation: Photographer

  • Send private message

60

Tuesday, November 21st 2017, 12:14pm

It still does not work for me. Is there any special settings or permission in the Facebook app? Thank you

No, facebook ap id is not required anymore...
Could you paste here the url displayed in the facebook share window adrees bar, I guess it's a cache problem on your side...

Similar threads