You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Alexey Tkachenko

Professional

  • "Alexey Tkachenko" started this thread

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

1

Wednesday, November 30th 2016, 1:02pm

Example - Mark visited spots

Hi)

I was working recently on this thing and it seems it may be useful for some of users here. Here's a small xml-only plugin to mark opened spots in some way.

How to use:

1) Include 'visited_spots.xml' into your tour.xml
2) Adjust 'visited_spots_check_settings'. There are only two settings now:
- 'style_to_check' - check if a hotspot belongs to that style and then do something
- 'what_to_do' - what actions to call from this hotspot (e.g. change crop, scale or smth else).

Here's working example (visited spots change crop to red):

http://vt.most-inform.com/bugs/visited/


Xml attached to the post. Enjoy! ;-)
Alexey Tkachenko has attached the following file:
Regards,

Alexey

Alexey Tkachenko

Professional

  • "Alexey Tkachenko" started this thread

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

2

Wednesday, November 30th 2016, 1:33pm

Small update here: added ability to mark also thumbs of the visited scenes (used mapspot png just for example).

Added some more settings:

Source code

1
visited_thumbs_icon="%SWFPATH%/skin/vtourskin_mapspotactive.png"		visited_thumbs_icon_align="rightbottom"		visited_thumbs_icon_x="0"		visited_thumbs_icon_y="0"		visited_thumbs_icon_scale="0.25"



Xml attached. *tongue*
Alexey Tkachenko has attached the following file:
Regards,

Alexey

This post has been edited 1 times, last edit by "Alexey Tkachenko" (Nov 30th 2016, 8:55pm)


Sergey74

Trainee

Posts: 128

Location: Russia, Chelyabinsk

Occupation: professional noob

  • Send private message

3

Wednesday, November 30th 2016, 2:41pm

Thank you, very good example!

наверх
в закладки
translation difficulties *huh*

Alexey Tkachenko

Professional

  • "Alexey Tkachenko" started this thread

Posts: 760

Location: Sevastopol, Crimea, Russian Federation

Occupation: Interpreting, Building virtual tours

  • Send private message

4

Wednesday, November 30th 2016, 3:43pm

Noted something strange happening in Edge, Win 10, Asus laptop. At first, I thought it's somehow related to this xml-plugin, but it seems no.

Here's the link without any xml added:

http://vt.most-inform.com/bugs/visited/test/

Test case:

1. Click right hotspot
2. Click 'previous pano" button.
3. All three spots are inactive for some time.

Seems strange, because I don't see this in Chrome and Firefox on the same laptop. *confused*
Regards,

Alexey

Tuur

Sage

Posts: 3,194

Location: Netherlands

Occupation: Krpano custom coding / Virtual Tours / Photography / Musician / Recording engineer

  • Send private message

5

Thursday, December 1st 2016, 1:14pm

Hi,

i find the issue also with Safari on all hotspots in the first scene ..on mac (latest);
Chrome an FF seem ok.

Tuur *thumbsup*
http://www.virtualtuur.com
Skype:studiotuur

6

Thursday, December 22nd 2016, 12:53pm

Thank you.

*thumbsup* *thumbsup*