You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, March 8th 2017, 10:07pm

Stereo video issue

So, I have an MP4 video file with side-by-side stereo content.

I wanted to test krpano's stereo video feature (mentioned here ). I set up a test like this:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
<scene name="outside" title="Outside Test">
	<plugin name="video"	
 		url.html5="%CURRENTXML%/plugins/videoplayer.js"
		url.flash="%CURRENTXML%/plugins/videoplayer.swf"
		pausedonstart="false"
		loop="true"
		volume="1.0"
		videourl="car.mp4"	
	 />
	<include url="skin/videointerface.xml" />
	<image>
		<sphere url="plugin:video" stereo="true" stereoformat="SBS" />
	</image>
	<view hlookat="0" vlookat="0" fovtype="DFOV" fov="110" fovmin="75" fovmax="150" distortion="0.0" />
</scene>


But this isn't working. I'm seeing the side-by-side video mapped over a sphere. When I click the 'VR' icon of the interface, I see the side-by-side video displayed twice, side-by-side. Am I missing something here?

Maybe I don't have the right expectations for this feature? What exactly should appear? Will the stereo halves be merged into a single view, which can then be switched (via the 'VR' button) back to stereo? Or does it do something else? Any help appreciated.

2

Tuesday, July 4th 2017, 1:20pm

Stereo

Hi philjms,

Not sure what you are expecting, but VR mode means indeed that the view is twice projected. With a small difference in angle, cause one view has to be seen with your left eye and the other with your right eye. Then your eyes and brain will merge it into a 3d image.
VR mode normally is seen with a vr device or cardboad mode on your phone. Hope this points you in the right direction.

Or I do not fully understand your question :)

3

Wednesday, July 5th 2017, 1:12am

Hi,

your xml code is wrong:

Source code

1
2
3
<image>
  <sphere url="plugin:video" stereo="true" stereoformat="SBS" />
</image>
The 'stereo' settings need to be at the <image> element.

Correct would be:

Source code

1
2
3
<image stereo="true" stereoformat="SBS">
  <sphere url="plugin:video" />
</image>

See here:
https://krpano.com/docu/xml/#image.stereo

Best regards,
Klaus