You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, March 29th 2017, 5:49pm

Open Polygonal Hotpots flashing closed periodically

Whenever I draw a polygon hotspot that is open, if the line spans the screen, it will occassionally 'flash' closed i,e, an additional segment will appear momentarily to create a closed polygon - any ide of a work around? :( thanks in advance

2

Sunday, April 2nd 2017, 8:02am

Hi,

you could enable the 'polyline' setting to draw a not-closing-lined polygonal instead of a filled one:
https://krpano.com/docu/xml/#hotspot.polyline

Best regards,
Klaus

3

Thursday, April 13th 2017, 3:15pm

Hi Klaus, this is what i am doing already - it seems to only happen when one end of the polyline is off screen (see red polygon hotspot in attached images) pline.png shows the hotspot as it should be, with an open end, however if I rotate round to far, the end point joins to the start with a new segment (see plineWithExtra.png), if i rotate back the extra segment disappears - me and my colleagues were wondering whether this could be related to end points being on different faces of a cube? n that may completely irrelevent, but it does only seem to happen with 'longer' hotspots which have one end point off screen...

fyi, see hotspotXml for hotspot xml definition
josh.burnett has attached the following images:
  • plineWithExtra.png
  • pline.png
  • hotspotXml.png

4

Wednesday, April 26th 2017, 2:03pm

any update ? :(

any update ? :(