You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Amedee

Beginner

  • "Amedee" started this thread

Posts: 33

Location: Brussels - Belgium

  • Send private message

1

Tuesday, October 20th 2009, 11:38am

[1.0.8 Beta8] User defined cursors and Handcursor

Hi!

I just came across the following: if you are using the user-defined mouse cursors and hover a plugin with 'handcursor="false"', then the cursor reverts to the default arrow.

Is this intended behaviour?

(When I have 'enabled="true" capture="false" handover="false"', I would like to keep the same mouse cursors inside or outside the plugin)

Tnx
Phil.

2

Wednesday, October 21st 2009, 11:26am

Hi,
Is this intended behaviour?
at the moment yes, currently the cursor will only stay with - enabled="false",
but for 1.0.8 beta 9 I have changed that, there the cursor will also stay with handcursor="false",

best regards,
Klaus

Amedee

Beginner

  • "Amedee" started this thread

Posts: 33

Location: Brussels - Belgium

  • Send private message

3

Thursday, October 22nd 2009, 9:34am

Great!

Tnx.
Phil.

4

Monday, October 26th 2009, 8:40pm

btw - here is an newer pre-release krpano.swf where this already should work:
krpano XMAS Edition - let it snow ;-)

Amedee

Beginner

  • "Amedee" started this thread

Posts: 33

Location: Brussels - Belgium

  • Send private message

5

Monday, October 26th 2009, 8:55pm

Mmmmh...

I'm afraid it does not...

Still reverts back to the arrow when I hover my plugin (which is just a PNG image)

NFO: krpano 1.0.8 beta 9 DEV (build 2009-10-21)
INFO: Flashplayer LNX 10,0,32,18 PlugIn
Phil.

6

Monday, October 26th 2009, 9:04pm

hmm, is "handcursor" set to "false"?

Amedee

Beginner

  • "Amedee" started this thread

Posts: 33

Location: Brussels - Belgium

  • Send private message

7

Monday, October 26th 2009, 9:26pm

Yep, otherwhise I would have a hand, not an arrow...

My testcase is not online, but I just have

Source code

1
2
3
4
<plugin name="backgnd" url="backgnd.png"
    	keep="true" visible="true" zorder="10" alpha="0.4" enabled="true" capture="false" handcursor="false"
    	align="bottom" width="100%" height="100" x="0" y="20"
    	/>


In the 'buttons' example file
Phil.

8

Monday, October 26th 2009, 9:41pm

I'm not sure why yet, but try also adding:

Source code

1
children="false"


or just:

Source code

1
enabled="false"

when it just a background image and don't need to be interactive,
this should also already work in beta 8,

best regards,
Klaus

Amedee

Beginner

  • "Amedee" started this thread

Posts: 33

Location: Brussels - Belgium

  • Send private message

9

Monday, October 26th 2009, 9:53pm

Both are working in term of cursor, but unfortunately I need to have both on "true" as I do have children.

My prefered workaround for the time being is not to use the custom cursors, and keep consistently the arrow.
Phil.