You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Friday, June 23rd 2017, 6:38pm

Chrome - loading video failed!

Hi Klaus,

mit der aktuellen Version (1.19.pr10) bekomme ich in Chrome keine Videos unter HTML5 mehr zum laufen, sofern der Rundgang in einem geschützten Serververzeichnis liegt. Egal, was ich auch versuche!
Ich habe es mit MP4 und WEBM getestet und habe sämtliche Pfadvarianten durchprobiert. Der Pfad muss jedoch zwangsläufig stimmen, da es in Firefox keine Probleme gibt.
Dieser Fehler tritt auch NUR auf, sobald ich den Rundgang auf einem Server teste und auch nur dann, wenn er in einem geschützten Verzeichnis liegt. Lokal oder in einem ungeschützten VZ, mit dem krpano-testing server läuft es auch unter Chrome. Ich habe auch mehrere Server bei verschiedenen Hostern getestet, allesamt mit dem gleichen Ergebnis.

Die Videodateien sind ebenfalls fehlerfrei, da sie A) bei direkter Adresseingabe im Browser fehlerfrei angezeigt werden und B) ich es sogar mit Deinem cats-video aus Deinem Beispiel versucht habe.

Wieso kann ich in Chrome Videodateien auch in geschützten VZ direkt abspielen, aber krpano kann auf diese Videos nicht zugreifen?

Dank und Gruß,
Nupsi

This post has been edited 1 times, last edit by "Nupsi" (Jun 27th 2017, 1:04pm)


2

Tuesday, June 27th 2017, 1:04pm

Hi Klaus,

hättest Du für o.g. Problem evtl. einen Lösungsansatz parat? Zeit ist hier leider ein nicht unwesentlicher Faktor, da der Kunde den Rundgang nicht korrekt angezeigt bekommt. Auf meine Mail (~05/2017) habe ich leider auch keine Antwort erhalten *unsure*

Viele Grüße,
Nupsi

3

Wednesday, June 28th 2017, 2:31pm

Hi,

manche Browser (ich glaube Chrome und IE) benötigten bei http-Passwort-geschützten Dateien die CORS Einstellung 'use-credentials' (warum auch immer).

In krpano kann dies so gesetzt werden:

Source code

1
<security cors="use-credentials" />


Quoted

Auf meine Mail (~05/2017) habe ich leider auch keine Antwort erhalten
Sorry, die habe ich entweder nicht erhalten oder übersehen oder auch noch nicht gelesen (ich bekomme Zeitweise mehr Mails als ich leider lesen und beantworten kann).

Schöne Grüße,
Klaus

4

Monday, July 3rd 2017, 11:26am

Funktioniert bestens! Vielen Dank *thumbsup*

Gruß,
Nupsi