You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Mael B.

Trainee

  • "Mael B." started this thread

Posts: 149

Location: France, Montpellier

  • Send private message

1

Friday, August 25th 2017, 12:08am

Example "A video as distorted hotspot" not working on my mobile phone

Hi,

I just realize that the Example "A video as distorted hotspot " is not working well on my mobile phone when i try with Firefox (Android 6.0.1 (rv:55.0) - Firefox 55.0 - WebGL) : only the first frame seems to be displayed (or it is the posturl image) and only the sound is played :(
But curiously, it's working fine with Chrome 60.0 - WebGL.

I've almost the same behaviour with one of my own pano : http://photo.maelbathfield.net/hitme/ (except the videos are fully black with Firefox).

Is somebody esle having the same issue ??

2

Wednesday, August 30th 2017, 5:22pm

Hi,

right, there seems to be a general problem WebGL video textures in Android Firefox 55.

I was just testing Android Firefox 54 and it was working fine but after updating to Firefox 55 the video stop working...

Event this technically super simple example fails:
https://krpano.com/ios/bugs/ios8-webgl-video-performance/

That means that this a Firefox bug and that this could be only fixed on Firefox side.

Best regards,
Klaus

Mael B.

Trainee

  • "Mael B." started this thread

Posts: 149

Location: France, Montpellier

  • Send private message

3

Saturday, September 2nd 2017, 11:46am

Thanks Klaus for this answer :)

4

Tuesday, September 12th 2017, 3:12pm

Hi guys,

I noticed the same problem a couple of days ago. It started with version 55.0

Last week I filed a bug report with Mozilla, here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1395543


If you want to add relevant technical information for them, please do.
They already reacted that they will pick this up. One of the guys from Kolor already added some information.

I hope this can be solved as this is the last mobile browser able to use in WebVR mode.

Thanks, Johan

benji33

Intermediate

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

5

Wednesday, September 13th 2017, 1:37pm

Here is a comment of a Mozilla Dev member : https://bugzilla.mozilla.org/show_bug.cgi?id=1395543#c5
"users need to disable anti-aliasing for WebGL context, otherwiser, on some mobile devices, it indeed will be black."

Can it be a solution Klaus ?

6

Thursday, September 14th 2017, 11:24am

Hmm...

In that example:
https://krpano.com/ios/bugs/ios8-webgl-video-performance/

antialias of the WebGL canvas is/was already disabled (see the page-source!) and it's still black...

Beside of this, krpano also disables antialias by default for mobile devices...

So that can't be the reason!
That's a core bug and need to be fixed in Firefox, there is no other solution.

Best regards,
Klaus

7

Friday, September 15th 2017, 9:50am

Hi Claus,

I just read the Bugzilla feedback and also your comment on this Forum.
Do you mind feeding that back to them too?
My technical knowledge is too low, but your observation looks quite valuable for the process.
It's good to read that it's pick up on all sides (krpano, kolor and mozilla) ... hopefully there's a solution soon.

Many thanks, Johan