Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

81

Montag, 6. November 2017, 14:25

WebVR on the iphone

Oops... well it was my own fault. I had the iPhone set on “rotation lock”.
All’s well now.

Btw, if you want to have some fun viewing the gardens at les Quatre Vents, try this: http://www.etpanorama.com/QuatreVents/VR/index.html

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »dave360« (6. November 2017, 15:01)


benji33

Fortgeschrittener

Beiträge: 244

Wohnort: France

Beruf: Senior Software engineer

  • Nachricht senden

82

Dienstag, 7. November 2017, 16:40

Is it a known issue with text layers in VR ?

If I create a layer through addlayer() and set its properties and the parent property with a hotspot ID, my spot and my text layer are not visible when entering VR.

Sample :

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
<hotspot name="spotpoint"
ath="112.814930"
atv="1.401869"
url="myImage.jpg"
distorted="true"
depth="1000"
onclick=""
tooltip="My tooltip text"
visible="true"
onloaded="showTooltip();"
/>

<action name="showTooltip">
set(tooltipForSpot, "myTooltipForPointSpot");
addlayer(get(tooltipForSpot));
set(layer[get(tooltipForSpot)].distorted, true);
txtadd(layer[get(tooltipForSpot)].parent, 'hotspot[', get(name), ']');
set(layer[get(tooltipForSpot)].align,bottom);
set(layer[get(tooltipForSpot)].edge,top);
set(layer[get(tooltipForSpot)].enabled,false);
set(layer[get(tooltipForSpot)].capture,false);
set(layer[get(tooltipForSpot)].visible, true);
set(layer[get(tooltipForSpot)].type, 'text');
set(layer[get(tooltipForSpot)].bg,false);
set(layer[get(tooltipForSpot)].bgborder,0);
set(layer[get(tooltipForSpot)].txtshadow,'1.0 1.0 4.0 0x000000 1');
set(layer[get(tooltipForSpot)].css,'color:#ffffff;font-family:Arial;font-weight:bold;font-size:14px;text-align:center;');
set(layer[get(tooltipForSpot)].interactivecontent, false);
set(layer[get(tooltipForSpot)].zorder,0);
set(layer[get(tooltipForSpot)].padding,2);
set(tooltipHtmlText, get(tooltip));
escape(tooltipHtmlText);
set(layer[get(tooltipForSpot)].html, get(tooltipHtmlText));
</action>

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »benji33« (7. November 2017, 16:54)


Beiträge: 715

Wohnort: Angers - France

Beruf: Photographer

  • Nachricht senden

83

Dienstag, 7. November 2017, 21:58

my spot and my text layer are not visible when entering VR.

No layer support in VR, and no child/parent

84

Dienstag, 7. November 2017, 22:35

bug when update pr12 to pr13 , style and scope related ?

hi,

when updating project from pr12 to pr13 there a new bug,
i think it's may be related to new "scope" feature for Styles,
i use style to assign custom action to my UI buttons (OnUp) as is :

UI btn :

Quellcode

1
<plugin name="icon_infos_retina" style="onover_style" ...


style :

Quellcode

1
2
3
<style name="onover_style"
		onup="txtadd(customised, 'button_ui_action.',get(name));customised();"
		keep="true" preload="true" blendmode="normal" autoscale="false" handcursor="true"/>


array of actions for UI btn :

Quellcode

1
2
3
4
5
6
7
<button_ui_action 
icon_thumbs_retina="action(drawer_switch);"
		icon_infos_retina="action(infos_switch);"
		icon_sound_on_retina="action(resume_sound);"
		icon_sound_off_retina="action(pause_sound);"
		icon_controls_retina="action(drawer_controls_switch);"
/>


all runs fine with pr12,
but when using pr13 it doesn't trigger the correct action and console show : WARNING: Unknow action: customised

so what's the workaround ??
or pr14 will fix it ?

thanks *smile*

z

85

Mittwoch, 8. November 2017, 09:19

Hi,

when updating project from pr12 to pr13 there a new bug,
i think it's may be related to new "scope" feature for Styles,
i use style to assign custom action to my UI buttons (OnUp) as is :

That's because the new version checks when calling sometime like 'customised()' and 'customised' is a variable, if that variable even contains some actions code.

This is done to avoid problems when defining variables that have the same names as actions.
E.g. when there is an <action> named 'test' and also a variable name 'test', then the 'test' variable would be called (now only if it contains code).

In your case the 'customised' variable has this value:

Quellcode

1
button_ui_action.icon_infos_retina
But that's not a valid call (but still working in normal cases because of a 'syntax tolerance').
A correct/valid call would look like this ( with the () ):

Quellcode

1
button_ui_action.icon_infos_retina()


You could change that in your code by adding a '()' in the txtadd:

Quellcode

1
txtadd(customised, 'button_ui_action.',get(name),'()');


Best regards,
Klaus

86

Mittwoch, 8. November 2017, 11:14

Hello.
I seem to have found a problem. If I change limitview="auto" to limitview="fullrange" for Flat Images, the image doesn't load correctly. I seem to be seeing a mix of image tiles from different zoom levels when trying to view the full image.

Regards
James.

benji33

Fortgeschrittener

Beiträge: 244

Wohnort: France

Beruf: Senior Software engineer

  • Nachricht senden

87

Mittwoch, 8. November 2017, 11:23

Thanks Jérome :)

benji33

Fortgeschrittener

Beiträge: 244

Wohnort: France

Beruf: Senior Software engineer

  • Nachricht senden

88

Mittwoch, 8. November 2017, 11:24

Hello.
I seem to have found a problem. If I change limitview="auto" to limitview="fullrange" for Flat Images, the image doesn't load correctly. I seem to be seeing a mix of image tiles from different zoom levels when trying to view the full image.

Regards
James.


Yes it's a pr12/13 issue.
Will be corrected into pr14.

89

Mittwoch, 8. November 2017, 15:32

scrollarea plugin and Update() Action

Zitat

You could change that in your code by adding a '()' in the txtadd:

Thanks , working now *thumbsup*

another fix i need :

i'm trying to use the new update(); Action for scrollarea plugin but i get warning :

the scrollarea plugin within layers :

Quellcode

1
2
3
4
5
<layer name="scroll_text" visible="false" handcursor="false" keep="true" type="container" align="lefttop" edge="lefttop" y="0" width="100%" height="100" zorder="7" bgcolor="0x00CCFF" bgalpha="0.0">
		 <layer name="scrollable_text" url="plugins/scrollarea.js" .........  >
                <layer name="textfield_infos" url="plugins/textfield.swf" ........... />
</layer>
</layer>


to call update :

Quellcode

1
layer[scrollable_text].update();


but console throw me a warning as :

Quellcode

1
WARNING: Unknown action: plugin[scrollable_text].update 


How to correct ?

thanks

z

90

Donnerstag, 9. November 2017, 14:12

hi Klaus

Speaking of autolevel / remap parameter

now the off setting works well thanks :)

but it doesn't seam to remap to the north when using remap option

would it be possible to have these options?

Quellcode

1
2
3
4
5
off : no change

level : just levelling the image no north remap

remap : levelling + remap to the north



best regards

91

Freitag, 10. November 2017, 16:27

"ERROR: HTML5 Browser with WebGL support required!"
Klaus Wrote: and when that WebGL is not supported there, there is not much that could be done (except of changing the GPU card or maybe trying to update the GPU drivers).
Fixed , updating the GPU drivers

Thanks Klaus , as usual

92

Montag, 13. November 2017, 19:21

set hotspots style

Hello Klaus,

thank for the fantastic update and your great work! krpano is an important foundation of my profession.

With the update from pr12 to pr13 I have detected a little problem: With starting VR-mode I like to align the styles of my hotspots. The following code has functioned bevor updating to pr13:

Quellcode

1
2
set(style[skin_hotspotstyle].scale, 0.33);
set(style[info].visible, false);


Now I get the following message in the trace-box:

Quellcode

1
2
WARNING: plugin[webvr]: set style[skin_hotspotstyle].scale=0.33 - 'style' is not an array! 
WARNING: plugin[webvr]: set style[info].visible=false - 'style' is not an array!


Is this ab bug or is there any other another workaround to solve this problem?

Best regards
Stefan

93

Montag, 13. November 2017, 21:42

try this:
set(global.style[skin_hotspotstyle].scale, 0.33);
set(global.style[info].visible, false);

94

Montag, 13. November 2017, 22:15

Hi,
With the update from pr12 to pr13 I have detected a little problem: With starting VR-mode I like to align the styles of my hotspots. The following code has functioned bevor updating to pr13:
set(style[skin_hotspotstyle].scale, 0.33);
set(style[info].visible, false);
Now I get the following message in the trace-box:
WARNING: plugin[webvr]: set style[skin_hotspotstyle].scale=0.33 - 'style' is not an array!
WARNING: plugin[webvr]: set style[info].visible=false - 'style' is not an array!
Is this ab bug or is there any other another workaround to solve this problem?

The problem was already reported a few posts above ;-)
In the next release it will be fixed.

Please see here for more:
krpano 1.19-pr13

Best regards,
Klaus

95

Dienstag, 14. November 2017, 07:30

Thank you for your answers!

@indexofrefraction: Thank you, this ist the solution for my problem!
@klaus.krpano: I should have read the last posts better. Thank you for fixing it in the next version. :-)

Best regards,
Stefan

96

Dienstag, 14. November 2017, 08:50

Hi Klaus,

Can you confirm my question about Theta remapping?

As i read on some docs it has a built in compas so it should indicate the real north right?

But when i use remap option the images aren't remapped to the north

Thanks for you advise

97

Mittwoch, 22. November 2017, 15:37

new editor: pb with tooltip on mapspot

hello Klaus,

with the new editor it is impossible to show tooltip on mapspot... in skin settings i put "tooltips_mapspots="true"" but it doesn't work...
it could be very useful to see tooltip on mapspot, do i have to use the old editor for that??
Thank's a lot for your answer

98

Donnerstag, 23. November 2017, 16:44

textfield is not selectable in html5

Hi Klaus,

With the new PR4, I find that the textfield is not selectable anymore.
With PR3, and variable selectable="true", I can select the text

It's something in .js since PR4 to cause the problem
P.S. both "interactivecontent" and "selectable" are set to "true"

99

Dienstag, 28. November 2017, 20:20

It's something in .js since PR4 to cause the problem
P.S. both "interactivecontent" and "selectable" are set to "true"

If you're using the textfield as hotspot add also renderer="css3d".
Textfields rendered via WebGL can't have interactive content.

Best regards,
Klaus