You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, October 9th 2017, 6:14pm

Gear VR and Oculus Browser: resetsensor not working?

I've started to use Gear VR with my tours, using the native Oculus Browser, and I've found that is really much better than firefox or Chrome Browser in therms of smooter images, no lags, etc.

I've only a problem now on how to give the desidered viewing direction when I enter in VR mode: I have setted the correct direction with my hlookat and vlookat parameters, and all works fine if I use Firefox and Chrome and also in desktop of my pc, but using Oculus Browser all the view direction remain the same of the previous scene (like having keepview activated).

So first question: anyone have found a similar trouble?

In order to resolve, I've tryed to reset the sensor in VR mode.

So I've tryed to add this line in my tour.xml:

onstart="if(webvr AND webvrisenabled, webvr.resetSensor(20,0))"

or also

onstart="if(webvr AND webvrisenabled, webvr.hlookat(22))"

but it seems that both don't work.

Could anyone help me?
GIOLETS has attached the following file:
  • tour.xml (21.83 kB - 1 times downloaded - latest: Nov 6th 2017, 3:51pm)

2

Tuesday, October 10th 2017, 7:52pm

Hi,

this will be fixed in the next release:
Gear VR - Oculus Browser / Samsung Internet

Best regards,
Klaus