Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Dienstag, 24. Oktober 2017, 23:44

External media files

Hello all,

This seems like a trivial matter, but it is bugging me now several workdays, and I just cant figure it out ! Am I overlooking something? I need a third person to look at my issue...

This is because my client is hosting the player on a cloud server, and the media files are hosted on a CDN.

I have the following basic XML doc:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
<krpano version="1.18" bgcolor="0x000000">
	
	<view hlookat="0" vlookat="0" fovtype="MFOV" maxpixelzoom="1.0" limitview="fullrange"/>
	<image hfov="1.00" voffset="0.00" prealign="0|0|0">
	
	<!-- cylinder url="http://localhost/image21.JPG"/ -->
	<cylinder url="http://someone.blob.core.windows.net/project/00/FroudeHofmann_Content/image21.JPG"/>
	</image>
	<control mousetype="drag2d" zoomtocursor="false" zoomoutcursor="false" mouseaccelerate="1.0" mousespeed="10.0" mousefriction="0.8" mousefovchange="1.0" keybaccelerate="0.09" keybfriction="0.94" keybfovchange="0.25" fovspeed="3.0" fovfriction="0.9" bouncinglimits="true" touchfriction="0.9"/>
	<cursors standard="default" dragging="move" moving="move"/>
	
	<contextmenu fullscreen="false" versioninfo="false" />
</krpano>


This is hosted from a html page linking to the krpano.js. The krpano loads fine, and the http://localhost/image21.JPG image displays fine in it.

When I change to the remote url http://someone.blob.core.windows.net/pro…ent/image21.JPG (url changed due to IP, but you can use any external image), I just cant get the image to load. The image also has a HTTPS variant; both are not working in the player.

However, when pasting the url directly in the browser, there are no problems viewing all of the images.

Im aware that the crossdomain.xml needs to be present for the flash version to work, but this is tested with html5 set to 'always' and I can clearly see the canvas element in dom-developer mode.

Am I missing something? Does the player load external images? Can someone give me some additional hints/pointers/suggestions?

2

Donnerstag, 26. Oktober 2017, 14:12

Hi,

enable CORS on the external server:
https://enable-cors.org/server.html

Best regards,
Klaus