Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

21

Dienstag, 5. Dezember 2017, 14:16

Hi,

Ich ziehe ein equi. Bild auf das Droplet "MAKE PANO (NORMAL)". Das Ausgangsbild hat das sRGB-Profil (sRGB IEC61966-2.1) eingebettet. Folgende Dateigrößen werden druch krpano erstellt, ich nehme ein erstelltes Würfelbild als Vergleich:

Option "skip" (praktisch ohne Profil): pano_b.jpg - Dateigröße: 957 KB
Option "sRGB": pano_b.jpg - Dateigröße: 1095 KB (hier wird ein sRGB-Profil eingebettet, welches sRGBz heißt)
Option "copy": pano_b.jpg - Dateigröße: 902 KB (hier wird das korrekte Profil weitergereicht)

Komischerweise wird die Dateigröße bei der Option "copy" gegenüber der Option "skip" kleiner und nicht wie von Dir beschrieben größer. Ich finde das wunderbar, denn genau diese Funktion habe ich in den letzten krpano-Versionen vermisst. Aber warum wird die Datei kleiner?

Das 'skip' größer ist als 'copy' ist eigentlich nicht möglich - in beiden Fälle bleiben die RGB Werte in der Datei die gleichen, was dann auch die gleiche Bytegröße für das Bild nach der JPEG-Kompression ergeben sollte. Das 'copy' Bild sollte zusätzlich noch um die Größe des Farbprofiles größer sein (~1-32kb).

D.h. meine einzige Erklärung hier wäre das falls gemessen oder falsche Dateien vergleichen wurden...

Oder es wurde eine Demo-Version getestet - durch die zufälligen Wasserzeichen und die JPEG-Kompression kann sich die Dateigröße bei jedem Durchlauf um einiges unterschieden...

Du kannst mir aber gerne das Bild zum Testen schicken, dann kann ich dies nachprüfen, obwohl ich mir hier ziemlich sicher bin das dies richtig funktioniert (hab dies gerade auch noch einmal getestet).

Schöne Grüße,
Klaus

Tourvista

Fortgeschrittener

Beiträge: 254

Wohnort: Leicester UK

  • Nachricht senden

22

Dienstag, 5. Dezember 2017, 14:43

Thank you Klauss!

That did the trick and now it's working OK.

23

Dienstag, 5. Dezember 2017, 16:17

Oder es wurde eine Demo-Version getestet - durch die zufälligen Wasserzeichen und die JPEG-Kompression kann sich die Dateigröße bei jedem Durchlauf um einiges unterschieden...
Sorry, es war tatsächlich eine Demo-Version, da ich zum Zeitpunkt an meinen Zweitrechner saß und nicht darauf geachtet hatte...

MfG

tksharpless

Schüler

Beiträge: 63

Wohnort: Philadelphia, Pennsylvania

Beruf: Retired S/W engineer

  • Nachricht senden

24

Mittwoch, 6. Dezember 2017, 03:42

3D TV support

Hi Klaus

I'm very happy to see in this release some support for displaying stereo panos on 3D TV.

But side-by-side anamorphic mode is not enough. You should at least provide over/under anamorphic as well -- it usually gives more satisfactory stereo.

And for 4K passive 3D TV (which will soon be the standard for home theater) the interlaced format is much the best. I urge you to add that to the next release. It is easy to implement as a shader.

Best,
-- Tom

25

Mittwoch, 6. Dezember 2017, 13:31

Icon Issues

Hi klaus.
There seems to be a problem with the control bar on both iOS and Android.

On my Galaxy S8+, there's no initial view of the Gyroscope icon until I rotate my phone from Portrait to Landscape, or the other way around. There's also no 4 arrows for rotating the image ever shown either.

iOS 11.2 (iPad Air 2) also has the exact same Gyroscope issue, but does display the 4 arrows for moving the image fine.

On various Android Tablets, the Gyroscope icon won't load at all for me.

Kind regards
James.

ninerian

Anfänger

Beiträge: 40

Wohnort: Zwickau

Beruf: Softwareentwickler

  • Nachricht senden

26

Mittwoch, 6. Dezember 2017, 16:18

Issues vor Samsung VR Browser

Hello Klaus,

thank you for the steady development.

Unfortunately their occured a bug in this release, which regards the Samsung VR Browser.

When I start the WebVR Example and click on Start VR, the Browser goes fullscreen, but Web VR isn't initialized.
In the console the warning: submitFrame must be called within a VRDisplay.requestAnimationFrame callback. is logged.

360boy

Fortgeschrittener

Beiträge: 211

Wohnort: Mexico City

Beruf: Virtual tours, Krpano coding, Graphic Design, Photographer, Panographer

  • Nachricht senden

27

Samstag, 9. Dezember 2017, 02:26

Zitat

Klaus: Sorry, not sure what you mean - and related to the event processing nothing had been changed. With which version do you compare your case?


I mean some custom events are called twice on first load. This is a quick example, I inserted this code in a tour created with MAKE VTOUR (MULTIRES) Droplet:

Quellcode

1
<events	name="test_event" keep="true" onnewscene="trace(hello!);"/>


Which on first load renders this at console:

Quellcode

1
2
3
4
5
INFO: krpano 1.19-pr14 (build 2017-12-01)
INFO: HTML5/Desktop - Firefox 57.0 - WebGL
INFO: Registered to: Imagen360.com
INFO: hello!
INFO: hello!


After first load just got one "hello!" on all other scenes but twice at first one. And I found this to hapen as well with onxmlcomplete event but not with onnewpano or onpreviewcomplete.

Haven't looked this at detail but you may want to check it out.

Best *thumbup*

Luis

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »360boy« (9. Dezember 2017, 20:08)


Beiträge: 710

Wohnort: Angers - France

Beruf: Photographer

  • Nachricht senden

28

Montag, 11. Dezember 2017, 09:36

25% offset when mobilescale is not set

HI, there is a bug in pr14, whe mobilesacle is not set (so 0.5 by default) then hotspots width edge different than center are offset by 25% the height or width of the hotspot on mobile.

Barebone here

29

Dienstag, 12. Dezember 2017, 17:13

Hi,

And for 4K passive 3D TV (which will soon be the standard for home theater) the interlaced format is much the best.
Sorry, but as written by mail I disagree here (and I have two 4K passive 3D TVs here for testing) - many TVs are processing the input signal in the one or the other way, e.g. in my tests the TVs were always converting the 4K RGB signal internally to YUV420 - and for 'software-side-interlaced' pictures this is a bad thing! And it's also bad when the PC resolution doesn't exactly fit the screen resolution or when the TV does some scaling or overscan processing.
E.g. Try taking a interlaced picture, save it as color-sub-sampled jpeg and/or scale it a bit.

The way more compatible and problem-free solution is sending the 3D image as Top-Bottom or Side-By-Side image. All 3D TVs should have an option to select the type of the 3D-input-signal. This way the TV can prepare the image by itself for its individual physical 3D output.


On various Android Tablets, the Gyroscope icon won't load at all for me.
Which browser and devices do you use?
There was recently an Android Chrome bug that avoids using the gyroscope, but latest Chrome versions should work fine so far I know...


HI, there is a bug in pr14, whe mobilesacle is not set (so 0.5 by default) then hotspots width edge different than center are offset by 25% the height or width of the hotspot on mobile.
Thanks for the report, I can confirm that - in WebGL-rendered hotspots without zoom=true or distorted=true some offsets (align and ox/oy) were not stage-scaled. In the next release this will be fixed.

Best regards,
Klaus

30

Freitag, 15. Dezember 2017, 09:13

options plugin not working

hi, Klus, I've added code to xml file and put options.swf in plughin folder as usual, but the options interface doesnt show up at the right corner when I load the tour.xml to krpano Tools.exe , please advise. ths!

Midhat

Anfänger

Beiträge: 26

Wohnort: Sarajevo, Bosnia & Herzegovina

  • Nachricht senden

31

Montag, 18. Dezember 2017, 14:56

My virtual tour has about 150 panoramas and the new VTourEditor very slowly loads when adding a new hotspot.
toureditor.html was much faster, but now it does not work anymore (flash problem). Is there a way to speed up a new VTourEditor, or make the old one with flash is working for me again?


Thanks in advance,
midhat

Mael B.

Schüler

Beiträge: 98

Wohnort: France, Montpellier

  • Nachricht senden

32

Dienstag, 19. Dezember 2017, 00:24

My virtual tour has about 150 panoramas and the new VTourEditor very slowly loads when adding a new hotspot.
toureditor.html was much faster, but now it does not work anymore (flash problem). Is there a way to speed up a new VTourEditor, or make the old one with flash is working for me again?


Thanks in advance,
midhat
Actually, toureditor.html is still working by using Safari for windows (with windows seven) ;-)

33

Dienstag, 19. Dezember 2017, 09:53

Hi,
hi, Klus, I've added code to xml file and put options.swf in plughin folder as usual, but the options interface doesnt show up at the right corner when I load the tour.xml to krpano Tools.exe , please advise. ths!
The options.swf plugin is a Flash plugin and works only in the krpano Flash Viewer.
But the viewer in the krpano Tools application and the default viewer in the most browsers is the HTML5 viewer.

So to use the options.swf start the viewer in a browser that supports the Flashplayer (you might need to manually enable/active/unlock the Flashplayer usage) and e.g. add '?flash=only' to the url.


My virtual tour has about 150 panoramas and the new VTourEditor very slowly loads when adding a new hotspot.
toureditor.html was much faster, but now it does not work anymore (flash problem). Is there a way to speed up a new VTourEditor, or make the old one with flash is working for me again?
I will look to make that faster.
Using the Flash vtoureditor.swf plugin is still possible, just use a Browser with Flashplayer support. All desktop browsers are basically still supporting Flash, but you might need to enable/whitelist it manually in the browser settings.

Best regards,
Klaus

Midhat

Anfänger

Beiträge: 26

Wohnort: Sarajevo, Bosnia & Herzegovina

  • Nachricht senden

34

Dienstag, 19. Dezember 2017, 17:49


I will look to make that faster.
Using the Flash vtoureditor.swf plugin is still possible, just use a Browser with Flashplayer support. All desktop browsers are basically still supporting Flash, but you might need to enable/whitelist it manually in the browser settings.

Best regards,
Klaus
Thank you.
I use Chrome and I have allowed flash for my site, but I have the following error:

ERROR: Calling action 'loadscene' failed! Parameter count mismatch!

jordi

Fortgeschrittener

Beiträge: 406

Wohnort: Barcelona

Beruf: creating ideas & coding them

  • Nachricht senden

35

Donnerstag, 28. Dezember 2017, 12:32

I have been trying to use // inside an event without success, it breaks the action at this point. Maybe here once krpano execute it became a single line, and that's the reason ? not sure.

In previous version it was not supposed to work but if you ended the line with a semicolon it worked.

Maybe that was also related to the events stuff that 360boy mentioned above.
visita3d.com advanced virtual tours
a new way to communicate

36

Donnerstag, 28. Dezember 2017, 13:18

I have been trying to use // inside an event without success

i think // is only allowed inside actions
if you break the xml syntax that can't work

37

Donnerstag, 28. Dezember 2017, 15:28

Hi,
I have been trying to use // inside an event without success, it breaks the action at this point. Maybe here once krpano execute it became a single line, and that's the reason ? not sure.
That's a core xml limitation - line-breaks inside xml attributes are getting automatically normalized to one space character by the browser. That means the krpano HTML5 viewer itself never receives line-breaks inside attributes.

The '// comment' itself works up to the next line-break - and because in attributes there will be never a line-break character, it comments the whole remaining code in this case.

In previous version it was not supposed to work but if you ended the line with a semicolon it worked.
In previous versions there was no official or real '//' comment support - but there was only a 'little' one - there the '//' characters were not filtered or marked and so they become a part of the action-call name and action calls with '//' were simply skipped. So these could be used so comment-out one action call. But now with the real // support that's not possible anymore.

Best regards,
Klaus

tonesh

Schüler

Beiträge: 68

Wohnort: Rome

Beruf: Photographer

  • Nachricht senden

38

Freitag, 29. Dezember 2017, 13:30

Hotspots flag in web-VR

Hi,
I can't change the flag for hotspots operating in web-vr.
If I set something like this, in for example "onentervr",

Quellcode

1
set(style[skin_hotspotstyle].loadscene_flags, KEEPVIEW);

the flag still remains in MERGE setting.
Maybe I'm doing something wrong, but trying for example "scale",

Quellcode

1
set(style[skin_hotspotstyle].scale, 0.5);

is working well.

(modified some days later)

here I've put here a very simple project that can explain the problem:
all the "flags" are set to KEEPVIEW, in all versions are working well except
the webvr where the passing from a scene to the other is in MERGE flag.
In vtourskin.xml the code in "skin_webvr_setup" action was modified like this:

Quellcode

1
<action name="skin_webvr_setup">	if(webvr.isenabled,	copy(skin_settings.loadscene_flags_backup, skin_settings.loadscene_flags);	set(skin_settings.loadscene_flags, KEEPVIEW);


Error checked with krpano 1.19-pr14 on iOS, with chrome, safari, firefox apps.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »tonesh« (7. Januar 2018, 11:52)


39

Dienstag, 2. Januar 2018, 22:11

Hi Klaus

I've tested the pr14 with my Samsung Galaxy Note 4.
When I start the tour in portrait and roate to landscape, fullscreen starts
correctly (and it shows me also the icon in the playerbar).
When I rotate back to portrait fullscreen ends (and it shows me also the icon
in the playerbar), but it doesn't resize to fullscreen.
I have around 10% black screen on the bottom side (see screenshot).

When I enter fullscreen manually before I rotate it doesn't exit fullscreen when I rotate back to portrait and it resizes correctly.


Problem happens to me on Samsung Galaxy Note 4 on:
Chrome 63.0.3239.111
Chrome canary 65.0.3309.0
Opera 44.1.2246.123029

No issues with :
Samsung internet 6.2.01.12
Opera mini 32.0.2254.122976
Firefox 57.0.1


When I replace the tour.js with the tour.js generated from version pr13 it solves me the problem.
But thats probably not the solution *tongue*


Best regards

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »vope« (3. Januar 2018, 12:22)


40

Donnerstag, 4. Januar 2018, 13:48

Dear Klaus!

It seems that mailto: and tel: href links inside html plugins aren't working since version pr14. They worked just fine in pr13. In pr14 when the user clicks on such a link, the background goes dark and there is some kind of a js error in the console. Can you confirm this? Is there any workaround?

Ähnliche Themen