You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

41

Thursday, January 4th 2018, 3:44pm

webvr 1.19pr14 and macos 10.10 yosemite with safari 10.1.2

hi klaus,

i dont know if that is pr14 related but when i go to webvr with safari 10.1.2 on macos 10.10 yosemite,
then the exit/setup buttons are displayed, but i can't look around, the view is locked.

on sierra with the newest safari it works normally, also on yosemite and the newest firefox,
so it doesnt look to be an issue of the tour itself.

is there a known issue with safari on yosemite?

best, index

ps. there is no error in the console

This post has been edited 1 times, last edit by "indexofrefraction" (Jan 5th 2018, 4:16pm)


42

Monday, January 8th 2018, 4:54pm

Hi,
If I set something like this, in for example "onentervr",
set(style[skin_hotspotstyle].loadscene_flags, KEEPVIEW);
In the default vtourskin.xml there is no 'loadscene_flags' setting in the skin_hotspotstyle style, so when you do that nothing will happen of course.

If you want to change the loadscene flags that will be used by the loadscene calls in the vtourskin.xml, you would need to change 'skin_settings.loadscene_flags' variable.

43

Monday, January 8th 2018, 4:56pm

I've tested the pr14 with my Samsung Galaxy Note 4.
When I start the tour in portrait and roate to landscape, fullscreen starts
correctly (and it shows me also the icon in the playerbar).
When I rotate back to portrait fullscreen ends (and it shows me also the icon
in the playerbar), but it doesn't resize to fullscreen.
I have around 10% black screen on the bottom side (see screenshot).
The wrongly scrolled page after exiting the fullscreen mode is an Android Chrome bug and there is no workaround so far I know.

When I replace the tour.js with the tour.js generated from version pr13 it solves me the problem.
But thats probably not the solution *tongue*
You can also disable the (new) autofullscreen setting, then it will work like before (but it will not anymore switch automatically to fullscreen when rotating to landscape):
https://krpano.com/docu/xml/#display.autofullscreen

44

Monday, January 8th 2018, 5:01pm

It seems that mailto: and tel: href links inside html plugins aren't working since version pr14. They worked just fine in pr13. In pr14 when the user clicks on such a link, the background goes dark and there is some kind of a js error in the console. Can you confirm this? Is there any workaround?
No I can't confirm this!
I have just tested mailto: and tel: now and its working.

45

Monday, January 8th 2018, 5:04pm

i dont know if that is pr14 related but when i go to webvr with safari 10.1.2 on macos 10.10 yosemite,
then the exit/setup buttons are displayed, but i can't look around, the view is locked.
Older Safari versions don't have pointer-lock support, so a free looking around with the mouse is not possible there. But moving the view via dragging (normal controlling) should work (that's the internal fallback for this case).

46

Tuesday, January 9th 2018, 5:02pm

It seems that mailto: and tel: href links inside html plugins aren't working since version pr14. They worked just fine in pr13. In pr14 when the user clicks on such a link, the background goes dark and there is some kind of a js error in the console. Can you confirm this? Is there any workaround?
No I can't confirm this!
I have just tested mailto: and tel: now and its working.
Well, the error is still there. Mind you, the mailto itself works, as my default e-mail client opens and the address gets in there as it should, but like I said the background of the panorama goes dark, and here's the error I get in the console:

Uncaught TypeError: Cannot read property 'style' of null
at K (eval at embedpanoJS (krpano.js:11), <anonymous>:1:146537)
at V (eval at embedpanoJS (krpano.js:11), <anonymous>:1:151571)
at Object.Dd.U.renderpano (eval at embedpanoJS (krpano.js:11), <anonymous>:1:174667)
at Object.a [as updateview] (eval at embedpanoJS (krpano.js:11), <anonymous>:1:114959)
at Qf (eval at embedpanoJS (krpano.js:11), <anonymous>:1:29159)
at c (eval at embedpanoJS (krpano.js:11), <anonymous>:1:232226)


What I have discovered is I get the very same error by simply reloading (CTRL+R) the tour. The reload happens ok, but right before the page unloads this error flashes up in the console. In this case of course it doesn't really have any ill effects, but it does with the mailto and tel links.

Klaus, any idea what might be causing this? I definitely didn't have any of this with pr13...

47

Tuesday, January 9th 2018, 5:19pm

the background of the panorama goes dark

What 'background' do you mean and how can it go dark...?

Sorry, but generally - without knowing your case/example I can't help.
Maybe open a thread and post there all details - example-links, browser, system and so on...

48

Tuesday, January 9th 2018, 11:42pm

the background of the panorama goes dark

What 'background' do you mean and how can it go dark...?

Sorry, but generally - without knowing your case/example I can't help.
Maybe open a thread and post there all details - example-links, browser, system and so on...
Ok, I did, please take a look if you can!

49

Wednesday, January 10th 2018, 12:01pm

When i enter VR Mode on a Samsung Galaxy Note 8, the device isn`t supported?

50

Thursday, January 11th 2018, 2:16pm

Older Safari versions don't have pointer-lock support, so a free looking around with the mouse is not possible there. But moving the view via dragging (normal controlling) should work (that's the internal fallback for this case).

dear klaus, sorry, i dont understand...

i use <control usercontrol="all" mouse="drag" touch="drag" /> which is the default, i think...

i also checked with a freshly made vtour using the droplet (1.19pr14):
on safari 10.1.2, macos 10.10 yosemite, if you switch to webvr,
the view is stuck und and you cant look around

i can confirm the pointerlock-api doesnt work on that safari version,
but there seems to be no fallback....

is there anything i can do about that ?

This post has been edited 1 times, last edit by "indexofrefraction" (Jan 11th 2018, 2:33pm)


ninerian

Beginner

Posts: 40

Location: Zwickau

Occupation: Softwareentwickler

  • Send private message

51

Friday, January 12th 2018, 9:16am

the background of the panorama goes dark

What 'background' do you mean and how can it go dark...?

Sorry, but generally - without knowing your case/example I can't help.
Maybe open a thread and post there all details - example-links, browser, system and so on...


I discovered the error too. It seems the renderCycle is evaluated, after the krpano DOM element is removed. And in the script it tries to access the style property of that element. But while the element is gone, its throwing the undefined error.

52

Friday, January 12th 2018, 12:31pm

I discovered the error too. It seems the renderCycle is evaluated, after the krpano DOM element is removed. And in the script it tries to access the style property of that element. But while the element is gone, its throwing the undefined error.

Please see: strange mailto: and tel: link behaviour

53

Friday, January 12th 2018, 12:36pm

When i enter VR Mode on a Samsung Galaxy Note 8, the device isn`t supported?
It depends what you mean - via WebVR and GearVR it should definitely work (e.g. in the Oculus Browser).

If the 'MobileVR' mode will work depends if your device is already listed in the Cardboard database:
https://krpano.com/plugins/webvr/#mobilevr_database_url
Here the default database source:
https://github.com/WebVRRocks/webvr-polyfill-dpdb

But even when not in the list yet, then only the physical screen-size is unknown and it should be possible to enter it once manually (the default webvr.xml should ask for it).

benji33

Intermediate

Posts: 244

Location: France

Occupation: Senior Software engineer

  • Send private message

54

Friday, January 12th 2018, 3:07pm

The addhotspot(name); method doesn't work for webgl textfield hotspots ?

55

Friday, January 12th 2018, 3:31pm

The addhotspot(name); method doesn't work for webgl textfield hotspots ?
Sure it works!

56

Friday, January 12th 2018, 3:35pm

on safari 10.1.2, macos 10.10 yosemite, if you switch to webvr,
the view is stuck und and you cant look around

i can confirm the pointerlock-api doesnt work on that safari version,
but there seems to be no fallback....
I have no OSX 10.10 system here for testing yet (but already started partitioning and installing one) but it might be possible that this Safari version already has the Pointerlock API itself but a not working one (or a buggy one). If that's the case I would need to blacklist that API for a certain Safari version range.

Sergey74

Trainee

Posts: 124

Location: Russia, Chelyabinsk

Occupation: professional noob

  • Send private message

57

Monday, January 15th 2018, 8:47am

A small error in the documentation https://krpano.com/docu/xml/#view.camroll
The link (control.camrollreset) in the description does not lead anywhere
translation difficulties *huh*

58

Monday, January 15th 2018, 8:57am

A small error in the documentation https://krpano.com/docu/xml/#view.camroll
The link (control.camrollreset) in the description does not lead anywhere
Thanks for the note!

59

Tuesday, January 16th 2018, 3:40pm

ERROR: copy(startscene,scene[0].name) - invalid variable name: 123

Hi.
step 1. create tour using "MAKE VTOUR (MULTIRES) droplet.bat"
step 2. open it and change URL to something like this: http://192.168.0.13:64544/tour.html#123
step 3. reload the browser page
Get an error: ERROR: copy(startscene,scene[0].name) - invalid variable name: 123
I think this issue is about of addEventListener and attachEvent

This post has been edited 4 times, last edit by "sblack" (Jan 16th 2018, 3:58pm)


spacerywirtualne

Professional

Posts: 872

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

60

Tuesday, January 16th 2018, 6:28pm

ERROR: copy(startscene,scene[0].name) - invalid variable name: 123
Probably you have invalid scene name. A Number name is restricted. Show us the link or tour.xml file.

More here

Piotr
You own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: facebook group :: youtube

cms4vr team *thumbsup*