Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »360gradenfotografie« ist der Autor dieses Themas

Beiträge: 39

Wohnort: Tilburg, The Netherlands

  • Nachricht senden

1

Freitag, 22. Dezember 2017, 14:10

Sound Interface - Oncomplete bug?

When I pay a sound like this...

Quellcode

1
2
3
4
5
6
playsound(
  soundid,
  get(soundfile1),
  1,
  oncompleteaction();
);


... and after finishing, I play another sound with the same id...

Quellcode

1
2
3
4
5
6
playsound(
  soundid,
  get(soundfile2),
  1,
  oncompleteaction();
);



... the oncomplete actions don't fire.

They do fire when I use a different id for the second sound. I need the id to be identical, because otherwise a user interaction is needed for every new sound.

Is this a bug? Or is there a way to fire oncomplete actions after re-assigning an id to a sound?

2

Donnerstag, 28. Dezember 2017, 15:59

Hi,

what krpano version are you using?

That should be fixed since 1.19-pr12:
https://krpano.com/forum/wbb/index.php?p…72133#post72133

Zitat

Fix: Soundinterface Plugin - playing a completed sound again wasn't working correctly.


Best regards,
Klaus

  • »360gradenfotografie« ist der Autor dieses Themas

Beiträge: 39

Wohnort: Tilburg, The Netherlands

  • Nachricht senden

3

Mittwoch, 3. Januar 2018, 17:10

what krpano version are you using?

That should be fixed since 1.19-pr12:
https://krpano.com/forum/wbb/index.php?p…72133#post72133

Zitat

Fix: Soundinterface Plugin - playing a completed sound again wasn't working correctly.


I'm using 1.19-pr14. The problem is not that the sound isn't playing, but that oncomplete actions aren't firing when using an id more than once.

  • »360gradenfotografie« ist der Autor dieses Themas

Beiträge: 39

Wohnort: Tilburg, The Netherlands

  • Nachricht senden

4

Dienstag, 20. Februar 2018, 15:17

Hi Klaus,

Any idea about this?

Hope to hear from you.

Ähnliche Themen