You are not logged in.

Dear visitor, welcome to Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.


Tuesday, January 9th 2018, 5:57pm

Enbale GYRO but not STEREO

Hi there,
I am getting better with this awesome plugin. But i am having trouble getting the Gyro button to show and be enabled when using an iPad. I do NOT want the Stereo goggle button visible. I just want the user to be able to click on the Gyro button if they are using an iPad.

It seems that WEBVR needs to be enabled/true for the Gyro button to work? I have tried adding the stereo=false but that doesnt work either.

Any advice for me?


Tuesday, January 9th 2018, 9:17pm


the default vtourskin.xml has already a gyro supported integrated.

That means don't set gyro=false in the tour.xml and add manually another gyro plugin, just keep the default one enabled and press the gyro icon to enable the gyro control.
And if you want to have the gyro enabled from startup - edit the vtourskin.xml and look there for the gyro plugin and set its 'enabled' setting to 'true'.

Btw - the gyro control and WebVR-suport and two independent things and are not related together.

Best regards,


Wednesday, January 10th 2018, 2:28pm

Thanks for the reply. I understand what you say. I am still having trouble with getting the gyro button to work. I can get the gyro functionality to work. But the button does not show.

I will keep trying and post back if i need more help.

Thanks again.


Friday, January 12th 2018, 6:42pm

I am still having trouble with getting the gyro button to work

What kind of trouble?
There would be nothing todo manually...

Or do you have an old iPad 1? - that's the only iPad without gyroscope sensor.