You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, February 26th 2018, 12:18am

Keep Getting Booted Out of iOS WebVR

I'm having a serious problem that, for the life of me, I cannot figure out. I've done a million tests to try and eliminate the variables, but no luck.

Basically, whenever I'm viewing my virtual tour via WebVR stereoscopic on my iPhone 7 Plus, I eventually get booted back to the 2D start scene.

This can happen in any of the 17 scenes. It can happen right after getting into a new scene....or up to a minute or more later.

I suspect it might have to do with the HTML5-VR Audio Plugin by spacerywirtualne, but I'm not 100% certain. When I get rid of 3D sounds but leave in 2D sounds, the crash doesn't happen - at least not yet, anyway. No sound files also result in no crash.

The crash never happens when viewing 2D on the computer.

I'm running an iPhone7 Plus, iOS 11.2.6, krpano 1.19-pr14, and HTML5-VR Audio Plugin ver 3.1.0

I've not had any issue like this before.

Here's a link to the tour:

http://virtualtour.hermanmiller.com/soundTest


Any help would be much appreciated.

2

Monday, February 26th 2018, 8:33am

maybe check if all your sound files are encoded the same ways
(bitrate and other options when encoding)
i had issues with downloaded audio files and it was better when i re-encoded all the same way

3

Monday, February 26th 2018, 6:16pm

Tnx indexofrefraction,

All of my sound files are:
mp3
16000Hz
32bit
32kbps CBR OFL

Are you using the HTML5-VR Audio Plugin?

4

Monday, February 26th 2018, 7:22pm

no, but i remember getting problems with audio files when cbr and vbr or bitrates were mixed...
i did some tests at that time ... my notes say: mp3, vbr, 41.1 khz for all files

5

Tuesday, February 27th 2018, 7:34pm

spacerywirtualne, the creator of the sound plugin, is checking out the sound files/folder to see if he can spot any issues. Will post back here if anything is found.

6

Wednesday, February 28th 2018, 10:20am

Hi,

with 'booted back to the 2D start scene' you mean a page-reload by Safari because the page has crashed?

That could happen when using too much resources - e.g. when using way too large images. Try checking the pixel-size (not the file-size) of all included images.

Best regards,
Klaus

7

Thursday, March 1st 2018, 12:22am

Klaus, thanks for the suggestion. Each of my cube images are 1536x1536 - which is a very standard size. Reducing the size would mean a pretty significant quality hit.

I did, however, save the overall jpg quality down to get all the images nearly half the file size. The tour still crashed in Safari.

However, I did a test in Chrome on the iPhone (even though you can't get rid of the menu bar) and it made it though the entire tour (including playing all the sound files) with no problem at all.

My guess is that something in Safari is the problem; perhaps connected with the sound plugin I'm using.

8

Thursday, March 1st 2018, 10:31am

as said, try to re-encode all files with mp3, vbr, 41.1 khz
clear your caches, restart, and then see if it still crashes.
in my tests cbr and non-standard hz settings did lead to crashes,
specially when playing multiple files at the same time.

EDIT: these experiences are about safari/ios
about other browers i dont know.

This post has been edited 1 times, last edit by "indexofrefraction" (Mar 1st 2018, 12:37pm)


spacerywirtualne

Professional

Posts: 907

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

9

Thursday, March 1st 2018, 10:45am

My guess is that something in Safari is the problem; perhaps connected with the sound plugin I'm using.
Safari is full of errors in this matter, that's why I did not share this droplet. Safari is restarting all the time - and safari only, even on strong iPad Air II. *angry*


Kind regards
Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

10

Thursday, March 1st 2018, 2:43pm

as said, try to re-encode all files with mp3, vbr, 41.1 khz
clear your caches, restart, and then see if it still crashes.
in my tests cbr and non-standard hz settings did lead to crashes,
specially when playing multiple files at the same time.



indexofrefraction, I'm re-encoding now. Did you mean 44.1hz? 41.1 seems like a non-standard frequency. ?? Tnx

11

Thursday, March 1st 2018, 3:23pm

ups, yes ofc 44.1 the standard
and btw webaudio also worked better here than html5 audio
but i dont know if you can choose that in piotrs plugin

i also think it is a problem of safari/macos/ios ...
are you testing on these? or on another browser, os?

12

Thursday, March 1st 2018, 8:12pm

Tnx index. Yeah, chrome works just great - no crashes - on both iOS and the latest android. I’m going to test the new sound file encoding and report back.

13

Thursday, March 1st 2018, 11:08pm

Well, I changed every sound file to 44.1Hz, VBR but it still crashes in Safari iOS.

14

Friday, March 2nd 2018, 8:34am

sorry it didnt help you...
i have my own audio solution, and here strict encoding worked.
now you can only disable features one by one
to find what is causing those crashes.

15

Friday, March 2nd 2018, 7:51pm

Yeah, tnx. I did discover that no sound files = no crashes. No 3D sounds = no crashes. Even if I have just one scene with 3D sounds it will eventually crash.

What audio solution are you using? Does it have both 2D and 3D sounds?

spacerywirtualne

Professional

Posts: 907

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

16

Friday, March 2nd 2018, 10:56pm

Hi

I build a small project with your audio files here:

http://spacerywirtualne.pl/krpano/audio_error/


Check this. On my iPhone 5s works grates.

Kind regards
Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

17

Saturday, March 3rd 2018, 10:21am

.. i have my own audio plugin,
but not 3d, yet

spacerywirtualne

Professional

Posts: 907

Location: Poland, Europe

Occupation: krpano developer : virtual tours

  • Send private message

18

Saturday, March 3rd 2018, 11:14am

.. i have my own audio plugin,
but not 3d, yet
My post was dedicated for andrvr1 *cool* *squint*

Piotr
Your own online, cloud tool for creating virtual tours - www.cms4vr.com

facebook page :: youtube

cms4vr team *thumbsup*

19

Saturday, March 3rd 2018, 5:10pm

Piotr, I didn't have any crashes with your test scene, but many times when I would go to play a sound file in WebVR the first half second of the sound is cut-off. This was also a problem with my tour - the first time you play a 3D sound.

I'll keep testing your tour to see if it crashes. Sometimes on my tour it would not occur until you are at the 6th or 7th scene - sometimes later.

Tnx