You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

bazaar

Trainee

  • "bazaar" started this thread

Posts: 57

Location: Bourgogne, Savoie, Ardèche, France..

Occupation: Photography and Virtual tours

  • Send private message

1

Sunday, March 11th 2018, 5:20pm

No zoom / Flat image filling to get a simple background

Hi all, i need an advice:
I need to fill the window with a flat photography. Vertical or horizontal screen, there should be no black stripes around the image.

Then, this image have to be not interactive, or zoomable (with mouse, keyboard, fingers or other ways..), just immobile, and the cursor not active.

Just to serve as a simple fitted background for other layers.

I tried different fov types, HFOV, VFOV, DFOV, MFOV.. DFOV seemed nice, but when the aspect ratio of the screen turns to vertical (less than 1:1), then it doesn't works..

limitview="auto" seemes a way..

I don't care if the photo is cropped.

Does anyone have an idea?
Thank you very much,
Regards

Scott Witte

Intermediate

Posts: 270

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

2

Sunday, March 11th 2018, 9:16pm

If I'm not mistaken you want limitview="range" and control.usercontrol="off"

bazaar

Trainee

  • "bazaar" started this thread

Posts: 57

Location: Bourgogne, Savoie, Ardèche, France..

Occupation: Photography and Virtual tours

  • Send private message

3

Sunday, March 11th 2018, 10:46pm

Thank you Scott!! It works for me! *thumbsup*

Last thing, do you know how to disable the handcursor on a scene? It seems the handcursor="false" works only on plugins..?

Thank you!!
xavier

Scott Witte

Intermediate

Posts: 270

Location: Milwaukee, WI USA

Occupation: Professional Photographer

  • Send private message

4

Sunday, March 11th 2018, 10:56pm

Last thing, do you know how to disable the handcursor on a scene?

I just place a container layer over the scene, width="100%" height="100%" bgcolor="0x000000" bgalpha="0.02" bgcapture="true" capture="true" handcursor="false". Place this under any elements that you want to interact with by using zorder.

bazaar

Trainee

  • "bazaar" started this thread

Posts: 57

Location: Bourgogne, Savoie, Ardèche, France..

Occupation: Photography and Virtual tours

  • Send private message

5

Sunday, March 11th 2018, 11:19pm

Thank you so much Scott!
So nice!
Thank you!