You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, March 22nd 2018, 12:22am

Black screen with no pano image in Google Chrome MacOs

It seems like this affects only macOs at least I tried on windows Chrome with no trouble or black screen.

the google chrome version that i have is Version 65.0.3325.162 (Official Build) (64-bit) and downloaded chromium to see if the problem persisted , and it does at least in this version: Chromium Version 67.0.3378.0 (Developer Build) (64-bit)

The black screen is also happening in all of the examples at the krpano site. The interface and maps do appear only the loading shows up and finishes but leaves a fully black pano image.

I assume that there is a problem with WebGl?

if chrome is forced to ?flash=only there is no problem or black screen

Klaus, can you confirm this?

Any idea or solution?

Thanks!
cmorgan has attached the following images:
  • Screen Shot 2018-03-21 at 6.20.31 PM.png
  • Screen Shot 2018-03-21 at 6.20.05 PM.png

2

Thursday, March 22nd 2018, 10:53pm

Hi,

Klaus, can you confirm this?

No, I can't confirm a problem.
My test macs are working fine.

But yes, when only the pano is black it looks like a core WebGL browser problem.

Please run this page in your Mac Chrome and make a screenshot of it:
https://browserleaks.com/webgl

and additionally also a screenshot of 'About this Mac' => 'System Report' => 'Graphics/Display' page.

With that information it should be possible to make a research about Chrome and GPU-chipset related problems.

Best regards,
Klaus

3

Wednesday, June 6th 2018, 4:33pm

Hello Klaus,
I'm facing exactly the same problem as described above...
Here are the screenshots you asked for.
I add I just updated to pr16, assuming that might be the problem, but with no result.
Thanks in advance for your help !
Olivier
koala has attached the following images:
  • Capture-d’écran-2018-06-06-à-16.22.32.png
  • Capture d’écran 2018-06-06 à 16.24.45.png

4

Wednesday, June 6th 2018, 5:27pm

Hi,

according to your screenshot there is no WebGL support on your system in Chrome.

That's already strange and probably also explains the not working CSS3D graphics...

Sorry, but that has nothing to do with krpano itself and can't be solved from there.

Something between Chrome and your system is broken regarding graphics support.
It might be related to the Intel HD 3000 GPU, I'm not sure, but I think I've read somewhere that Chrome doesn't support that GPU anymore.

You could try running Chrome with disabled GPU blacklisting - enter this url in Chrome:
chrome://flags/#ignore-gpu-blacklist
and enable the 'Override software rendering list' / 'ignore-gpu-blacklist' setting.

If that doesn't work, another browser like Firefox or Safari or an newer system would be the next options...

Best regards,
Klaus

5

Wednesday, June 6th 2018, 5:37pm

Thanks for your quick reply Klaus !
Enabling the 'Override software rendering list' device didn't work...

According to you, downgrading to an old older version of Chrome may help ? (it worked on desktop with 65 for instance, but still there was this gyro saccades problem on mobiles though...)

6

Wednesday, June 6th 2018, 7:31pm

According to you, downgrading to an old older version of Chrome may help ?
Maybe, it depends on your system...

(it worked on desktop with 65 for instance, but still there was this gyro saccades problem on mobiles though...)
Using and older Chrome version on your desktop shouldn't affect the gyro usage on your mobile.

7

Wednesday, June 6th 2018, 10:02pm

...


The strange thing is that it doesn't work on Opera either....

8

Wednesday, June 6th 2018, 10:23pm

Opera is basically the same as Chrome - same browser engine - so that's not that strange.

9

Thursday, June 7th 2018, 10:55am

Thank you Klaus for your help ! It finally worked after so many uninstall/reinstall and parameters combinaisons that I can't remember... showing my level...
but basically, it only works on my system when enabling 'Override software rendering list' / 'ignore-gpu-blacklist' option (both on Chrome 67 and Opera 12.16).
According to you, is that only the case because of the "age" of my system ?