You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Fernando

Intermediate

  • "Fernando" started this thread

Posts: 222

Location: Habana, Cuba

Occupation: Architect, Photographer.

  • Send private message

1

Thursday, April 12th 2018, 11:31pm

Report of Testing 1.19-16 Gyroscope issue.

Hi, this test was made with a phone with real gyroscope sensor.
Android version 4.4.4

Firefox 34: work fine (but not FS)
Chrome 39: work fine, Full Screen OK.
Chrome 47: work fine, Full Screen OK.
Chrome 63: the gyro only work for tilt

Best regards,
fernando

This post has been edited 2 times, last edit by "Fernando" (Apr 16th 2018, 2:45am) with the following reason: To update info of others browsers tested,,,


2

Saturday, April 14th 2018, 9:13pm

Hi,

sorry, not sure what you mean...
What exactly is the problem in 1.19-pr16 with the gyroscope?

Basically nothing has been changed there, except:
  • the workarounds for the Chrome 65 bugs - and these workarounds (using the setting sensor=0 by default) only get applied to the Chrome 65 browser of course
  • and except the radians/degree change for Chrome 66 and higher - and that also only get applied to that Chrome versions
More information here:
krpano 1.19-pr15 / pr16

And I can say the gyro is working on ALL my test-devices: several iPhones and iPads, S3, S5, S7, S8, Note4, LG G3, Nexus9, Amazon Fire 8 and some more...

Best regards,
Klaus

Fernando

Intermediate

  • "Fernando" started this thread

Posts: 222

Location: Habana, Cuba

Occupation: Architect, Photographer.

  • Send private message

3

Monday, April 16th 2018, 12:55am

What exactly is the problem in 1.19-pr16 with the gyroscope?
Hi, Klaus. The problem report is for 1.19-pr16 with Chrome 63 for Android. The panorama when the gyro was activated, only can move vertically, which happens when there is not a real gyroscope sensor. I checked that the sensor existed and then installed an old chrome version in the mobile (Chrome39). With this old version, with the gyro activated, the panorama It works normally: You can see in any direction, not only in the vertical direction.

And I can say the gyro is working on ALL my test-devices: several iPhones and iPads, S3, S5, S7, S8, Note4, LG G3, Nexus9, Amazon Fire 8 and some more...
Did you try this with chrome 63 for Andoid? My device is Motorola Droid mini. Android 4.4.4

Note: I have unfortunately lost Chrome's apk 63, to substitute for Chrome 47, I forgot to make a back up copy. But I only tried chrome 63 with the version 1,19,16. I have not meant that it run ok on another previous version of krpano. I had not tried that before because he did not have cellular phone with real gyroscope.

Best regards, Fernando

This post has been edited 1 times, last edit by "Fernando" (Apr 16th 2018, 2:28am)


4

Monday, April 16th 2018, 7:10pm

Maybe the Android version (4.4) is too old...

It works that way: krpano => depends on the browser => the browser depends on the system => and the system depends on the device drivers (and the available sensors of course)...

Only slow vertical movement means - no gyroscope data! (for what reason whatever)

The horizontal movement and the quick movements are calculated using the gyroscope data, but the 'stabilization' (leveling and rolling) from the accelerometer sensor. So without gyroscope data only a slow leveling is happening...

Best regards,
Klaus

Fernando

Intermediate

  • "Fernando" started this thread

Posts: 222

Location: Habana, Cuba

Occupation: Architect, Photographer.

  • Send private message

5

Monday, April 16th 2018, 8:14pm

Thanks very much for your fast and clear answer!!!
Best regards,

Fernando