Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 14. April 2018, 16:49

How to block scrolling?

I have a task to embed the tour into website. So, the problem is that the tour cover 90% of the visible part of the site page and doesn’t allow to scroll the website. I need to turn off the panorama reaction to any scrolling (zoom) actions. However, panorama rotation should be preserved. Setting FOV min and max to the equal value doesn’t work. How can I disable zoom in panorama?

2

Samstag, 14. April 2018, 21:34

Hi,

set the 'mwheel' and optionally also the 'capturetouch' embedding settings to false:
https://krpano.com/docu/html/#mwheel

Best regards,
Klaus

3

Sonntag, 15. April 2018, 11:27

It is very unobvious for me where to set the value "false" in the .js file. Can you help me please?

Best regards, Alex
»Alex_U« hat folgendes Bild angehängt:
  • 7.jpg

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Alex_U« (15. April 2018, 11:55)


4

Montag, 16. April 2018, 19:13

Hi,

that's a setting for the embedding code in the html file (see the documentation link above)!
That means no editing of any .js or .xml files.

Look in the .html file for:

Source code

1
embedpano({...});

and change it to:

Source code

1
embedpano({..., mwheel:false, capturetouch:false});


Best regards,
Klaus

5

Montag, 16. April 2018, 22:17

Klaus, Many thanks! I figured it out!