Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 6. Juli 2018, 06:37

Unable to trace/find error for the krpano.webGL.createPostProcessingShader()

Hi there,

I did a couple of searches and couldn't find anything about the issue I'm encountering, so hopefully I'm not duplicating this issue. I'm currently building a plugin that loads GLSL code dynamically (from an XML file) and runs the shaders in krpano for use within the viewer. On a whole everything is working correctly, however I'm having an issue with a particular GLSL shader I'm trying to load in. Normally when I use THREE.js and it tries to compile the GLSL code I input, it'll provide an error saying where the GLSL code isn't well-formed, however, I'm unable to retrieve any of the logs or errors relating to the issue.

This leaves me with the krpano.webGL.createPostProcessingShader() method returning null and not knowing why it failed.


I've set the <krpano showerrors="true">, but I'm not sure if there is another setting I need to be using to see deeper to trace the error.

Any help would be greatly appreciated!

Thanks

2

Freitag, 6. Juli 2018, 08:26

Ok so I found the issue, silly mistake on my part.

<krpano showerrors="true" debugmode="true">

Turning on debug mode allowed me to the see errors and thus resolve the GLSL code issues.