Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: krpano.com Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Scott Witte

Fortgeschrittener

  • »Scott Witte« ist der Autor dieses Themas

Beiträge: 212

Wohnort: Milwaukee, WI USA

Beruf: Professional Photographer

  • Nachricht senden

1

Sonntag, 5. August 2018, 18:57

Architectural View in WebVR

Howdy Klaus,

When a scene's architectural view is set, say to 1, the view shifts weirdly in VR mode. You would never want it in VR even if you really want it in non-VR. But to have that I have to add code to set architectural to 0 in VR mode and return it to whatever it was when not in VR mode. That can get complicated. Wouldn't it make more sense for KRPano to automatically disregard view.architectural in VR mode?

2

Sonntag, 5. August 2018, 23:05

Hi,

hmm... but the WebVR plugin is already setting view.architectural to 0 every frame...
(and additionally also doing a backup and restore of the setting when entering or leaving the VR mode, also for several view settings)

So... are you sure that this is the problem...?

Best regards,
Klaus

Scott Witte

Fortgeschrittener

  • »Scott Witte« ist der Autor dieses Themas

Beiträge: 212

Wohnort: Milwaukee, WI USA

Beruf: Professional Photographer

  • Nachricht senden

3

Montag, 6. August 2018, 01:56

Hmmmm. Just to be sure I made a test with the distribution version of pr16 and... No problem. But with my modified template, the problem exists. I see more debugging in my near future.....