You are not logged in.

Dear visitor, welcome to krpano.com Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, September 25th 2018, 5:28am

krpano in embedded browser component

Hi!


I'm doing some experimenting in embedding the krpano html5 viewer in a desktop app, so not in a traditional browser window, but in a compact browser component used as part of a desktop application.
I was intenting to use the makescreenshot api, but unfortunately I found that the krpano.webGL is undefined. I'd think it's simply because this browser component doesn't have webgl capabilities, but that is not true, first if I open https://get.webgl.orgit shows that I do have webgl functionality, and also if I open the debug window it says "INFO: HTML5/Desktop - Chrome 67.0 - WebGL" so it seems there is WebGL capability just fine.

My embedding parameters are also ok, html: "webgl+only". Any ideas why the krpano.webGL returns as undefined?

2

Tuesday, September 25th 2018, 4:29pm

Hi,

Any ideas why the krpano.webGL returns as undefined?
The only possibility that I could currently image is that the krpano version would be way too old...
But for using the makescreenshot api it should be at least krpano 1.19-pr15 anyway...

So no real idea...
I would say something in your example setup is wrong...

Best regards,
Klaus

3

Wednesday, October 10th 2018, 3:08am

I am using the latest, PR16 version.

Following up on this case I did a little test, opened a page capable of detailing some of the capabilities and limitations of the actual browser in this particular embedded browser module.

You can view the results here: http://html5test.com/s/a6248640748a8445.html

Anything that might give a clue as to why it's returning null for the krpano.webgl?


Or any other idea/suggestion on what should I test further? Like I mentioned earlier, get.webgl.org tells me I have webgl (as does the html5test site), and I'm using the latest krpano version. Something's fishy here :)


EDIT: I actually tried loading the makescreenshot example from here on krpano.com into the browser module and everything works fine there. Very strange, now it's a matter of me trying to find out what is the difference between your example and my code...

This post has been edited 1 times, last edit by "webseta" (Oct 10th 2018, 12:35pm)